Graphics
Intel® graphics drivers and software, compatibility, troubleshooting, performance, and optimization
20728 Discussions

Intel GMA965 Half-Life 1 and Source engine FPS issues

idata
Employee
5,582 Views

Hello,

I've got the newest drivers, and I'm running Vista. Anyway, I'm trying to play the original Counter-strike off Steam. When I start playing, everything seems fine, but then I turn on the in game flash light, and the FPS drops down to under 14. Using Opengl mode.

And if i try to start playing using D3D mode, fps dropping horribly in big area or if any color text appear (amxmodx texts).

I think it is bug in actual drivers.

Next problem I have is with Source engine.

If any smoke appear in Half-life 2 game, fps dropping horribly and game become choppy.

Can anybody help me?

I think game counter-strike is very, very old and popular, I need it, because I own portal with counter-strike and need to be admin on it.

PS: Sorry for my English

0 Kudos
8 Replies
ROBERT_U_Intel
Employee
2,818 Views

Hi

I have a few of questions regarding the issue you are seeing.

1. What version of the graphics driver are you using?

2. How much memory is in your system?

3. What patch level is the game at?

4. Do you have Windows Vista* SP1 installed?

Thanks

Robert

* Product and vendor names are copyrights/trademarks of their respective companies.

0 Kudos
idata
Employee
2,818 Views

1. version is 7.15.10.1666

2. I have 3GB RAM 667Mhz.

3. Latest patch from Steam (protocol v48).

4. Yes, i have SP1 installed.

0 Kudos
ROBERT_U_Intel
Employee
2,818 Views

Thanks for the additional information. What are the graphics settings you are using for the game?

Also,, I found a very good write up on playing Halflife based games and improving performance with the Mobile Intel® 965 Express Chipset Family. Here is a link to the blog with the write up . http://intelintegratedgaming.blogspot.com http://intelintegratedgaming.blogspot.com

Hope this helps.

Robert

0 Kudos
idata
Employee
2,818 Views

In Half-life, I tried all resolutions from 640x480 16bit to 1280x800 (wide screen) to 32it. But problem still remains.

In Source engine same and also all from low details to high.. But issue with smoke still remains too.

IMHO maybe there is problem with driver, like bad fill rate.

Regards

dog.big

0 Kudos
ROBERT_U_Intel
Employee
2,818 Views

Were you able to try any of the suggested tweeks on http://intelintegratedgaming.blogspot.com/ http://intelintegratedgaming.blogspot.com to see if they resolve the issue?

0 Kudos
idata
Employee
2,818 Views

Also tried..

I have reinstalled windows.

I am geting mad, because issues still remains.

please help

0 Kudos
ROBERT_U_Intel
Employee
2,818 Views

I will do some additional investigation and see what I can find.

Thanks

Robert

0 Kudos
Daniel_INTELCR
Employee
682 Views
0 Kudos
Reply