Graphics
Intel® graphics drivers and software, compatibility, troubleshooting, performance, and optimization
20728 Discussions

Intel HD 520 - Screen Flashes Constantly

Ptuga88
Novice
4,166 Views

Hi

Recently I noticed that whenever I removed the laptop from charging (battery mode) the display kept blinking constantly.
So , I deduced that it could be the a battery problem , so I ordered a new battery exactly the same as the original one .

However , the same happens with the new battery so I can deduce that it may be related to the graphics chip . I did the test and projected the computer image to an external monitor and even without the charging cable, the problem does not happened.
I've already tried to uninstall the Intel HD 520 drivers and install through Windows update, but the same thing happens.
However, I notice that when I lower the brightness of the screen, the blinking is less frequent.
Could you help me with this ?

Thanks in advance everyone
Ricardo

0 Kudos
12 Replies
AlHill
Super User
4,133 Views

Sounds like the laptop needs a bios update.

 

Doc (not an Intel employee or contractor)
[Maybe Windows 12 will be better]

0 Kudos
Ptuga88
Novice
4,123 Views

Hi AlHill , thnks for your reply .
I also tought about it also , but I don’t know how to do it .
Can you please Help me ?

can you please check my bios details in attach ?

0 Kudos
AlHill
Super User
4,118 Views

You will need to contact the laptop manufacturer for help with their BIOS.

 

Doc (not an Intel employee or contractor)
[Maybe Windows 12 will be better]

0 Kudos
Ptuga88
Novice
4,079 Views
Hi
I think the problem it’s on Intel hd 520 graphic drivers .
If I’m run the windows in safe mode the problem never happens . And then I tried to run DDU software in safe mode (to uninstall completely the drivers) and then I run the windows back in normal mode , and it works ok…and then , few minutes later (after the windows update install the last drivers 30.0.101…) the problems occurs again instantly !
I’ve tried some old versions of the drivers and install them manually and no success…the problem always comes alter the controls drivers instal 😕
0 Kudos
DeividA_Intel
Employee
4,032 Views

Hello Ptuga88,  

  


Thank you for posting on the Intel® communities. I am sorry to know that you are having issues with your Intel® HD Graphics 520.

  


In order to better assist you, please provide the following:  


1. Run the Intel® System Support Utility (Intel® SSU) to gather more details about the system.  

2. Does the issue appear with the laptop manufacturer drivers?

3. Did you notice this issue after a system update?

4. Can you take a short video where we can see the issue? 


  

Regards,  

Deivid A. 

Intel Customer Support Technician 


0 Kudos
Ptuga88
Novice
4,011 Views

Hi Deivid 

Thanks for your reply .

 

1 - In attach , I've sent you the Detailed View of my laptop. 

 

2. Does the issue appear with the laptop manufacturer drivers? 

     No ! If I uninstal the Intel Graphic drivers ( 30.0.101.1660 ) , the Windows will detect my 520 HD as a "microsoft basic display driver" with 10.0.19041.869 drivers and the problem wont shows up , until the Windows Update update this graphic card for the Intel latest version  ( 30.0.101.1660 ) . I've tried some old Intel drivers as "24.20.100.6286" and others...and the problem always happen. 

 

3. Did you notice this issue after a system update?

    Im not sure . However , on Windows Safe Mode the problem never happens. 

 

4. Can you take a short video where we can see the issue? 

   Sure  .   

 

DeividA_Intel
Employee
4,010 Views

Hello Ptuga88, 



Thanks for the information provided. Based on your report and your video seem that your laptop is not compatible with the Intel driver (Generic drivers). The laptop manufacturers can limit or restrict their units to only support their own drivers (in this case from Topstar) since those are customized for their units. 


In this case, I recommend you to check with the place of purchase to confirm for proper drivers and information about the manufacturer (Topstar) since I was not able to find much information about this manufacturer online.


As of the moment, I would like o to confirm the following:


1. When did the issue start? Was it out of the box or after some time using it?

2. Did the laptop work properly before?

3. When did the issue start?

 

 

Regards,  

Deivid A.  

Intel Customer Support Technician 


0 Kudos
Ptuga88
Novice
3,935 Views

1. When did the issue start? Was it out of the box or after some time using it?

     I realized about  this issue about 1 year ago  . But once I using it in charging mode most of the time , I've been extended it till I buy a new battery last week , because i tought it was a battery problem .

2. Did the laptop work properly before?

      Yes it did .

 

0 Kudos
DeividA_Intel
Employee
3,916 Views

Hello Ptuga88, 


  

Thank you for the information provided 


  

I will proceed to check the issue internally and post back soon with more details. 


 

Best regards, 

Deivid A.  

Intel Customer Support Technician 



0 Kudos
DeividA_Intel
Employee
3,903 Views

Hello Ptuga88, 



I do appreciate your patience on this matter. In order to proceed, please try the following:



1. Can you let me know if the issue appears in the BIOS? (To access the BIOS, check with the motherboard/laptop manufacturer).

2. Disable the Panel Self Refresh setting in the Intel Graphics Command Center by following the steps in How to Enable and Disable Panel Self Refresh:

3. On your IGCC program, go to Displays and lower the resolution to the next setting down:

  • Change the refresh rate to a lower setting.
  • Put the system on full power.

4. Disable Desktop Window Manager:

  • Access the Power User menu by right-clicking the Windows taskbar icon.
  • Select Run.
  • Type “services.msc” into the Run dialog box.
  • Locate Desktop Window Manager Session Manager.
  • Right-click on it and select Stop.
  • Right-click Desktop Window Manager Session Manager again.
  • Select Properties.
  • Under the General tab, modify the start-up type to Disabled.



Based on the steps performed and the information you have provided, this seems an issue with the laptop itself. I recommend you to check with the laptop manufacturer of the place of purchase for a hardware review and replacement if possible.



Regards,  

Deivid A.  

Intel Customer Support Technician 


0 Kudos
Ptuga88
Novice
3,883 Views

1. Can you let me know if the issue appears in the BIOS? (To access the BIOS, check with the motherboard/laptop manufacturer).

     No , it works ok in the BIOS 

2. Disable the Panel Self Refresh setting in the Intel Graphics Command Center by following the steps in How to Enable and Disable Panel Self Refresh:

       I've tried befone , nothing changed . As soon as i unplug the connector, it starts blinking.

3. On your IGCC program, go to Displays and lower the resolution to the next setting down:

  • Change the refresh rate to a lower setting.
  • Put the system on full power.

        I've tried befone. Tried 40hz and 60hz with max performance with power saving disabled. 

 

4. Disable Desktop Window Manager:

  • Access the Power User menu by right-clicking the Windows taskbar icon.
  • Select Run.
  • Type “services.msc” into the Run dialog box.
  • Locate Desktop Window Manager Session Manager.
  • Right-click on it and select Stop.
  • Right-click Desktop Window Manager Session Manager again.
  • Select Properties.
  • Under the General tab, modify the start-up type to Disabled.

        Nothing changed about the screen problem.

0 Kudos
DeividA_Intel
Employee
3,865 Views

Hello Ptuga88, 



Thanks for the information provided. Based on the troubleshooting steps performed I recommend you to try a fresh installation of the operating system and if the issue persists try to check with the place or purchase or the laptop manufacturer for a replacement.

 


Regards,  

Deivid A.  

Intel Customer Support Technician  


0 Kudos
Reply