Graphics
Intel® graphics drivers and software, compatibility, troubleshooting, performance and optimization
17458 Discussions

Intel UHD 750 problem with WPF application (.NET Framework 4.8)

daniel-activefloor
723 Views

We have a problem where the picture is not updated in our WPF application (.NET Framework 4.8) when using WriteableBitmaps. My CPU is Intel i9-11900 and I have tried updating the drivers with the automatic update tool, and I have tried the latest beta driver which fixes the hardware acceleration problem in browsers, but none of these drivers solved my problem.

I have verified that my code works as intended on another CPU, an Intel i7-7500U.

I have attached a sample application that illustrates the issue. When the application is run, it displays a blue box and writes Blue in the corner. When you click on any key, it changes the color to red and writes Red in the corner. 

When I run this application on my Intel i9-11900, the Image doesn't change color to red (but it writes Red in the text). When running this on the other CPU, it changes the color and text as expected.

There is another strange thing on the Intel i9-11900: I have two monitors, and if I move the application window back and forth between the monitors then sometimes it will show the red image on one monitor and the blue image on the other monitor when it is moved back.

I have also attached the output from the system diagnostics tool.

 

Best regards,
Daniel

10 Replies
Alberto_R_Intel
Moderator
688 Views

daniel-activefloor, Thank you for posting in the Intel® Communities Support.


In order for us to provide the most accurate assistance on this topic, we just wanted to confirm a few details about your system:

Is this a new computer?

Did you build it?

Was it working fine before with the WPF application?

When did the issue start?

Did you make any recent hardware/software changes?

This problem, does it happen just with the WPF application or there are problems with other applications as well?

If that is the case, please provide the name of those apps.

Does the problem happen at home or in the work environment?


Any questions, please let me know.


Regards,

Albert R.


Intel Customer Support Technician


daniel-activefloor
680 Views

Is this a new computer?

 - Yes

Did you build it?

 - No, I bought it

Was it working fine before with the WPF application?

 - It is a brand new computer, and it never worked with the WPF application. The WPF application works on other computers with different CPU models

When did the issue start?

 - I received the computer May 20th, and that is when I noticed the problem

Did you make any recent hardware/software changes?

 - As it is a brand new computer I have installed a lot of software, Windows updates etc. I have updated the graphics driver using the Intel driver tool, and I have then installed the latest beta graphics driver. The problem exists in all three versions of the driver (the OEM, the updated one, and the beta)

This problem, does it happen just with the WPF application or there are problems with other applications as well?

 - With the updated graphics driver there were many graphics artefacts in browsers. These artefacts were resolved after installing the beta driver, but the WPF problems still exists

If that is the case, please provide the name of those apps.

 - Chrome, Opera

Does the problem happen at home or in the work environment?

 - It is a work computer

Alberto_R_Intel
Moderator
674 Views

daniel-activefloor, Thank you very much for providing that information.


Based on the information showing in the SSU, we can confirm that the graphics driver currently installed is the Intel® Beta Generic GRaphics driver version 27.20.100.9616.


Even though you mentioned that "the problem exists in all three versions of the driver (the OEM, the updated one, and the beta)", we always recommend to install the graphics driver provided by the manufacturer of the computer, since that driver was customized by them to work with your specific platform.


I looked in ASUS's website and the latest graphics driver they have available is version 27.20.100.9127, just to make sure, is that the driver version you already tested?

If not try a clean installation of that driver following the instructions in the links below:

https://www.asus.com/Motherboards-Components/Motherboards/CSM/Pro-B560M-C-CSM/HelpDesk_Download/

https://www.intel.com/content/www/us/en/support/articles/000057389/graphics.html


Also, we suggest to get in contact directly with ASUS to make sure the latest BIOS version is currently installed or to gather the instructions on how to do that, once you get the chance, please let us know the results:

https://www.asus.com/support/


Regards,

Albert R.


Intel Customer Support Technician


daniel-activefloor
634 Views

I have tried installing the ASUS graphics driver, and can confirm that it doesn't work with this either. With the ASUS driver, my WPF problem exists, as well as the problem with graphic artefacts in browsers when hardware acceleration is on.

Could you please try to run the code sample I sent you on comparable hardware so you can see the issue yourself?

Alberto_R_Intel
Moderator
621 Views

daniel-activefloor, Thank you very much for letting us know those results.


We are sorry to hear the issue persists after installing the ASUS driver.


"Could you please try to run the code sample I sent you on comparable hardware so you can see the issue yourself?", we will do further research on this matter, as soon as I get any updates I will post all the details on this thread.


Regards,

Albert R.


Intel Customer Support Technician



Alberto_R_Intel
Moderator
610 Views

Hi daniel-activefloor, I just received an update on this matter.


Just to let you know, there will be a new driver release, version 27.20.100.9664, which is expected for June 11th, 2021, today. Please try a clean installation of that driver and once you get the chance, let us know the results:

https://downloadcenter.intel.com/product/209801/Intel-UHD-Graphics-for-11th-Gen-Intel-Processors


Regards,

Albert R.


Intel Customer Support Technician


Alberto_R_Intel
Moderator
570 Views

Hello daniel-activefloor, I just wanted to check if the information posted previously was useful for you and if you need further assistance on this matter?


Regards,

Albert R.


Intel Customer Support Technician


daniel-activefloor
552 Views

Hello,

Well, the driver you mentioned isn't available on the driver page yet, so there is nothing new. Do you have an updated ETA for the driver release?

daniel-activefloor
549 Views

I have now installed the latest beta driver 30.0.100.9667 and I can confirm that this driver solves my issue with WPF. So I'm looking forward to the official release of this driver.

Alberto_R_Intel
Moderator
538 Views

Hello daniel-activefloor, Thank you very much for sharing those updates.

 

Perfect, excellent, it is great to hear that the problem with the WPF application got fixed after installing the Intel® graphics driver version 30.0.100.9667. 

 

Yes, the official release of the driver will be anytime soon, there is no specific date yet, but it will be released for sure, once the driver is ready I will let you know. You can always keep checking our website as well since where it will be available:

https://downloadcenter.intel.com/

 

Regards,

Albert R.

 

Intel Customer Support Technician

 

 

Reply