Graphics
Intel® graphics drivers and software, compatibility, troubleshooting, performance and optimization
Announcements
The Intel sign-in experience is changing in February to support enhanced security controls. If you sign in, click here for more information.
18291 Discussions

Iris Xe not going above 1280x1024 when using Dell dock

Cenur
Beginner
1,018 Views

Dear Community,

I recently bought some new hardware, but I'm unable to get it working in the intended way. Although my monitor has a native resolution of 1600x1200 I'm unable to select anything higher than 1280x1024. In the past weeks I did lots of tests, both on hardware and on software side. Based on the results my current assumption is that this seems to be an issue of the Intel Iris Xe graphics driver for Windows 10 or an issue with the drivers required by the USB-C / Thunderbolt ports.

I have no idea what to do next. If this is really a software bug, how to get support? If it's not a bug, what am I doing wrong? I would be really grateful for any kind of support in here! I'm really looking forward to finally use the hardware I bought about 2 months ago with its full potential. But I don't know how to get there 😞

Of course more details are required to be able to assess the situation, so here we go:


Short summary
My new hardware is a Dell Latitude 7420 laptop with an Intel 11th Gen CPU and Iris Xe graphics chip + a Dell WD19TBS Thunderbolt dock. In parallel my father bought a Latitude 7520 with a WD19S dock. It's almost the same hardware except for the connection of the dock (Thunderbolt vs. regular USB-C). The described problem occurs with both laptops and both docks in the same way.

I want to connect my existing monitors to the WD19 dock. These are NEC MultiSync LCD 2180UX with a native resolution of 1600x1200 and DVI input. However, I'm only able to select 1280x1024 as highest resolution in Windows, 1280x960 is offered as preferred solution (I guess due to the 4:3 aspect ratio). I have three of these monitors, but even when only one of them is connected to the dock it does not work as expected. For the sake of simplicity I did all tests with just one monitor connected.

I searched the Internet for similar reports. I found only few entries. For some there was no response or solution at all. Some others where related to issues with 4K monitors, wrongly selected refresh rate or wrong cabling (not using DualLink cables for higher resolutions, etc.). Nothing was applicable to my problem.

The monitors are working nicely with 1600x1200 resolution for many years now using my old hardware (see details below) and when checking the Graphics Control Center the EDID of the monitor is correctly read (1600x1200 is listed as supported resolution). Now I'm stuck.


What I tried so far on hardware side

The hardware I got from my employer is a Dell Latitude 7280 and a WD15 dock. In addition to the new WD19 docks I also bought a Dell DA310 portable USB-C dock. And finally there is a Fujitsu DisplayLink Port Replicator (PR08) with regular USB 3.0 (USB-A) connection. Using this hardware I tried out many different combinations. Here are the results:

  • Latitude 7280 with WD15: 2x 1600x1200 working (with HDMI->DVI and miniDP->DVI cables)
  • Latitude 7280 with WD19: 2x 1600x1200 working (with 2x DP->DVI cables)

  • Latitude 7420 with WD15/WD19 and HDMI->DVI cable: only 1280x1024 possible (single monitor connected)
  • Latitude 7420 with WD15/WD19 and (mini)DP->DVI cable: only 1280x1024 possible (single monitor connected)
  • Latitude 7420 with WD15: 2x 1280x1024 is working (but no higher resolution)
  • Latitude 7420 with WD19: 3x 1280x1024 is working (but no higher resolution)

  • Latitude 7420 with DA310 and DP->DVI cable: 1600x1200 working
  • Latitude 7420 with DA310 and HDMI->DVI cable: 1600x1200 working
  • Latitude 7420 with direct HDMI->DVI cable: 1600x1200 working
  • Latitude 7420 with DisplayLink PR: 2x 1600x1200 working (DP->DVI + DVI->DVI cables)

Firmwares of WD15 and both WD19 docks are up to date.
Firmware/BIOS of Latitude 7420 and 7520 are up to date.


What I tried so far on software side

I'm using Windows 10 21H2 with all available updates installed (as found by Windows update + Dell Command | Update).

I tried many different versions of the graphics chip driver:

  • Version 30.0.100.9955 (latest version provided by Dell)
  • Version 30.0.101.1191 (latest version provided by Intel)
  • All older versions provided on the Dell homepage
  • Latest Beta version provided by Intel

Completely removing any installed driver and rebooting resulted in a fallback to the "Microsoft Basic Display Driver". However, at that moment a resolution of 1600x1200 was suddenly possible - but only one monitor was recognized and there was no 2D/3D acceleration. Few minutes later Windows auto-installed the latest Intel/Dell driver (9955) and the resolution switched down to 1280x1024.

I tried to manually add "1600x1200" as resolution in the Intel Graphics Control Center. I was able to add the entry to the dropdown list, but selecting it resulted in an error message and an automatic switchback to 1280x1024.

To make sure this is not related to a bad pre-installation of Windows by Dell, I installed Windows 10 from scratch onto an USB drive (Windows To Go). But there the behavior is exactly the same. It won't go above 1280x1024 when using any of the docks.

I finally booted a live Linux from an USB drive (Fedora 35), and with this running I was able to use 3 monitors at 1600x1200 with the WD19 dock and 2x 1600x1200 with the WD15. This was the final evidence to me that this seems to be Windows/driver related and has nothing to do with the hardware or cabling.

 

Tool output
Since it was requested in several other threads, I attached the reports of multiple tools to this post (Intel SSU, DxDiag and the Graphics Control Center). In some of the reports it's also visible that the monitor(s) are detected with a native resolution of 1600x1200, but I can't see any reason why it cannot be used.

 

I'm looking forwarding to any kind of input on this topic!

Thanks in advance for any help!

 

Best regards,

Cenur

0 Kudos
10 Replies
Alberto_R_Intel
Moderator
1,011 Views

Cenur, Thank you for posting in the Intel® Communities Support.

 

In reference to this scenario, just to let you know, pretty much you already tried all the troubleshooting steps that we recommend for this kind of situation. For us to try to find a possible solution for this matter, first, we just wanted to confirm a few details about your system:

Is this a new laptop?

When did you purchase it?

Were you able, at some point, to use the proper resolution on this specific computer with the proper drivers and the same docking station that you are currently using?

If that is the case, when did the issue start?

Did you make any recent hardware/software changes that might cause this issue?

Which Windows* version are you using?

Does the problem happen at home or in the work environment?

 

Any questions, please let me know.

 

Regards,

Albert R.

 

Intel Customer Support Technician

 

Cenur
Beginner
996 Views

Dear Albert,

 

thanks for your quick reply! Here are the details as requested:

 

This is a new laptop. I bought it in November 2021.

 

I am able to use this new laptop + docking station at the proper resolution, but only when using Linux.

The combination of new laptop + Windows 10 + docking station never worked for me (no matter if new or old docking station).

 

I did not make any recent hardware/software changes, as it is a new laptop.

With my old laptop I can use the proper resolution with both Linux + Windows 10 and with both docking stations (new+old).

 

I'm using Windows 10 (21H2). I tried both the pre-installed version and a completely fresh installation.

 

This problem happens at home, as this new laptop is privately owned by myself.

 

 

Regards,

Christoph

Alberto_R_Intel
Moderator
988 Views

Hi Cenur, You are very welcome, thank you very much for providing those details.


Regarding the docking station, it is important to mention that Intel® does not recommend the usage of docking stations, adapters, or converters since there might be compatibility issues between those products and the computer itself, as you can confirm in the link below. In there you will be able also to see some troubleshooting steps that we recommend to this kind of scenario:

https://www.intel.com/content/www/us/en/support/articles/000026412/graphics.html


If by any chance the problem persists after following those suggestions, then the next thing to do will be to get in contact directly with the manufacturer o of the laptop or with the adapter manufacturer for further assistance on this matter.


Regards,

Albert R.


Intel Customer Support Technician



IainH
Beginner
647 Views

Er, you don't recommend the use of docking stations? So with most laptops simply having USB-C now, how is anyone expected to connect their laptop to one of more screens without a docking station? It's now the starting point for most peripheral connection to modern laptops

n_scott_pearson
Super User Retired Employee
629 Views

Yea, @IainH, and that also represents the starting point for *so* many of the problems. The issue is that half the dongles/hubs/docking stations out there are *absolute garbage* - and that includes from the major vendors, who regularly oversell the capabilities of their components. Intel thus requires that you demonstrate that your problems will still occur without these items being in the picture. For the more complex issues that only occur when multiple devices are connected and/or resources are being shared, the onus is going to be on you to prove first that the dongles/hubs/docking stations are NOT responsible for the problem. You simply cannot expect Intel to have examples of every single one of these components on hand and support the *huge* validation matrices that would be necessary to include them all. This would raise the cost of everything to ridiculous levels. No, Intel is not responsible for debugging every piece of crap that is out there.

I also contend that, in the cases involving dongles/hubs/docking stations that come from the majors (including Dell), *they* should be validating *their* devices to work properly, not waiting for the problems to occur and then dumping you off on Intel as they so often do. They have escalation paths into Intel that have a much, much higher priority, based upon sales volumes, than little old you coming here, by yourself, with an issue. Do you know that, in the case of laptops, you have absolutely no warranty of any kind from Intel for any of the Intel components used? Your warranty is *exclusively* from the laptop vendor - and it is the laptop vendor that *should* be providing the support. Their excuse is that it is 'usually' caused by Intel's drivers. True or not (ok, usually true; Intel's drivers are a dumpster fire), but so what? Again, they should use their escalation paths and their priorities to get a solution quickly, not dump off individuals at Intel's site.

I rant, but I hope I have covered the issue,

...S

P.S. My opinions are my own. I don't work for Intel (well, not any longer; I am retired) and am not compensated by them.

IainH
Beginner
619 Views

Yes I understand all that Scott, BUT...  The majority of laptops these days have no native video out port (HDMI, DP or other), only USB-C. Meanwhile many screens, and certainly ones more than a few years old, have only HDMI/DP/VGA input. Consequently there is no option but to need 'some device', e.g. a base station, to link the two together. How otherwise is someone going to connect the HMDI-in screen to a USB-C out laptop?

So while you might think many base stations are junk and oversold, the fact remains they are now a necessity simply to be able to connect the laptop to the screen. It's therefore 'a little odd' to to not support what is a mandatory intermediary between laptop (and graphics driver) and screen seems, albeit I quite see the issues.

In my own case I have an Dell 9360, HP 840 G6 and a new G8. They all drive a Dell 1920x1080 + older 1600x1200 panel via a WD15 base station...

  • The 9360 drives all 3 fine at their native resolution
  • The G6 drives all 3 fine at their native resolution
  • The G8 drives the 1920x1080 fine, but despite seeing a 1600x1200 resolution on the second panel, will only drive it as 1280x1024 although says it would prefer 1152x864

The 9360 and G6 both use the Intel UHD Graphics 620, the G8 switches to use Iris Xe Graphics. So that "absolute garbage" WD15 base station is just fine when driven by Graphics 620. The issue with the 1600x1200 only occurs with the G8 and Xe Graphics.

So I can indeed validate that the base station, 'garbage' or not, is quite happy to drive the panels properly and indeed does so when I swap laptops I'm working with, the issue is isolated to the Xe graphics. That all makes a pretty compelling case that the issues is with Xe ... unless it is something about the G8 hardware.

n_scott_pearson
Super User Retired Employee
613 Views

Yes, it's true that, to simply *use* the port, you need some kind of component (dongle, hub or docking station). The problem is that there are so many of these components out there (and more appearing literally daily) that Intel cannot keep up with or test them all and, when a problem appears, Intel likely does not have samples of these components with which to test the issue.

In your case, it would appear that the graphics channel from the G8 does not have the bandwidth to support these two monitors - and that is why the second monitor detected is not able to use its highest resolutions. I do not know what processor you have in this G8 nor do I know whether we are talking about a USB-C port in this G8 that supports Thunderbolt 3/4 capability or only an anemic USB capability. If it is only USB and this WD15 is also supporting USB devices, then the bandwidth of the DisplayPort channel is cut in half. If this is only a DisplayPort 1.2 channel, this would explain why the second monitor cannot be supported at its higher resolutions.

So, the questions becomes: What processor is in this G8? What capabilities is the G8 offering at this USB-C connector?

...S

IainH
Beginner
604 Views

Thanks for the further explanation Scott 🙂

  • G8 cpu is 11th gen i7-1165G7 showing 8 cores, which I presume is 4 cores hyperthreaded
  • Port is Thunderbolt™ 4 with USB4 Type-C® 40Gbps signaling rate (USB Power Delivery, DisplayPort™ 1.4) ... specifically port 4 on page 2 of ... https://www8.hp.com/h20195/v2/GetPDF.aspx/c06969201.pdf

The G6 and Dell 9360 are both about 3+ years old. Both are also i7 (I'd have to check processor model), but the G8 is pretty well spec-ed machine, circ $1,500, so it's not a bargain basement i3 or anything. The WD15 must have enough grunt on the basis both of the older machines can use it to drive both panels, it's just the newer more powerful G8.

n_scott_pearson
Super User Retired Employee
596 Views

Hhmmm... The G8 is beyond all of the others in capabilities. The WD15 is only USB and only DisplayPort 1.2, and it does encounter the USB channel issue, which drops throughput to only 4K@30Hz -- but that should be sufficient for the two displays in question to be connected. I am not sure what to think. Intel Customer Support (@Alberto_R_Intel?) will have to look at this.

...S

IainH
Beginner
581 Views

Thanks Scott.

From my simply Googling, I found numerous people will Dell, HP and other laptops and the common element was always Xe, so it seemed to be a 'feature' of the driver, but you know far more about these things than I do. Thanks for your help 🙂

Reply