Graphics
Intel® graphics drivers and software, compatibility, troubleshooting, performance and optimization
17789 Discussions

Missing display updates with Intel Iris XE

EckartRS
Beginner
1,047 Views

In our WPF application we have an update problem, which only appears on PCs with the Intel Iris XE graphics card. 

In the application there is an animation done by the use of a System.Windows.Media.Imaging.WriteableBitmap, attached to a System.Windows.Controls.Image as "Source"

 

NO display update is seen on PCs with the Intel Iris XE graphics card, while it works well with other PCs. An update ist only seen, when for e.g. the window is resized.
Looks like a driver problem, but we already installed the most recent display driver.

 

examples according to  https://docs.microsoft.com/de-de/dotnet/api/system.windows.media.imaging.writeablebitmap?view=net-5....

 

m_myWriteableBitmap.WritePixels(UpdateRegion, m_PixArray, 4 * 100 /* stride */, 0 /* offset */);

does not lead to the expected display update.

A full test project is attached

 

Thanks very much for any hints

Eckart

Labels (1)
0 Kudos
1 Solution
DeividA_Intel
Moderator
992 Views

Hello EckartRS, 



Based on the information provided, please try the following:



1. Take a picture/video of the issue.


2. Update your Windows version.


3. Check for BIOS updates.

- https://www.dell.com/support/home/en-us/product-support/product/latitude-14-7420-2-in-1-laptop/drive...


4. Try a manual installation of the Intel driver. 

- Driver: https://www.intel.com/content/www/us/en/download/19344/intel-graphics-windows-10-windows-11-dch-driv...

- Steps: https://www.intel.com/content/www/us/en/support/articles/000057389/graphics.html


5. Have you reported this issue with DELL?





Regards,  

   

Deivid A. 

Intel Customer Support Technician 


View solution in original post

7 Replies
DeividA_Intel
Moderator
1,024 Views

Hello EckartRS,  

  


Thank you for posting on the Intel® communities.   

  


In order to better assist you, please provide the following:  


  


1. Run the Intel® System Support Utility (Intel® SSU) to gather more details about the system.  


· Download the Intel® SSU and save the application on your computer: https://www.intel.com/content/www/us/en/download/18377/25293/intel-system-support-utility-for-window...  


· Open the application, check the "Everything" checkbox, and click "Scan" to see the system and device information. The Intel® SSU defaults to the "Summary View" on the output screen following the scan. Click the menu where it says "Summary" to change to "Detailed View".  


· To save your scan, click Next and click Save.  



2. Is this issue recent? If so, when did it start?


3. Does the new version appear in the device manager?


4. Did you receive any kind of errors? If so, which ones?


5. Can you take pictures/videos of the issue?


6. What is the full name of the app/tool that you are using?


7. Can you share any extra details of the issue?




Regards,    


Deivid A. 

Intel Customer Support Technician 


EckartRS
Beginner
996 Views

Thank you very much.  
1. I have attached the result of the SystemSupportUtility.

2. This is issue is present for at least half a year, probably longer. It appears also on a second systems with Intel Iris XE graphics

4. No errors appear in the software, you only see, that a display update is missing. 

5. A moving diagonal line is expected, but a blank white screen is seen.

6. - 7.  the simplified app is attached (WpfAppDynamicImages.zip), which contains code snippets from MSDN

Thank you very much

DeividA_Intel
Moderator
993 Views

Hello EckartRS, 



Based on the information provided, please try the following:



1. Take a picture/video of the issue.


2. Update your Windows version.


3. Check for BIOS updates.

- https://www.dell.com/support/home/en-us/product-support/product/latitude-14-7420-2-in-1-laptop/drive...


4. Try a manual installation of the Intel driver. 

- Driver: https://www.intel.com/content/www/us/en/download/19344/intel-graphics-windows-10-windows-11-dch-driv...

- Steps: https://www.intel.com/content/www/us/en/support/articles/000057389/graphics.html


5. Have you reported this issue with DELL?





Regards,  

   

Deivid A. 

Intel Customer Support Technician 


DeividA_Intel
Moderator
961 Views

Hello EckartRS, 



Were you able to check the previous post and try the recommendations? Please let me know if you need more assistance.   


  


Regards,  


Deivid A.  

Intel Customer Support Technician  


DeividA_Intel
Moderator
941 Views

Hello EckartRS, 


  


We have not heard back from you, so we will close this inquiry. If you need further assistance or if you have additional questions, please create a new thread and we will gladly assist you.  


  


Regards,  


Deivid A.  

Intel Customer Support Technician  


EckartRS
Beginner
885 Views

Thanks for your hints. Unfortunately, this problem does not arise on my place, but at a customer on a different location, so we could not update bios or manual driver installation by now. I will try to get a hardware, that I have direct access to, and do this. 

EckartRS
Beginner
820 Views

Just as update, 

the customer could meanwhile do the installation of drivers from the site

 https://www.dell.com/support/home/en-us/product-support/product/latitude-14-7420-2-in-1-laptop/drive...

 

and this indeed solved the problem

The new  driver of the Intel Iris XE  is  27.20.100.9749  (Date 24/06/2021)  seems to fix it. 

 

Thank you very much

best regards

Eckart

Reply