Showing results for 
Search instead for 
Did you mean: 

Mouse freezing HD630

Jump to solution

Hello,After installing Windows everything is OK. After the automatic installation of the drivers for the HD630 graphics card by Windows update, the problem starts. The problem is the mouse jams when you press the right button on the desktop, or when you turn on the application from the taskbar. The explorer and applications run 5-6 seconds. If I enter the device manager and turn off the HD630, it all gets back to normal on the GTX1050. The only thing that is strange to me is the lack of the ability to increase the GTX1050 resolution and low screen smoothness, despite the latest drivers, so it is not good to use Windows with this graphics card. Hence my request to help determine the cause of problems caused by the new HD630 drivers. <- current driver<br style="color: # 222222; font-size: 16px;"/>I found on your site a newer driver with the date 2/13/2018 but when trying to install, an error pops up that does not support my graphics card ....? here it is written that it supports.P.S. Disabling and enabling HD630 removes the problem for several minutes.HP OMEN 15-ce008nwSSD Plextor 256GB M8PeGN M.2 PCIeThe problem did not occur on the originally enclosed 2.5 "drivePlease help.Regards

0 Kudos
1 Solution

This issue is being discussed /thread/119093 HERE, currently there are no solutions. Welcome to the club!

View solution in original post

3 Replies
Community Manager

Hello kp43h8,



I understand that you are currently experiencing freezing problems when using the HD 630 graphics after the Windows Update.



First I would like to start by saying that we supply generic versions of graphics drivers for general purposes. Computer manufacturers can change the features, incorporate customization, or make other changes to the graphics driver software or software packaging. To avoid potential installation incompatibilities, we recommend that you first check with your computer manufacturer and use the driver software provided. So, if you haven't downloaded the latest graphics driver from HP's website my first recommendation is to do so.



Also, if you do have the latest one from them we can try the one you were trying to install before, however, I need you to download the ".zip file". Please refer to the link below:



After the download, please follow the next steps:



1 - Unzip the file to a designated location or folder.


2 - Right-click Windows Start icon and open Device Manager.


3 - Click Yes when prompted for permission from User Account Control.


4 - Expand the Display adapters section.


5 - Right-click the Intel® graphics entry and select Update Driver Software.


6 - Click "Browse my computer for driver software".


7 - Click "Let me pick from a list of device drivers on my computer".


8 - Click "Have Disk".


9 - Click "Browse".


10 - Access the designated location or folder, and access a folder called "Graphics".


11 - Select the file called "igdlh64" or "igdlh".


12 - Click Open, then click OK, and finally click Next. Drivers are now being installed.


13 - Reboot your computer



I hope this helps.






David V

I uninstalled the old one and I managed to install these here. The problem, however, has not been solved, somewhere on the Internet I came across a solution to the problem. Namely, using ShellExView, disable the Intel graphics settings from the context menu.

As here:

I also tried to enable Intel and disable NVIDIA, however, they are still lagging. Only turning off Intel helps.

The worst thing is that lagging is visible in other places. Folders from the start menu and the application start 3 times longer. It is very visible and cumbersome on the SSD.

I hope u will fix that

Best regards


This issue is being discussed /thread/119093 HERE, currently there are no solutions. Welcome to the club!

View solution in original post