Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Mahlum__Greg
Beginner
117 Views

OpenGL rendering issues with driver version 6861 and above

We have a program that uses OpenGL to display a diagram. Since the release of driver version 6861 the diagram is no longer displaying correctly. We have been able to reproduce the issue on all released drivers since 6861 and none of the drivers currently available prior to 6861.

 

System Setup Information:
-----------------------------------------

System Used: Dell Inspiron 5579
CPU SKU: i5
GPU SKU: UHD 620
Processor Line: U-Series
System BIOS Version:N/A
CMOS settings:N/A
Graphics Driver Version: 6861 or above
GOP/VBIOS Version:N/A
Operating System:Windows 10
OS Version: 1809
API:OpenGL
Occurs on non-Intel GPUs?: No

Steps to Reproduce:
-------------------------------
1. Install diver version 6861 or above
2. Download and extract attached archive
3. Run SliderDemo.exe
4. Open the file savnw.sld
5. Window will appear to be blank, zoom in slightly with [Ctrl + Scroll Down] and distorted view will be visible

Expected Results:
-------------------------------

See image in attached archive labeled expected.png

Actual Results:
-------------------------------

See image in attached archive labeled actual.png

Additional Information:
-------------------------------

This behavior is not observed in any version below 6861

When in GL_SELECT mode, items appear to be placed where they should.

Also does not occur when using the Windows implementation of OpenGL to draw on a bitmap in memory and then bitblt to the screen DC.

0 Kudos
1 Reply
Mahlum__Greg
Beginner
117 Views

Is there any update on this? More and more of our users are running into this issue as they either buy new machines or get updated drivers. We have been advising them to downgrade their driver version for now, but we are beginning to recommend that if they get new machines that they have either a discrete video card from Nvidia or AMD or an AMD processor with integrated graphics, since we have not seen this problem with those vendors. Any information on what needs to be done to fix this issue would be great including anything we can do on our end to mitigate this issue.

Reply