Graphics
Intel® graphics drivers and software, compatibility, troubleshooting, performance, and optimization
20858 Discussions

PCI Memory Controller driver not found

driversaregone
114,686 Views

My pci memory controller driver and SM bus controller driver is not found. I went to PCI lookup and found that the drivers are as the picture seen below but I can not find it anywhere. Can someone help me find the PCI memory controller please!

driversaregone_0-1617634262443.png

if you cant see it then refer to the file below.

That is the largest I can make that. Here are the drivers. If anyone can help me fix the other one too, that will be greatly appreciated.

driversaregone_1-1617634348906.png

 

Labels (1)
0 Kudos
1 Solution
driversaregone
114,629 Views

Ok so I extracted right, I go to device manager and the errors are gone now? I can't find the pci stuff anywhere. The only thing I did was install intel chipset software installer. was that a bad move?

View solution in original post

0 Kudos
21 Replies
driversaregone
111,176 Views
0 Kudos
driversaregone
111,175 Views

but wait, do I just download the latest one?

0 Kudos
Stefan3D
Honored Contributor II
111,157 Views

Yes, sort by date to catch the latest.

Otherwise Windows update will sooner or later suggest to update a driver from 1968 🙄

0 Kudos
driversaregone
111,155 Views

Got it, thanks! And one more thing, after I click download a new web comes up with a link, what do I do there?

0 Kudos
Stefan3D
Honored Contributor II
111,146 Views

Click the CAB file and choose download

unpack it the same way like a ZIP file to a new folder

in device manager select update driver for the messed up device

select have disk

navigate to the download folder and select the INF file

0 Kudos
driversaregone
111,137 Views

I keep clicking it but it wont download anything

0 Kudos
driversaregone
111,132 Views

Ok I got it, now Im gonna need a little more help as I dont know how to unpack it.

0 Kudos
Stefan3D
Honored Contributor II
111,125 Views

A popular unpacker is 7zip

After installation you can right-click a CAB file and select extract to "xxx"

0 Kudos
driversaregone
114,630 Views

Ok so I extracted right, I go to device manager and the errors are gone now? I can't find the pci stuff anywhere. The only thing I did was install intel chipset software installer. was that a bad move?

0 Kudos
Stefan3D
Honored Contributor II
111,104 Views

If the yellow triangles are gone everything is fine.

The devices have different names now, similar to screenshot below

 

stefan133-20210405-173945

0 Kudos
driversaregone
111,102 Views

Nope. It looks like this.

driversaregone_0-1617637335122.png

 

driversaregone_1-1617637399652.png

like that?

0 Kudos
Stefan3D
Honored Contributor II
111,100 Views

Perfect. No yellow triangles anymore.

Device A121 has the official Intel name now.

0 Kudos
driversaregone
111,094 Views

ok, thank you so much for your help!

0 Kudos
AlHill
Super User
111,049 Views

You need to install the MEI (management engine).

If that does not work, So the Intel support engineers can have more information about your system, Download, run, and save the results of this utility as a text file:
https://downloadcenter.intel.com/download/25293/Intel-System-Support-Utility

Then ATTACH the text file using the instructions under the reply window ( Drag and drop here or browse files to attach ).

Doc (not an Intel employee or contractor)

0 Kudos
Childhood_is_over-3
101,467 Views

I have that same issues too idk how to fix it i'm trying to find intel chipset driver to download it

 

Childhood_is_over3_0-1644045346355.png

 

 

 

0 Kudos
n_scott_pearson
Super User
101,414 Views

@Childhood_is_over-3, over 3 what? My kids are well over 3 decades old and they still act like children ;^)

Ok, bad-attempt-at-humor over with, to answer the question for you, we need to know what chipset your motherboard has.

...S

0 Kudos
Vulkany
Novice
65,970 Views

Hello, 
I'm having this issue with the PCI Memory Controller

Vulkany_0-1678625285554.png


I've installed the Intel® Driver & Support Assistant and run it but didn't fix the issue.
I've also run the System Support Utility but when I try to submit the report I get

Vulkany_1-1678625523887.png

Any help would be greatly appreciated.
Thanks

 

0 Kudos
AlHill
Super User
65,963 Views

@Vulkany You need to start a new thread for your issue and provide full information, rather than hijacking an old thread.

 

Doc (not an Intel employee or contractor)
[Maybe Windows 12 will be better]

0 Kudos
Reply