Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Eric_G
Beginner
626 Views

Sofware Cura, Da Vinci Resolve, OpenGL Extension Viewer, ... does not work with Core i7-1065-G7 / Iris Plus Graphics on HP Laptop 15s-fq1xxx

Lastest graphics driver version installed (27.20.100.8187), Windows updated,

laptop HP 15s-fq1xxx

Problems:

  • Cura 4.6 is displaying a white window when starting
  • Da Vince Resolve 16.2.1 (last version) is crashing when starting (bug report windows)
  • Tool “OpenGL ExtensionViewer 5.4.1” is displaying a dark screen when testing (normally should display a rotating cube)

PC has been fully recently reinstalled Following HP support recommendation to this problem (so not solved...)

In attachment, filled form and dxdiag / ssu report

0 Kudos
15 Replies
Stefan3D
Honored Contributor II
511 Views

Try build 8190 (ignore the yellow bar)

 

Since you already ran OpenGL Extensions Viewer, does it expose all extensions up to 4.6 correctly?

 

Try the demos in GPU Caps Viewer 1.44.3.1

Eric_G
Beginner
511 Views

Hi Stefan. Thank you very much for your support.

Build 8190 installed : I still have the problem for the 3 software ;-(

 

With OpenGL Extensions Viewer, all extensions up to 4.6 are passed during test. (for .i.e, 11/11 for 4.6).

For ARB 2015, on 2/12 are passed.

I notice first time I run the test I have a back screen (with no cube). Next tries (without relaunching the viewer), I have the error message : "wglCreateContext failed"

 

With GPU Caps Viewer,

GL3.x, Triangle of Death : OK with 600x600, but KO with 1000x1000

GL 3.x, Illuminated Torus : OK with 400x400, sometimes, but KO 600x600

GL 4.x - Tessellation: KO with 600x600, but OK 300x300

GL 2.1 - soft shadows : KO

GL 2.1 - CEL-SHADING : KO

GL 1.2 - Simple mesh : OK

KO=empty screen

i don't really understand why , but a test which was KO may be OK if it executed after same test with lower resolution.

 

Vulkan tests are all KO

OpenCL : "not supported"

 

 

 

Stefan3D
Honored Contributor II
511 Views

Best thing you can do over the weekend is to roll back to previous driver versions and find out with which driver build the regression started.

 

Unfortunately i have no current iGPU handy to double-check...

Alberto_R_Intel
Moderator
511 Views

EGENO, Thank you for posting in the Intel® Communities Support.

 

I just wanted to check if you were able to test previous Graphics driver versions and if the problem remains after that?

If the issue was fixed, please provide the version of the older Graphics driver?

 

Any questions, please let me know.

 

Regards,

Albert R.

 

Intel Customer Support Technician

A Contingent Worker at Intel

Eric_G
Beginner
511 Views

Hi Albert,

I could downgrade with older versions. I 've an error message like "driver not supported for this computer".

It may be due to Microsoft update ?

I tried with 8141, 7985, 7870, 7755

I don't know if there is any workaround to bypass this check.

 

I tried last beta version 8236, May 12.

I still have the problems:

  • Cura 4.6 is displaying a white window when starting
  • Da Vince Resolve 16.2.1 (last version) is crashing when starting (bug report windows)
  • Tool “OpenGL ExtensionViewer 5.4.1” is displaying a dark screen when testing (normally should display a rotating cube)

Similar results with GPU Caps Viewer

 

I was not expected to face with so many graphic problems.

We bought not a basic laptop, with Corei7 10th gen 8Mo, and Iris Plus Graphic which is supposed to be competitive.

But I still cannot use some softwares such as Cura or video editing system, and so confused.

I hope we'll find a solution...

 

 

 

 

Alberto_R_Intel
Moderator
511 Views

EGENO, Thank you very much for providing that information.

 

In order for us to provide the most accurate assistance, we just wanted to confirm a few details about your system:

Is this a new computer?

Those applications, were they working fine before?

Did you make any recent hardware/software changes?

When did the issue start?

 

Please provide the Intel® Graphics report so we can verify further details about your platform:

https://www.intel.com/content/www/us/en/support/articles/000005848/graphics-drivers.html

 

Regards,

Albert R.

 

Intel Customer Support Technician

A Contingent Worker at Intel

Eric_G
Beginner
511 Views

Hi Albert

The laptop is quite news, bought in 2019 Nov. Following to actions with HP support regarding this problem, it has been fully reinstalled.

I didn't use these software before, so I couldn't say there is a regression.

These software have never worked on this PC.

Graphic problem was firstly detected using Autodesk Fusion 360 which did not work.I did not try to reinstall it since remastoring.

 

Please find graphic report in attachment.

Alberto_R_Intel
Moderator
511 Views

HI EGENO, Thank you very much for sharing theIntel® Graphics report.

 

We will do further research on this matter, as soon as I get any updates I will post all the details on this thread.

 

Regards,

Albert R.

 

Intel Customer Support Technician

A Contingent Worker at Intel

Alberto_R_Intel
Moderator
511 Views

EGENO, I just received an update on this matter.

 

We tried to replicate the issue in our Intel® Lab and the issue was not replicated, we were able to use all 3 applications with no problems, the Intel® Graphics driver worked with no problems. Please let us know if we are missing some steps or if we need to do something differently, please see the results below: 

 

LAB results:

 

1.Environment:

  • NUC6I7KYK.
  • Graphics: Intel® Iris® Pro Graphics 580
  • Driver: 26.20.100.8141

 

CURA 4.6:

Result: White screen when initialization, for 1 second.

Attached: Video, photo.

 

Davinci 16.2.1:

Result: I was able to run the tool without any issue or Windows* Bug.

 

OpenGL ExtensionViewer 5.4.1:

Not able to find or install this version of the software.

I downloaded the latest version 6.0.8.1, version 4.6.0.

The tool ran fine.

 

 2.Environment

  • NUC8I7HVK
  • Driver: 26.20.120001.12000
  • Graphics card: Radeon RX Vega M

 

Cura 4.6: Same behavior, the screen goes white for a second, loading the app, this does not persist. Video attached

 

Davinci 16.2.1:

Result: I was able to run the tool without any issue or Windows* Bug.

 

OpenGL ExtensionViewer 5.4.1:

Not able to find or install this version of the software.

I downloaded the latest version 6.0.8.1, version 4.6.0.

The tool ran fine.

 

Cura 4.6 KYK.png

 

DaVinci 16.2.1 kyk.png

 

OpenGL test KYK.png

We recommend to install the graphics driver provided by the manufacturer of the computer, since that driver was customized by them work with your specific platform. 

I looked in HP,s web site and the latest Graphics driver available is version 26.20.100.7926 Rev.A, please test that driver and let us know the results:

https://support.hp.com/us-en/drivers/selfservice/swdetails/hp-15s-fq1000-laptop-pc-series/29322771/s...

 

A BIOS update to the latest version is also something that we suggest to do to try to fix this problem, the latest version is F.09 Rev.A, please get in contact directly with HP to gather the instructions of how to install it:

https://support.hp.com/us-en/drivers/selfservice/swdetails/hp-15s-fq1000-laptop-pc-series/29322771/s...

 

Regards,

Albert R.

 

Intel Customer Support Technician

A Contingent Worker at Intel

 

Alberto_R_Intel
Moderator
511 Views

Hello EGENO, I just wanted to check if the information posted previously was useful for you and if you need further assistance on this matter?

 

Regards,

Albert R.

 

Intel Customer Support Technician

A Contingent Worker at Intel

Eric_G
Beginner
511 Views

Hello Albert,

Sorry for my late reply. I didn't have access to the laptop.

 

Thank you first of all for all your efforts to help me and to try to solve the problem.

 

The behaviour with softwares you have is OK. It is also the same I have with another desktop PC which have a different graphic card (evrything is OK).

 

I installed the graphics driver you recommend (26.20.100.7926 linked to HP SP sp102131.exe) : I still have the problem.

It is so a downgrad version compared to the one I had before (8190). I'm keeping 7926 for now, but HP upgrade invites me to upgrade to 8190 version

 

I also upgraded BIOS to F09 : I still have the problem.

 

I'm not advanced in graphic hardware, but it seems the HP laptop graphics I have is the family model, but not "Intel Iris Pro Graphics 580" you used for testing.

Do you think I could make the difference ?

Would you have any possibility to test with the same processor ?

Alberto_R_Intel
Moderator
511 Views

EGENO, You are very welcome, no problem at all, thank you very much for providing those results.

 

Regarding your question, if we have the "possibility to test it with the same processor?", we will do further research on your request, as soon as I get any updates I will post all the results on this thread.

 

Regards,

Albert R.

 

Intel Customer Support Technician

A Contingent Worker at Intel 

Alberto_R_Intel
Moderator
511 Views

Hi EGENO, I just received an update on this matter.

 

I just wanted to let you know that we have been unable to replicate the issues you are reporting with Cura, Da Vinci Resolve and OpenGL Extension Viewer.

 

We used 3 different systems featuring:

Intel® Core i7-1065G7 

Intel® Core i5-1035G4

Intel® Core i5-1035G1

The drivers tested were 100.8187 and 100.8190

 

Since we couldn't replicate the issue in our lab it is possible the issue is introduced with an OEM customization. 

So, the next thing to do in this case will be to get in contact directly with HP for them to provide further assistance on this matter, Refer you can always point them to this thread to confirm Intel® couldn't replicate the issues:

https://support.hp.com/us-en

 

Regards,

Albert R.

 

Intel Customer Support Technician

A Contingent Worker at Intel

Eric_G
Beginner
511 Views

Hi Albert,

Thank you for your reply.

I had alrealdy contacted HP support., before lauching this thread. They checked PC configuration (drivers version, BIOS version, ...) . I remastered PC with factory version. Everything was ok for them.

 

I 'll do it again refering this thread.

 

I wonder if I'm not going to sell this PC and by a different model, if the problem still lingers.

 

Best regards

 

Eric

Alberto_R_Intel
Moderator
511 Views

EGENO, You are very welcome, thank you for letting us know those updates.

 

Regarding your question, it is very difficult to know if the problem will persist on a different computer, what we always recommend is to contact the developers of the applications or check the system requirements to make sure the platform that you are using complies with them.

 

Yes, to contact HP directly will be the next thing to get further assistance on this matter.

 

Regards,

Albert R.

 

Intel Customer Support Technician

A Contingent Worker at Intel

Reply