Community
cancel
Showing results for 
Search instead for 
Did you mean: 
JAust7
Beginner
305 Views

Strange bug with anti aliasing. Moving objects smear and window flickers.

First, about my computer. I am currently running Windows 10 (1909) on an Inspiron 15 5000 Series Dell Laptop. My only GPU is the integrated Intel UHD Graphics 620. I have 8 GB of RAM. This problem only seems to occur on my device but I have not been able to test it on another system with the same model or GPU.

 

I made a Fourier Transform program a while back (sometime last April). I wrote it in C++ using SFML 2.0 compiled on VC++ 2010. This is the only image I have of it when it looked normal.programmingclub_beforeproblem.pngI hadn't touched the program in a while but sometime within the past few months, anti aliasing seemed to stop working entirely on my all of my sfml projects. Any level on anti aliasing greater than 0 causes the drawing on the screen to smear (fast-moving objects don't clear completely after telling the window to do so) and the lines to look dotted. In addition, the window seems to flicker between two states. This is the same image above, using the same exact executable and data for the drawing, rendered now:programmingclub_AABroken.PNGIf you want to try to replicate the problem, here is an image (the code snippet option doesn't seem to be working) of some minimal code which will show a line sweeping down the right edge of the screen along with the result on my computer:

minimal_code_and_result.PNGI have ruled out code issue for several reasons: I have not modified the original code, I used an old stable version of a library (SFML 2.0) which has not changed, the same problem occurs when compiled using VS 2017 and the latest version of the library (SFML 2.5.1), and this problem only happens on my computer as far as I've seen.

 

I've been digging for the past few week to see if I could find a setting pertaining to anti aliasing which might fix the problem but with no luck. Unfortunately, I have not noticed this problem occur anywhere else except my sfml projects which confuses me even more.

 

I wasn't sure if this was a problem with Windows, Dell or Intel so this just happens to be the first of the three places that might ask about this issue.

 

Any help is appreciated. Thank you.

Tags (1)
0 Kudos
2 Replies
AlHill
Super User
125 Views

JAust7
Beginner
125 Views

Sorry, I didn't mean to create multiple threads. The other one is not correct. Somehow it must have duplicated when I edited in the image which shows the program when it worked. I get this error when I tried to delete the first thread: "ICS_FeedItem_Trigger: execution of BeforeDelete caused by: System.DmlException: Update failed. First exception on row 0 with id 5000P00000oncF9QAI; first error: OP_WITH_INVALID_USER_TYPE_EXCEPTION, Operation not valid for this user type: [] Class.ICS_FeedTriggerStatusUpdate_Handler.updateCaseStatusOnCommunityFeedItemDelete: line 149, column 1 Trigger.ICS_FeedItem_Trigger: line 81, column 1"

Reply