Community
cancel
Showing results for 
Search instead for 
Did you mean: 
SArmb
Beginner
1,439 Views

Why is the Intel Graphics Control Panel suddenly missing ?

After successful operation with the HD 630, the Intel Graphics Control Panel suddenly disappeared on one of my two system partitions.

I suspect the problem was caused by the installation of the driver 25.20.100.6577.

Manually installing V6519 results in the same problem.

In the logging file I see:

- HW-ID not found

- Vulkan RT not found

It appears that the Intel Graphics Control Panel is deleted, but then it is not reinstalled.

In addition, the "GFxUI.exe" is missing.

On the other partition of the same PC, the Intel Graphics Control Panel works correctly under V6577 !!!

Environment: i7-7700K + W10 Build 17763.348

0 Kudos
17 Replies
AlHill
Super User
587 Views

I installed the DCH driver on six different machines, and in each case when I re-established the network, the graphics control panel was immediately downloaded, and is easily found in the start menu.

 

Doc

 

SArmb
Beginner
587 Views

On my other system I also found the panel in the start menu. But in one system which is not so different to the other it is NOT visible !

AlHill
Super User
587 Views

Have you tried downloading it from the Microsoft store?

 

Doc

 

SArmb
Beginner
587 Views

Sorry, which program do you mean ?

SArmb
Beginner
587 Views

I think you mean the Intel Graphics Control Panel . Found it on the store. Will make a Backup and install it.

SArmb
Beginner
587 Views

Well, I installed it from the MS Store and now its visible in the W10 start menu.

But after starting it there is an error message (see att.) With this message my problems started some time ago. What the devil does this mean ? It can not be a HW problem because my other partition works.

 

SArmb
Beginner
587 Views

Addition: In the enhanced display settings of W10 one can see that my AOC monitor is connected to HD Graphics 630 and the graphics seem to work ("The device is working properly").

SArmb
Beginner
587 Views

After reading my readme files I noticed that a few days ago a RECOVERY of the defective HOME system was done with Acronis. Only the HOME partition was restored + not one of the OEM partitions (see attachment).

 

Is it conceivable that this caused the error message in Intel Graphics Control Panel?

 

If so, that would be a program weakness in the panel software!

I would like to mention that only this software has problems. All other programs work flawlessly.

 

I would be very grateful if a software specialist would voice his opinion.

SArmb
Beginner
587 Views

Now I deinstalled the Intel graphics control panel and the HD630 driver. After a Reboot Windows installed an old V6323 driver for HD630 and after that Intel graphics control panel is useable!!! There are no more error messages.

But when I update to V6577 the error message occurs again !

So IMO this is an Intel problem !

Leonardo_C_Intel
Moderator
587 Views

Hello SArmb Thank you for posting in the Intel Community. 1. Download the latest DCH driver and save it on the computer. 2. Disconnect from the Internet so no new drivers are automatically installed by Windows Update. 3. Uninstall the driver and the Intel Graphics Control Panel from Control Panel > Programs and Features. 4. Restart the computer. 5. Confirm in Device Manager > Video Adapters the controller is listed as 'Microsoft Basic Display Adapter' > if not, repeat steps 2 through 4. 6. If the adapter continues to be listed as ‘Intel HD Graphics’ or similar, and no other Intel Graphics driver is listed under 'Programs and Features' for removal, then it means Windows has switched to a previously installed Legacy driver. At this point we can remove Legacy drivers from Device Manager: • 6.1.1 Right-click on 'Intel HD Graphics' or similar, and select 'Uninstall Device' • 6.1.2 In the pop-up window make sure 'Delete the driver software for this device' is checked. • 6.1.3 Click on 'Uninstall'. • 6.1.4 Restart. (Repeat steps 6.1.1 through 6.1.4 until the device gets listed as 'Microsoft Basic Display Adapter') 7. Install the DCH driver that was downloaded on step 1. 8. Restart the computer. 9. Reconnect to the Internet • Please attach to this thread the TXT file the Intel® System Support Utility will generate: https://downloadcenter.intel.com/download/25293/Intel-System-Support-Utility • Steps to save the report: 1- Run the utility. 2- Click on “Scan” to get the scanned system. 3- Once the scan is complete click on “next”. 4- Use the “save” option, save the report to your desktop. 5- To attach a file, you must click the “Attach” option on the bottom left-hand corner of the response box. Hope this helps. Regards, Leonardo C. Intel Customer Support Technician Under Contract to Intel Corporation
SArmb
Beginner
587 Views

Thanks a lot for your assistance Leonardo,

First let me say that I'm operating at this moment with the HD630 V6323 connected to my main monitor AOC. IGCP creates no error message as described. HMI of HD 630 is useable. Second monitor is connected to NV 660TI.

 

Then I made your instructions except step 3: uninstall not possible because components not existing in Programs + Features. So I uninstalled the HD 630 from device manager with hook on driver software.

Seems to be ok everything so far.

Result:

  • Intel graphics and Control Panel is not installed

another question:

  • I'm using a 4K Monitor AOC Q3277 which is connected to HD630 via DisplayPort 1.2. Looking into the enhanced display informations of W10, I can see a bit deepth of only 8bit, why not 10 bit ?

 

I am looking forward to your diagnosis.

SArmb
Beginner
587 Views

I'm a little surprised, but the red marked components are only installed in the partition with the error. They are NOT installed in the healthy partition.

Leonardo_C_Intel
Moderator
587 Views

Hello SArmb Are you installing the driver/app in 2 different partitions on the same system? And same OS? If yes, why are you doing so? You mentioned you have a defective partition this could be a Hardware issue, could be related to the HHD/SSD. Since it has Hybrid graphics also it could be related to Original Equipment Manufacturer (OEM), in this case it is important to contacting the OEM to confirm why the system is not recognizing the display connected to the DP on the motherboard. If possible provide me with detail steps of how this behavior happened. Hope this helps. Regards, Leonardo C. Intel Customer Support Technician Under Contract to Intel Corporation
SArmb
Beginner
587 Views

Are you installing the driver/app in 2 different partitions on the same system? And same OS?

If yes, why are you doing so?

Yes two different partitions. Using the boot manager to boot into my

  • VIDEO system (only components to work with video software)
  • HOME system. (in addition to VIDEO other components like components for tests and general use)

They have the same W10 release V1809. When booted into one, the system gets ever the letter "C:\". That's a very normal procedure and works since years.

And of course I have to install a component twice if I want to use it in both partitions.

 

You mentioned you have a defective partition this could be a Hardware issue, could be related to the HHD/SSD.

Sorry my terrible english. With "defective" I'm meaning the HOME partition where the error message ".... none displays.... are using Intel...." occurred (As reported by me). No HW problem because both partitions are using the same HW!

 

Since it has Hybrid graphics also it could be related to Original Equipment Manufacturer (OEM), in this case it is important to contacting the OEM to confirm why the system is not recognizing the display connected to the DP on the motherboard

The Intel graphics card is connected to my AOC monitor and the NV card is connected to my Samsung U28E590D monitor. Maybe this calls "Hybrid" ?!

Several years ago I bought this PC from a PC dealer which built it using my wishes. Two years ago I changed the mainboard to ASUS Rog Strix 270F and created an new HOME + VIDEO partition using W10.

When I visit the ASUS homepage there is a very old Intel card publishes which I never want to install. IMO I have no OEM problem because the VIDEO system works without any problems as I said !

 

What about the "Vulkan RT Lib." and "Komponenten der Intel Management Engine" (components of Intel Engine) ? Shall I deinstall them ? Maybe they occurred with a test etc.

 

Leonardo_C_Intel
Moderator
587 Views

Hello SArmb Thank you for the information After reviewing the case I noticed that you uninstalled the DCH graphics driver from device manager instead from apps and features and this as indicated on DHC graphics driver release notes available at the download center may result in a unstable OS. Reference to the download center release notes: WARNING: Failure to follow the guidance below may result in system instability These new drivers labeled as Windows DCH graphics drivers are not backward compatible with our previous graphics drivers that we're now labeling Legacy. This means if later you want to revert to a Legacy driver you will need to uninstall the driver via Windows Apps and Features and reboot the system before installing a Legacy driver. Failure to do so may result in minor to catastrophic issues on your system as well as system instability. Reference link: https://downloadcenter.intel.com/download/28566/Intel-Graphics-Driver-for-Windows-10?product=98909. You can try the following on the system: • Windows restore point previous to driver update. • try to install an older prior to DHC graphics driver for example: https://downloadcenter.intel.com/download/27199/Intel-Graphics-Driver-for-Windows-15-47-?product=989... • New clean OS installation. Hope this helps. Regards, Leonardo C. Intel Customer Support Technician Under Contract to Intel Corporation
SArmb
Beginner
587 Views

Dear Mr. Leonardo C.,

I uninstalled the DCH graphics driver from device manager because in apps and features nothing was installed !

I ever used Intel driver + support assistent to update the HD630 and never installed a legacy driver by myself.

 

Well, now I made a RECOVERY to a build from 28. december 2018 where driver 25.20.100.6471 is installed.

I'm happy to see that IGC Panel ist working fine here without the described message !! 😄

Now I will never update the HD630 driver by myself except W10 will do this.

 

Thanks for your assistance

 

Leonardo_C_Intel
Moderator
587 Views

Hello SArmb I am glad to hear that the system is working fine; yes you can complete the updates for the system trough Windows® update. Hope this helps. Regards, Leonardo C. Intel Customer Support Technician Under Contract to Intel Corporation
Reply