Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
5,649 Views

Windows *7/8/8.1 GFX Driver Version 3412

Greetings everyone!

We have officially launched our latest driver supporting 3rd and 4th Generation Intel® Core™ Processors with Intel® HD/Iris™ Graphics for Microsoft* Windows 7, 8, & 8.1. The version is 3412 and is available at the following locations.

32-bit: Driver Download https://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&ProdId=3723&DwnldID=23638&ProductFamily=Grap... here - Release notes http://downloadmirror.intel.com/23638/eng/ReleaseNotes_GFX_3412_32.pdf here

64-bit: Driver Download https://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&ProdId=3723&DwnldID=23639&ProductFamily=Grap... here - Release notes http://downloadmirror.intel.com/23639/eng/ReleaseNotes_GFX_3412_64.pdf here

Also; http://www.intel.com/support/graphics/sb/CS-033838.htm Windows* 8/8.1 Graphics FAQ.

Please provide only constructive feedback here. Harassing comments, needless insults and personal attacks are not permitted, and will be promptly deleted.

If there are issues that carried over from previous drivers that you are still experiencing, feel free to announce them again here. I'll give a good list here though;

 

  • Some users are still experiencing either black screens OR Code43/31 issues on systems that utilize either 3rd party graphics cards or are using Intel-graphics only systems. If you are still having this issue, please provide that information here alongside an updated dxdiag report, and your system/motherboard model.
  • Sonic & All-Stars Racing* - This game was previously experiencing black screens during game-loading an character-loading. These issues should be resolved with this driver.
  • Netflix* experiencing screen distortion and loss of video/audio quality while being played in 5.1 sound. This issue has not been able to be reproduced internally, and therefore we have been unable to diagnose the issue.
  • Pokemon TCG Online* - This game is experiencing intermittent crashes at random times during game play and menu navigation. This issue has been reproduced internally and we are attempting to diagnose whether this is an application failure or graphics driver failure.
  • Display Audio Loss over AV/R or locally when a system goes to sleep/standby. This issue has been partially resolved. We have released BIOS updates for affected 8 Series boards/NUC's which resolves the issue. For users who are still experiencing the issue on non-Intel manufactured systems/boards, refer to the instructions in this thread;
  • Display Audio Loss over AV/R or locally when a system goes to sleep/standby. This issue is still in the process of being resolved. The resolution is not the same as what we provided via BIOS update for the 8 Series boards/NUC's, so it has not been a simple fix.
  • Low Memory errors. If you are still experiencing this issue with this driver, please provide that information in this thread alongside an updated dxdiag report and Intel Graphics Report.

     

if I have missed any, it is not because we are not aware of them! However, please feel free to remind me of them regardless.

 

If you are having trouble with installing the driver, it can be for various reasons. Most commonly, it is because your system currently has a driver that was installed by your OEM, and those drivers present various error messages to the effect of "this driver is not suitable for your computer because your OEM said so!". If that is the case, you should follow the http://www.intel.com/support/graphics/sb/CS-022355.htm Manual Driver Installation instructions to install your driver (this is prefaced by downloading the .ZIP version of the driver from the links above).

 

<p style="font-family: intel-neo-sans-1, intel-neo-sans-2, tahoma, helvetica, sans-s...
Tags (1)
0 Kudos
33 Replies
Highlighted
Valued Contributor I
120 Views

Driver forced AF is still broken in directx games or is this a feature by design from Intel? Anteworld OpenGL issue is solved by the way.

0 Kudos
Highlighted
New Contributor I
120 Views

Hello nic.

First of all, as an owner of a Pentium G3420 I have to thank Intel for the unexpected gift of full QuickSync encoding activated in my Pentium!

Unbelievable!

But now I have to go on for some other issues

1) I found out an equally extraordinary item as QuickSync encoding, appeared after the installation of 3412 drivers .

It's a device decoder called "HEVC_VLD_Main" !

Is it a real fully functional decoder or a driver's bug ?

If it's actually working, then how is it possible to accelerate HEVC codec with a Haswell iGPU ?

Is it software only or uses iGPU in any way, like EU's (programmable HW) or fixed-function hardware (QuickSync ASIC) ?

2) I'm glad you fixed Cinebench OpenGL test, although the quality score is lower than AMD and Nvidia (I'm not talking about performance)

3) At the release notes you mention that you provide a resolve for some .wmv files not playing correctly and I checked out that my VC-1 sample reported in the previous driver plays fine, but in software !!!

You simply closed above 1080p VC1_VLD2010 decoding, so everything above FullHD falls back to software!

But VC1_IDCT and the other two VC1 VLD DXVA modes (VC1_VLD_ClearVideo and VC1_VLD_2_ClearVideo) can HW decode up to 4K!

The problem is that open-source players/ decoders based on FFmpeg libraries can't use the above non-standard modes for VLD DXVA decoding and use only VC1_VLD2010.

Is there any other solution to avoid software fall back and keep using HW acceleration for 4K VLD VC-1 ?

4) VPP functions mentioned in my previous driver's release posts, still come pre-configured and we have to disable them in order to gain performance and image quality!

5) MadShaders v0.3.0 still have the exact same problems, no fixes here for OpenGL driver.

6) Intel GPA still crashes due to drivers problems with Win 8.1.

I have reported this issue (along with others) to GPA forum and still waiting for a solution, by you mainly for crashes/ freezes.

7) In the release notes, Pentium G3420, still is reported as no Intel Clear Video HD capable processor.

Is there any Clear Video HD function that Pentium Haswell cores actually don't support ?

Can you name a few in order to understand what I really miss ?

😎 Also InTru 3D is missing for Pentiums too in the release notes.

Is it a hardware or a software luck of resources ?

9) I have a suggestion for you.

For processors that utilize HW acceleration/ decoding via QuickSync ASIC, but have no QuickSync encoding support and no Intel Clear Video HD support you have to create another column in the release notes, mentioning just that capability - video decoding in HW - because a lot people really can't understand what is going on regarding video HW acceleration and the iGPU processors (Sandy and later)

10) Finally, I report another WMV3 1080p sample that has artifacts during DXVA acceleration via VC1_VLD2010.

It's here: http://www.sendspace.com/file/aep5vn Download BD-1080p.wmv from Sendspace.com - send big files the easy way

I don't know if there is something you can do about it.

Thank you and sorry for the large post, but I had to put everything in one post for easy access!

Best regards,

Nikos

0 Kudos
Highlighted
Beginner
120 Views

I have a Samsung NP740U3E with a HD4000 graphics adapter (only). I have been getting the infamous Code 43 since I (stupidly) updated to Windows 8.1. I installed the 3412 driver with high hopes, but unfortunately the problem still remains. The install went fine with no errors, however after the reboot it was still code 43. I have attached my dxdiag and a screenshot of the error/installed driver info.

(Btw: The samsung SW Update is pretty agressive and 5 minutes after the update reboot I was efficiently and silently downgraded back to 3304)

Geir

0 Kudos
Highlighted
Beginner
120 Views

@nic-

The memory leak that several of us described to you in the later pages of the 3345 driver still exist in this version of the driver as well.

0 Kudos
Highlighted
Novice
120 Views

@Nic, Did you check where the users are located that have issues with Netflix?

I am located in the Netherlands.

A Boxee Box cannot run Netflix in the Netherlands because Netflix uses a different software version compared to the US.

I can imagine the Netflix Metro app in Europe is different then the one for the US, which might be why you cannot reproduce the issue.

Not being able to reproduce the issue means that you have different circumstances then the users that are having issues.

Is there any kind of test I can run for you or any kind of log that will provide the information you need?

0 Kudos
Highlighted
Beginner
120 Views

Hello,

I'm sitll getting a blank screen (varies from black, grey or white) after booting when Fast Startup in Windows 8.1 is enabled. If it's disabled, everything works well. The blank screen occurs either before login or several minutes after login. I have tried several driver versions, from 3277, 3345, 3379, 3412, all with the same result. The motherboard is an Asrock Z87M Pro4. Any ideas? Thx for help! Here's my Dxdiag:

------------------

System Information

------------------

Time of this report: 3/1/2014, 14:56:34

Machine name:

Operating System: Windows 8.1 32-bit (6.3, Build 9600) (9600.winblue_gdr.131030-1505)

Language: German (Regional Setting: German)

System Manufacturer: To Be Filled By O.E.M.

System Model: To Be Filled By O.E.M.

BIOS: BIOS Date: 12/06/13 17:42:46 Ver: 04.06.05

Processor: Intel(R) Core(TM) i5-4670 CPU @ 3.40GHz (4 CPUs), ~3.4GHz

Memory: 4096MB RAM

Available OS Memory: 3256MB RAM

Page File: 2278MB used, 1553MB available

Windows Dir: C:\WINDOWS

DirectX Version: DirectX 11

DX Setup Parameters: Not found

User DPI Setting: Using System DPI

System DPI Setting: 96 DPI (100 percent)

DWM DPI Scaling: Disabled

DxDiag Version: 6.03.9600.16384 32bit Unicode

------------

DxDiag Notes

------------

Display Tab 1: No problems found.

Sound Tab 1: No problems found.

Sound Tab 2: No problems found.

Input Tab: No problems found.

--------------------

DirectX Debug Levels

--------------------

Direct3D: 0/4 (retail)

DirectDraw: 0/4 (retail)

DirectInput: 0/5 (retail)

DirectMusic: 0/5 (retail)

DirectPlay: 0/9 (retail)

DirectSound: 0/5 (retail)

DirectShow: 0/6 (retail)

---------------

Display Devices

---------------

Card name: Intel(R) HD Graphics 4600

Manufacturer: Intel Corporation

Chip type: Intel(R) HD Graphics Family

DAC type: Internal

Device Type: Full Device

Device Key: Enum\PCI\VEN_8086&DEV_0412&SUBSYS_04121849&REV_06

Display Memory: 1792 MB

Dedicated Memory: 224 MB

Shared Memory: 1568 MB

Current Mode: 1680 x 1050 (32 bit) (60Hz)

Monitor Name: SyncMaster 226CW,SyncMaster Magic CX226CW(Digital)

Monitor Model: SyncMaster

Monitor Id: SAM030F

Native Mode: 1680 x 1050(p) (59.883Hz)

Output Type: HDMI

Driver Name: igdumdim32.dll,igd10iumd32.dll,igd10iumd32.dll

Driver File Version: 10.18.0010.3412 (English)

Driver Version: 10.18.10.3412

DDI Version: 11.1

Feature Levels: 11.1,11.0,10.1,10.0,9.3,9.2,9.1

Driver Model: WDDM 1.3

Graphics Preemption: DMA

Compute Preemption: Thread

Miracast: Not Supported by WiFi driver

Hybrid Graphics GPU: Integrated

Power P-states: Not Supported

Driver Attributes: Final Retail

Driver Date/Size: 1/22/2014 14:48:28, 18629632 bytes

WHQL Logo'd: Yes

WHQL Date Stamp:

Device Identifier: {D7B78E66-4752-11CF-AD76-1824BBC2C735}

Vendor ID: 0x8086

Device ID: 0x0412

SubSys ID: 0x04121849

Revision ID: 0x0006

Driver Strong Name: oem18.inf:5f63e534dd898f5e:iHSWD_w81:10.18.10.3412:pci\ven_8086&dev_0412

Rank Of Driver: 00DA2001

Video Accel: ModeMPEG2_A ModeMPEG2_C ModeWMV9_C ModeVC1_C

DXVA2 Modes: DXVA2_ModeMPEG2_VLD DXVA2_ModeMPEG2_IDCT DXVA2_ModeWMV9_IDCT DXVA2_ModeVC1_IDCT DXVA2_ModeH264_VLD_NoFGT

Deinterlace Caps: {BF752EF6-8CC4-457A-BE1B-08BD1CAEEE9F}: Format(In/Out)=(YUY2,YUY2) Frames(Prev/Fwd/Back)=(0,0,1) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY VideoProcess_AlphaBlend DeinterlaceTech_EdgeFiltering

{335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(YUY2,YUY2) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY VideoProcess_AlphaBlend DeinterlaceTech_BOBVerticalStretch

{5A54A0C9-C7EC-4BD9-8EDE-F3C75DC4393B}: Format(In/Out)=(YUY2,YUY2) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY VideoProcess_AlphaBlend

{BF752EF6-8CC4-457A-BE1B-08BD1CAEEE9F}: Format(In/Out)=(UYVY,YUY2) Frames(Prev/Fwd/Back)=(0,0,1) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY VideoProcess_AlphaBlend DeinterlaceTech_EdgeFiltering

{335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(UYVY,YUY2) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY VideoProcess_AlphaBlend DeinterlaceTech_BOBVerticalStretch

{5A54A0C9-C7EC-4BD9-8EDE-F3C75DC4393B}: Format(In/Out)=(UYVY,YUY2) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY VideoProcess_AlphaBlend

{BF752EF6-8CC4-457A-BE1B-08BD1CAEEE9F}: Format(In/Out)=(YV12,YUY2) Frames(Prev/Fwd/Back)=(0,0,1) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY VideoProcess_AlphaBlend DeinterlaceTech_EdgeFiltering

{335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(YV12,YUY2) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY VideoProcess_AlphaBlend DeinterlaceTech_BOBVerticalStretch

{5A54A0C9-C7EC-4BD9-8EDE-F3C75DC4393B}: Format(In/Out)=(YV12,YUY2) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY VideoProcess_AlphaBlend

{BF752EF6-8CC4-457A-BE1B-08BD1CAEEE9F}: Format(In/Out)=(NV12,YUY2) Frames(Prev/Fwd/Back)=(0,0,1) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY VideoProcess_AlphaBlend DeinterlaceTech_EdgeFiltering

{335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(NV12,YUY2) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY VideoProcess_AlphaBlend DeinterlaceTech_BOBVerticalStretch

{5A54A0C9-C7EC-4BD9-8EDE-F3C75DC4393B}: Format(In/Out)=(NV12,YUY2) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY VideoProcess_AlphaBlend

{BF752EF6-8CC4-457A-BE1B-08BD1CAEEE9F}: Format(In/Out)=(IMC1,YUY2) Frames(Prev/Fwd/Back)=(0,0,1) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY VideoProcess_AlphaBlend DeinterlaceTech_EdgeFiltering

{335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(IMC1,YUY2) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY VideoProcess_AlphaBlend DeinterlaceTech_BOBVerticalStretch

{5A54A0C9-C7EC-4BD9-8EDE-F3C75DC4393B}: Format(In/Out)=(IMC1,YUY2) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY VideoProcess_AlphaBlend

{BF752EF6-8CC4-457A-BE1B-08BD1CAEEE9F}: Format(In/Out)=(IMC2,YUY2) Frames(Prev/Fwd/Back)=(0,0,1) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY VideoProcess_AlphaBlend DeinterlaceTech_EdgeFiltering

{335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(IMC2,YUY2) F...

0 Kudos
Highlighted
Beginner
120 Views

Hello,

BUG: I can confirm what ewtaylo has posted, the memory leak with games like Resident Evil 6 still persist in this version. This driver version still load the game for 5 minutes but for the older drivers (circa last quarter 2013) it loads the game instantly. Maybe you can check what makes that do so by reviewing your old drivers and checking if made a mistake on the new ones. Because this memory leak is around like 7-8 months or so, looking forward for you to fix this.

0 Kudos
Highlighted
Beginner
120 Views

This driver does nothing to address the netflix bug that dozens have confirmed since December. Again, it is not a "5.1" issue and the imprecise way it is described above makes me wonder whether any proper testing has ever been done for this bug. It is rather simple. Grab a Haswell NUC and load a fresh copy of Windows 8.1. Set it to bitstream to an avr. Run the metro Netflix app and try to play House of Cards (the new one -- not the UK original from 1990). Do not select other programs because this only affects the premier shows on netflix.Try to play with Dolby Digital Plus with the avr reporting DD+. It will not work.

Not 5.1 and not dolby digital. Dolby Digital Plus. There is a huge difference. If I sound a bit snippy it is because this is a fantastic piece of hardware and I just want it to work and I am disappointed there has been zero progress.

0 Kudos
Highlighted
Beginner
120 Views

Add me to the Netflix problem as well. As soon as I "upgraded" to Windows 8.1 Netflix will not play using Dolby Digital Plus as "imarmed" states above. I am using 3412 and a Gigabyte Z77M-D3H and i5 w/HD4000. This is easy to reproduce. Been this way for months now. Seriously, what's going on?

0 Kudos
Highlighted
Novice
120 Views

Hi Nic,

@Nic: Some users are still experiencing either black screens OR Code43/31 issues on systems that utilize either 3rd party graphics cards or are using Intel-graphics only systems. If you are still having this issue, please provide that information here alongside an updated dxdiag report, and your system/motherboard model.

Resume:

HP Probook 4540s

Intel Core i5-3230M cpu 2.60ghz

ram 4gb

system: x64

windows 8.1 Pro

graphics: intel hd4000 and amd 7650M

BUG: Intel control panel no run. Driver version 3412 code 43.on bios switchable mode:ON

Intel control panel no run but driver version 3412 works correctly on bios switchable mode: OFF(really don't works).

Catalist control center never runs. Tested amd driver versions; from OEM HP, AMD site 13.12 final version, 14.1 beta and 14,2 beta.

After 6 month.. i'm seriously tinking downgrade to win 8

0 Kudos
Highlighted
Beginner
120 Views

The latest driver fixed none of my problems at all.

See my thread. https://communities.intel.com/message/224674# 224674 https://communities.intel.com/message/224674# 224674

0 Kudos
Highlighted
Novice
120 Views

Some update regarding the Netflix issue (a possible workaround):

As reported by other sources on the Internet (e.g. ), on the Intel NUC units (mine is a D54250WYK) it surprisingly seems to help to disable the Legacy boot support in the BIOS. How that could have anything to do with the audio drivers is a mystery, but I am up and running with Windows 8.1, the Netflix metro app and 5.1 sound without any signs of slow motion issue. I however experience a slight sync issue between audio and video (maybe 100ms), but I can probably compensate for that in my Yamaha receiver...

I am running the 3412 driver.

I will continue testing throughout the day. Hope that someone else can confirm that this solves their issue, and hopefully this could be a clue to Nic to be able to reproduce the issue.

0 Kudos
Highlighted
Beginner
120 Views

@nic-

I am unsure if just stating that that memory leak that existed in all 8.1 drivers (including 3345) still exists is enough or not. Here are links to how I described that the issue can be recreated:

and

Under windows 8.1 only, the intel drivers cause all of virtual memory to be filled if the full screen program is running at a different resolution/refresh rate than the desktop.

0 Kudos
Highlighted
Novice
120 Views

I tried disabling the legacy boot on a Intel® NUC Kit DC3217IYE but this makes no difference.

Dolby Digital+ still does not work with the Netflix metro app. (House of Cards for example.)

0 Kudos
Highlighted
Beginner
120 Views

I am having some serious problems with the new Driver(s). After i updated windows my screen went ''Nuts'' and got all tored and full of pixels. I tried going back to earlier versions but none of them seem to work anymore.

The problem originated when I was playing a game, namely Diablo 3 when it suddenly crashed and the screen got all ''tored'' and got prompetd with the ''Display Driver Stopped Responding and Has Recovered''. It got so bad that i couldn't even open apps anymore. I reinstalled windows again everything went ok till i updated to the newest driver. I updated to windows 8.1 in hopes that the problem would be solved but it persisted.

Haven't come up with a solution yet. The only thing i've come up with out of frustration is to disable the 4600 driver or Go back to ''Microsoft Basic Display Adapter'' which is the only thing that seems to work for now.

My Laptop is a Sager NP8250

0 Kudos
Highlighted
Beginner
120 Views

Regarding Netflix Metro App/Dolby Digital Plus issue, I am also having the same problem on my Laptop (Acer V5-571, Intel Core i5 3317U, HD graphics 4000), running Windows 8.1 and this latest driver version (64bit). But I think I found a workaround. Keep in mind my TV is connected using HDMI (through an Onkyo A/V receiver) to the laptop as a second monitor (extended display).

While the Netflix app is running on the TV and a 5.1 DD+ audio track selected (i.e., with no sound output and skipping most video frames), go into the Speaker Setup configuration (right click on the Speakers icon, Playback Devices, select Intel Display Audio device, and click on Configure). Choose Stereo option and click Next a couple of times, followed by Finished.

I get an error message: "Format not supported by this device.", and the Netflix Metro App automatically reloads the film in Dolby Digital Plus and plays it OK from then on. The Intel Display Audio device stays configured as 5.1 (the Stereo option doesn't stick).

I hope this helps somehow until Intel/Netflix manage to figure out this problem.

0 Kudos
Highlighted
Beginner
120 Views

@d97ulf

I unchecked the legacy boot support, and it did not fix the Netflix problem. I'm running on mostly the settings that came from the factory. Perhaps you have some other setting that affects the issue? Is there a way to make a textfile of all the bios settings for comparison?

@boombuia

You sir are a genius. Your workaround does indeed work. I do detect a very, very slight audio delay. Almost not worth worrying about on a short viewing.

One more datapoint: I experience the exact same Netflix problem with HD audio sources in XBMC if audio is set to DirectSound instead of WASAPI. (Directsound can't handle HD audio passthrough.)

0 Kudos
Highlighted
Beginner
120 Views

hi i need now how to set Intel® Management and Security Status

0 Kudos
Highlighted
Beginner
120 Views

@imarmed

In my case, I was already booting my laptop in UEFI mode (Legacy mode disabled), so I kept looking for alternative solutions - I was basically trying to reset the audio configuration (set it to Stereo and then back to 5.1), when I discovered this workaround. I'm glad it helped you, as well!

0 Kudos