Graphics
Intel® graphics drivers and software, compatibility, troubleshooting, performance, and optimization
20839 Discussions

X-Plane 11 Vulkan Support

OE-DJ1
Beginner
8,699 Views

Hello Intel Team,

I'm using X-Plane 11 with integrated UHD770 graphics and have graphic errors under Vulkan in addon planes and plugins. The graphics display is perfect under OpenGL, but much slower. In my opinion, the problem in another post here is very similar to my concern.

I've tried several versions of the graphics driver, the latest being version 31.0.101.4125

Distribution is from x-plane.com (Laminar Research)

The error messages in the log "WARNING: extension missing proc..." indicate missing functions under Vulkan. There are several discussions in the x-plane.org forum with a similar situation and identical error messages, which, according to the feedback there, all point to the lack of Vulkan support in several functions for the Intel driver.

Do you have any suggestions?

Can we expect that the missing functions will be added?

I know this isn't a mainstream title, but I'd really appreciate a solution.

Many Thanks

Best regards

0 Kudos
18 Replies
Jean_Intel
Employee
8,657 Views

Hello OE-DJ1

 

Thank you for posting on the Intel️® communities.

 

I will proceed to check the issue internally and post back soon with more details.

 

Best regards,

Jean O. 

Intel Customer Support Technician


0 Kudos
Jean_Intel
Employee
8,634 Views

Hello OE-DJ1,

 

We appreciate your patience.

 

To further investigate this matter. We would like to gather more information about your issue:

 

  • Can you confirm if you can use an older driver (3 to 6 months) older to check if the issues appear? For example, you can try our driver version, 31.0.101.3802
  • Can you share the steps to replicate the issue?
  • What is the game distribution service? ( Blizzard, Epic, Origin, Steam, Xbox, Ubisoft connect)?
  • What are the plane or parts where the issue is present? Is the problem only present on the plane monitor (as in the image you shared)?
  • Have you tried a clean graphics driver installation, and reinstalling the game installation?

 

Best regards,

Jean O. 

Intel Customer Support Technician


0 Kudos
OE-DJ1
Beginner
8,617 Views

Hello Jean O.,

Thank you for your reply.

I appreciate your efforts and will try to contribute detailed information.

I am not at my SimPC every day, which is located somewhere else. I apologize for a few days of delay. I will test older drivers as recommended as soon as possible and report back.

At this time I can answer your other questions.

Regarding the steps to the error; after setting up the simulator situation, the aircraft “appears” cold & dark at the selected airport. I "powered" only the tablet and the left display for making the screenshots, the right display is still off and should appear black until switched on. In the picture regarding Vulkan, I may point out the pattern of bright dots on the right display. The left display is popped out to see the errors better. The graphic on the tablet is also not correct.

The X-Plane program was bought online from the manufacturer Laminar Research. The aircraft comes from X-plane.org Store. The computer was rebuilt at the beginning of January and the OS was freshly installed. In the simulator I have only a bare minimum of addons - only the additional aircraft and European scenery.

The graphic error occurs on the tablet visible on the left in the cockpit and on the left and right display. Other elements such as cockpit, landscape and buildings, aircraft body, are fine.

I did a clean driver installation as usual.

Kind regards

0 Kudos
Jean_Intel
Employee
8,605 Views

Hello OE-DJ1,

 

Thanks for your response.

 

We understand that you may need some time to continue with the recommendations, and we will wait a few days for you to follow them.

 

In the meantime, I would like to confirm whether or not the game add-ons are official. If not, does the issue occur when you run the game's basic version (without customizations)?

 

Best regards,

Jean O.

Intel Customer Support Technician


0 Kudos
OE-DJ1
Beginner
8,591 Views

Hello Jean O,

I'm not sure how to understand and judge "officially". The addons are from x-plane.org, the plane is payware. Unfortunately I cannot answer the question for sure.

My program version X-Plane 11.5 without the add-on plane works with Vulkan. The graphics are good and mostly fast enough on medium settings with UHD770. I contacted you directly because there are already several similar situations that indicate partially missing Vulkan support in the driver.

As you can see, I'm not the only customer asking about X-Plane and Intel graphics. With X-Plane 11, some addons do not work properly. X-Plane 12 won't start at all.

Is anything known about this? Do you intend to implement these features in the future?

Best regards

0 Kudos
Jean_Intel
Employee
8,543 Views

We appreciate your response.

 

It is important to mention that if the game works as expected without the add-ons, the issue may be present with the additional content. If the add-on is not official and is from a third-party developer, the add-on developer should work on a solution for their content.

 

Also, note that we are working to improve our products. If the issue is due to a driver issue, we will investigate the problem and implement a solution. If needed, we will work alongside the game developer.

 

Best regards,

Jean O.

Intel Customer Support Technician


0 Kudos
OE-DJ1
Beginner
8,529 Views
Hello,
 
thank you for your response.
 
I asked the add-on developer and was told it could either be fixed only by game developer or it is driver related.
 
So, they won’t touch version 11 anymore, as XP 12 is out for a while, what I also understand logically. I see no possibility to collect further information as I already provided or proof the cause of this issue. I guess the log file tells quite well.
 
At this time, the circle closes because XP 12 does not even start due to missing functions (linked in my 1st post). Anyway, I will wait a while to see how the situation develops. 
 
I understand your point of view and in my opinion this case can be closed. I myself and certainly many other users would appreciate it very much if the target group of X-Plane users were taken into account in further development.
 
I highly welcome the fact that another manufacturer of interesting graphic cards is now on the market and I hope for good success.
 
Thank you for your efforts, too.
 
Best regards
0 Kudos
Jean_Intel
Employee
8,508 Views

Hello OE-DJ1,


We appreciate the information shared.


We would like to further investigate this matter. However, we are missing some information we requested before:


Can you confirm if you can use an older driver (3 to 6 months) older to check if the issues appear? For example, you can try our driver version, 31.0.101.3802.

Can you share the steps to replicate the issue?


Best regards,

Jean O.

Intel Customer Support Technician


0 Kudos
OE-DJ1
Beginner
8,498 Views

Hello,

Thank you for your reply. I ask for a little patience, I'll be back at my Sim PC at my second home this weekend and will try out another driver.

Which steps do you mean, beginning from program start, airplane settings, environment and graphic settings? I assume screenshots and the X-Plane logfile would be helpful.

Best regards

0 Kudos
OE-DJ1
Beginner
8,462 Views

Hello,

I highly appreciate your further investigation. Will try to provide information as fine as I can do.

I documented the steps from program start to cockpit view, where the error is visable, with screenshots. Also I tried different graphic settings with no change.

I tried driver versions

31.0.101.3802 14.11.2022 no change
31.0.101.4146 22.02.2023 Vulkan error at start screen

The logfiles shows the procedure from program start, load flight environment to program shutdown.

I've put the driver version in log filenames. Always did a clean install and reboot before testing.

I look forward to testing the next steps.

Kind regards

0 Kudos
OE-DJ1
Beginner
8,461 Views

PS added screenshot graphic settings with driver 4146

0 Kudos
Jean_Intel
Employee
8,452 Views

Hello OE-DJ1,


Thank you for the information provided.  


Let us look into this and we will get back to you at our earliest convenience.


Best regards, 

Jean O.  

Intel Customer Support Technician


0 Kudos
Jean_Intel
Employee
8,392 Views

Hello OE-DJ1,

 

We appreciate your patience.

 

Since you previously mentioned that the X-Plane 11.5, without any add-on plane, works with Vulkan. This means that the Intel® UHD Graphics 770 can run and manage the base game properly, and it seems that the issue is related to the add-on. The best course of action for this problem should be to report this issue to the add-on developers and reach out to them for further Troubleshooting.

 

Best regards,

Jean O. 

Intel Customer Support Technician


0 Kudos
OE-DJ1
Beginner
8,375 Views

Hello Jean O.,

thank you for your reply.

I agree with your explanation and I already asked the add-on developers. They pointed out a driver issue as a possible reason.

It looks like A points to B points to C points to A. We're going in circles and we're getting nowhere.

My intention is not to make factory default state work, as it already does. X-Plane 11 default throws a few warning lines in log file, but it works with Vulkan API as long as more complex add-ons are not used.

There’s another discussion here, regarding X-Plane 12. May I point out, these lines in his and my log file are identical and in my humble opinion it leads to some missing driver functionality. A quick web search finds lots of results to this issue in the past.

WARNING: extension missing proc glGetnTexImage.  This is a problem with your video driver.WARNING: extension missing proc glGetnUniformdv.  This is a problem with your video driver.
WARNING: extension missing proc glGetnMapdv.  This is a problem with your video driver.WARNING: extension missing proc glGetnMapfv.  This is a problem with your video driver.
WARNING: extension missing proc glGetnMapiv.  This is a problem with your video driver.
WARNING: extension missing proc glGetnPixelMapfv.  This is a problem with your video driver.
WARNING: extension missing proc glGetnPixelMapuiv.  This is a problem with your video driver.
WARNING: extension missing proc glGetnPixelMapusv.  This is a problem with your video driver.
WARNING: extension missing proc glGetnPolygonStipple.  This is a problem with your video driver.
WARNING: extension missing proc glGetnColorTable.  This is a problem with your video driver.
WARNING: extension missing proc glGetnConvolutionFilter.  This is a problem with your video driver.
WARNING: extension missing proc glGetnSeparableFilter.  This is a problem with your video driver.
WARNING: extension missing proc glGetnHistogram.  This is a problem with your video driver.
WARNING: extension missing proc glGetnMinmax.  This is a problem with your video driver.

I forgot to add a factory default log file from my backup, driver version 4146.  As you can see, the Vulkan related lines are still there. 

I noticed that Vulkan API hasn't been mentioned yet. Is this cause known and will it be investigated further? Is there an "official" ticket ID? It would be my pleasure to help with information as long there is serious interest in a solution. Please tell me directly if there is no interest to save my time. I won't go around in circles longer...

I appreciate your efforts - thank you Intel Team!

Kind regards

0 Kudos
Jean_Intel
Employee
8,341 Views

Hello OE-DJ1,

 

Thanks for the information provided.

 

We will resume our investigation considering the new information provided. We will post back with further details.

 

We understand that you feel as if we are going around in circles, and you perceive that there is no interest in a solution for this issue. We would like to let you know that we will put our effort into everything that is in our hands to solve this problem.

 

Best regards,

Jean O. 

Intel Customer Support Technician


0 Kudos
Jean_Intel
Employee
8,063 Views

Hello OE-DJ1,


Thank you for waiting for a reponse.


We would like to let you know we are now investigating this matter under bug ID 18015534950. Unfortunately, we can't promise any ETA regarding this matter.


In order to void duplicate efforts, since this process requires further effort on our part, we are considering closing this case. However, before doing so, we would like to know if you agree with this.


Best regards,

Jean O. 

Intel Customer Support Technician


0 Kudos
OE-DJ1
Beginner
8,023 Views

Hello Jean O.,

Thank you for your efforts. I agree to close this case.

It was my pleasure I was able to contribute to a possible solution and will have an eye on future driver release notes.

Please feel free to contact me, if you - maybe - need more information or user tests.

Kind regards

 

0 Kudos
Jean_Intel
Employee
7,984 Views

Hello OE-DJ1,

 

Thank you for your response.

 

Since you have agreed to close the case, we will proceed to do so. If you need additional information, please submit a new question since this thread will no longer be monitored.  

 

Best regards,

Jean O.

Intel Customer Support Technician


0 Kudos
Reply