Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Beginner
1,270 Views

wglRestoreBufferRegionARB very slow

Jump to solution

Has anyone had problems with the wglRestoreBufferRegionARB function?

 

 

My users are reporting problems of slowness in the drawing of my software in recent times. All of them use integrated Intel HD graphics (with old cards to 4000 family) in Windows, of course. I think it has to do with some bug of the driver of the latest versions.

 

 

My software has been used this extension for years and now I have found that in old cards with Intel HD there are calls that take a long time to run (for example, 4000 milliseconds!).

 

 

I have checked that there is no problem with the handle that uses the function (for example, that it is corrupted for some reason), but everything seems to be fine. The strange thing is that the problem stops manifesting when doing some log of the type OutputDebugString.

 

 

Can someone help me with this topic?

 

Regards,

Angel

Tags (1)
0 Kudos

Accepted Solutions
Honored Contributor II
46 Views

You should get better help in the forum https://software.intel.com/en-us/forums/developing-games-and-graphics-on-intel Developing Games & Graphics on Intel

View solution in original post

0 Kudos
2 Replies
Honored Contributor II
47 Views

You should get better help in the forum https://software.intel.com/en-us/forums/developing-games-and-graphics-on-intel Developing Games & Graphics on Intel

View solution in original post

0 Kudos
Beginner
46 Views

OK, thanks

0 Kudos