Community
cancel
Showing results for 
Search instead for 
Did you mean: 
ahju
Beginner
84 Views

ISVS_RegisterApplicationEx2 failed

Hello

WhenI execute the sample StorageDumpin SDK, the ISVS_RegisterApplicationEx2 return failed.

I have a AMTdevice with the version 3.0.2, and is configured for SmallBusiness Module, and the SDKI am using is 4.0.

Lask week, I am calling it successfully before I add a new network card into the computer. And there are two network cards which both connect to teh network in the computer, one work for OS and the other one work for AMT.

I know AMT features will only be available to the onboard Network Interface Card, I think the fail isn't cause to the new network card.Butthe ISVS_RegisterApplicationEx2 doesn't work after the new network card was added, why?

Thanks

0 Kudos
9 Replies
ahju
Beginner
84 Views


Hello

Is anybody know what's wrong with it?

Thanks

84 Views

Hi,
Sorry; we were busy with the Virtual Boot camp and couldn't get back to you.
Is there any reason you are using the 2 network cards? Also, are you saying that with one additional NIC (other than the onboard NIC) you were able to call this function successfully and with 2 NICs it failed?
Thanks,
Sree

ahju
Beginner
84 Views

Hi,
Sorry; we were busy with the Virtual Boot camp and couldn't get back to you.
Is there any reason you are using the 2 network cards? Also, are you saying that with one additional NIC (other than the onboard NIC) you were able to call this function successfully and with 2 NICs it failed?
Thanks,
Sree

Thanks Sreelekshmy Syamalakumari

I used 2 netwrok cards just beause the OS cauldn't connect to the network, and I can login on the AMT through WebUI and the ISVS_RegisterApplicationEx2 called successfully. The OS can connect to the network but AMT failed after I add a new network card. SO, I connect both the two network cards to the network and both the OS and AMT can connect to the network but this API failed.

Thanks.

84 Views

Quoting - ahju

Thanks Sreelekshmy Syamalakumari

I used 2 netwrok cards just beause the OS cauldn't connect to the network, and I can login on the AMT through WebUI and the ISVS_RegisterApplicationEx2 called successfully. The OS can connect to the network but AMT failed after I add a new network card. SO, I connect both the two network cards to the network and both the OS and AMT can connect to the network but this API failed.

Thanks.


Hi,

There should be something wrong with your settings. Actually, with the onboard NIC, you should be able to login to AMT remotely using WebUI and the OS should also connect to the netwrok. Are you using static IP or DHCP?

Here are some links that will help you to set up the system correctly:

Please confirm that you have followed your guidelines here for setting up your system.
Thanks,
Sree
ahju
Beginner
84 Views


Hi,

There should be something wrong with your settings. Actually, with the onboard NIC, you should be able to login to AMT remotely using WebUI and the OS should also connect to the netwrok. Are you using static IP or DHCP?

Here are some links that will help you to set up the system correctly:

Please confirm that you have followed your guidelines here for setting up your system.
Thanks,
Sree


Thanks,

Yes, I am using static IP. At first both the AMT and OS can connect to the network through the onboard NIC, and the ISVS_RegisterApplicationEx2 API return successfully. And one day the OS suddenly can'tbut the AMT can. I add a new NIC to the computeraftertrying many methords.

I will try another time.

Thinks.

84 Views

Hi,
That is strange; Did you change any network settings in between?
Thanks,
Sree

ahju
Beginner
84 Views

Hi,
I didn't change any network settings in between.
Now the ISVS_RegisterApplicationEx2 return successfully after I only use one network card. I don't know why.
Thanks.

84 Views

Quoting - ahju
Hi,
I didn't change any network settings in between.
Now the ISVS_RegisterApplicationEx2 return successfully after I only use one network card. I don't know why.
Thanks.

Hi,

What about the OS? Can you connect to the network?

Thanks,

Sree

ahju
Beginner
84 Views

Hi,

What about the OS? Can you connect to the network?

Thanks,

Sree

Hi,

Yes, both the OS and the AMT can connect to the network. That's strange.

Thanks

Reply