Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Contributor I
23 Views

Update from V4.1 to V4.2.1

When update to 4.2.1 version, new server machine, the browser sample runs OK. but pc/android client cannot join room,

pc client cannot be called cb func no matter it is join room success or failure.

android client receive join room failed msg.

 

On server side:

the conference logs said:

2019-07-30 14:25:14.775  - DEBUG: WorkingNode - No native logger for reconfiguration
2019-07-30 14:25:14.818  - INFO: WorkingNode - pid: 3241
2019-07-30 14:25:14.818  - INFO: WorkingNode - Connecting to rabbitMQ server...
2019-07-30 14:25:14.839  - INFO: AmqpClient - Connecting to rabbitMQ server OK, options: { host: 'localhost', port: 5672 }
2019-07-30 14:25:15.075  - INFO: WorkingNode - conference-3f8461fbbe4591ed66fe@192.168.1.179_0 as rpc server ready
2019-07-30 14:25:15.077  - INFO: WorkingNode - conference-3f8461fbbe4591ed66fe@192.168.1.179_0 as monitor ready
2019-07-30 14:25:58.745  - ERROR: RoomController - new mix terminal failed. room_id: 5d3fb7e8d26508407066c7cf reason: No available node
2019-07-30 14:25:58.745  - ERROR: RoomController - new mix terminal failed. room_id: 5d3fb7e8d26508407066c7cf reason: No available node
2019-07-30 14:25:58.746  - ERROR: RoomController - init fail. view: threeview reason: No available node
2019-07-30 14:25:58.746  - ERROR: RoomController - init fail. view: fourview reason: No available node
2019-07-30 14:25:58.746  - ERROR: RoomController - new mix terminal failed. room_id: 5d3fb7e8d26508407066c7cf reason: No available node
2019-07-30 14:25:58.746  - ERROR: RoomController - init fail. view: moreview reason: No available node
2019-07-30 14:25:58.959  - ERROR: Conference - roomController init failed. No available node
2019-07-30 14:25:58.959  - ERROR: Conference - Init room failed, reason: roomController init failed. reason: No available node
2019-07-30 14:25:58.959  - WARN: Conference - Participant hccHp58RafgM3hlEAAAC join room 5d3fb7e8d26508407066c7cf failed, err: roomController init failed. reason: No available node

 

the video-agent logs said:

2019-07-30 14:29:42.813  - INFO: WorkingNode - pid: 4515
2019-07-30 14:29:42.815  - INFO: WorkingNode - Connecting to rabbitMQ server...
2019-07-30 14:29:42.829  - INFO: AmqpClient - Connecting to rabbitMQ server OK, options: { host: 'localhost', port: 5672 }
2019-07-30 14:29:42.846  - INFO: WorkingNode - video-110f37e023640357b20c@192.168.1.179_7 as rpc server ready
2019-07-30 14:29:42.848  - INFO: WorkingNode - video-110f37e023640357b20c@192.168.1.179_7 as monitor ready
2019-07-30 14:29:49,403  - INFO: mcu.media.VideoMixer - Init maxInput(16), rootSize(1280, 720), bgColor(16, 128, 128)
2019-07-30 14:29:49.621  - ERROR: VideoNode - Conference controller (type: node id: conference-3f8461fbbe4591ed66fe@192.168.1.179_2 ) fault is detected, exit.

 

it seems that some agent not init success.

 

all config is similar to v4.1 version

 

Can team help?

 

Thanks.

Tags (2)
0 Kudos
3 Replies
Highlighted
New Contributor I
23 Views

v4.1 join room step:

v4.1 join room step:

1. call join method of conferece client, when failed, join again(I guess server is preparing room).

2. when join failure second time, it failed to join room(NEVER HAPPEN).

 

v4.2.1 join room step:

1. call join room method of conference client, got error msg("(conferencesocketsignalingchannel.cc:138): Socket.IO disconnected.
") from server

2. join again, never call cb func.

0 Kudos
Highlighted
New Contributor I
23 Views

it is layout custom problem,

it is layout custom problem

layout like below, the server warning INVALID VIEW

[{
    "region": [{
        "id": "primary",
        "area": {
            "left": "0",
            "top": "0",
            "width": "0.5",
            "height": "0.5"
        },
        "shape": "rectangle"
    }, {
        "id": "1",
        "area": {
            "left": "0.5",
            "top": "0",
            "width": "0.5",
            "height": "0.5"
        },
        "shape": "rectangle"
    }, {
        "id": "2",
        "area": {
            "left": "0",
            "top": "0.5",
            "width": "0.5",
            "height": "0.5"
        },
        "shape": "rectangle"
    }, {
        "id": "3",
        "area": {
            "left": "0.5",
            "top": "0.5",
            "width": "0.5",
            "height": "0.5"
        },
        "shape": "rectangle"
    }]
}]

 

layout like below, it's OK

[{
    "region": [{
        "id": "primary",
        "area": {
            "left": "0",
            "top": "0",
            "width": "1",
            "height": "1"
        },
        "shape": "rectangle"
    }]
}, {
    "region": [{
        "id": "primary",
        "area": {
            "left": "0",
            "top": "0.25",
            "width": "0.5",
            "height": "0.5"
        },
        "shape": "rectangle"
    }, {
        "id": "1",
        "area": {
            "left": "0.5",
            "top": "0.25",
            "width": "0.5",
            "height": "0.5"
        },
        "shape": "rectangle"
    }]
}, {
    "region": [{
        "id": "primary",
        "area": {
            "left": "0.25",
            "top": "0",
            "width": "0.5",
            "height": "0.5"
        },
        "shape": "rectangle"
    }, {
        "id": "1",
        "area": {
            "left": "0",
            "top": "0.5",
            "width": "0.5",
            "height": "0.5"
        },
        "shape": "rectangle"
    }, {
        "id": "2",
        "area": {
            "left": "0.5",
            "top": "0.5",
            "width": "0.5",
            "height": "0.5"
        },
        "shape": "rectangle"
    }]
}]

 

pc client(v4.2.1) -> server v4.1/v4.2.1 always crash here after join room, it occur error when decode meeting stream

TIM图片20190730152627.png

TIM图片20190730151607.png

pc client sample always crash here when decoding meeting stream:

TIM图片20190730172147.png

0 Kudos
Highlighted
New Contributor I
23 Views

The crash problem, I found

The crash problem, I found the same issue on github,

https://github.com/open-webrtc-toolkit/owt-client-native/issues/54

But after compile the sdk successfully(20190730), the crash still exists. 

0 Kudos