Intel® DevCloud
Help for those needing help starting or connecting to the Intel® DevCloud
1693 Discussions

Apply for a Devcloud account for FPGA

He4Forum
Employee
1,375 Views

Hi,

 

I am an Intel employee and want to apply for an account with FPGA hardware access. While the only register website is for external users. 

https://www.intel.com/content/www/us/en/secure/forms/devcloud-cert/enrollment/intel-employee-access.html

While I still used this link and registered an account. After it, I want to access Devcloud under Intel firewall, so I use this guide: https://github.com/intel/FPGA-Devcloud/blob/master/main/Devcloud_Access_Instructions/README.md#connection-methods and set the .ssh/config.

Then I run `ssh colfax-intel` in Mobaxterm, it shows the error log.

 

stty: standard input: Inappropriate ioctl for device
Permission denied (publickey).
stty: standard input: Inappropriate ioctl for device
ssh_exchange_identification: Connection closed by remote host

 

Any suggestions on this issue? Thanks.

And another question, is Oneapi 23.1 version with Quartus for FPGA supported on Devcloud now?

 

Regards,

He

 

 
0 Kudos
9 Replies
AlekhyaV_Intel
Moderator
1,303 Views

Hi,

 

Thank you for posting in Intel communities. The document which you're following is an outdated one and the procedure has changed. Now, we could access FPGA hardware from oneAPI DevCloud by changing the queue to FPGA queue.

 

Firstly, you would need to connect to DevCloud via SSH. You could follow the below steps:

  1. Follow the Manual Configuration from this: https://devcloud.intel.com/oneapi/documentation/connect-with-ssh-linux-macos/
  2. If you’re behind Proxy(using Intel network), Please add the below content in your config file:
Host devcloud.proxy
User  <user>
Port 4022
IdentityFile ~/.ssh/devcloud-access-key-<user>.txt
ProxyCommand ssh -T devcloud-via-proxy

Host devcloud-via-proxy
User guest
Hostname ssh.devcloud.intel.com
IdentityFile ~/.ssh/devcloud-access-key-<user>.txt
LocalForward 4022 c009:22
ProxyCommand nc -x <proxy_name>:<port> %h %p
  1. As you’re an Intel employee, make sure you’re using the right proxy as per your location. 
  2. You could open your Mobaxterm and run the below command to connect to devcloud via Intel Proxy.
ssh devcloud.proxy
  1. Once you login to OneAPI DevCloud via SSH, you could get into FPGA queue with the below commands:
source /data/intel_fpga/devcloudLoginToolSetup.sh
devcloud_login

AlekhyaV_Intel_0-1682677393063.png

 

You would be logged into a compute node with FPGA hardware(Arria10/Stratix10)

 

  1. To make use of Quartus for FPGA, you would have to setup the tools with below commands
source /data/intel_fpga/devcloudLoginToolSetup.sh
tools_setup

AlekhyaV_Intel_2-1682677744022.png

From above screenshot, you can see that there are several versions of Quartus Prime available. 

 

If this resolves your issue, make sure to accept this as a solution. This helps others with similar issue. Thank you!

 

Regards,

Alekhya

 

0 Kudos
AlekhyaV_Intel
Moderator
1,242 Views

Hi,


Has the solution provided helped? Could you please give us an update regarding this issue?


Regards,

Alekhya


0 Kudos
He4Forum
Employee
1,238 Views

Hi Alekhya,

 

Thank you for the solution. While I still cound not access the DevCloud through ssh command.

My ssh config setting is as below. Seems no fault of it.

Host devcloud.proxy
User u191868
Port 4022
IdentityFile ~/.ssh/devcloud-access-key-191868.txt
ProxyCommand ssh -T devcloud-via-proxy

Host devcloud-via-proxy
User guest
Hostname ssh.devcloud.intel.com
IdentityFile ~/.ssh/devcloud-access-key-191868.txt
LocalForward 4022 c009:22
ProxyCommand nc -x proxy-prc.intel.com:913 %h %p

Now I still get the error log like this.

He4Forum_0-1683268499941.png

 

Thank you so much for supporting.

 

Regards,

He

 

0 Kudos
AlekhyaV_Intel
Moderator
1,159 Views

Hi @He4Forum ,

 

We are sorry to hear that. Which configuration did you try to connect to DevCloud? Manual or automatic configuration?

And please make the below modifications to your config file and please check if the issue still persists.

 

 

Host devcloud-via-proxy
User guest
Hostname ssh.devcloud.intel.com
IdentityFile ~/.ssh/devcloud-access-key-191868.txt
LocalForward 4022 c009:22
ProxyCommand nc -x proxy-prc.intel.com %h %p 

 

 

If this resolved your issue, make sure to accept this as solution. This helps others with similar issue! Thank you!

 

Regards,

Alekhya

 

0 Kudos
AlekhyaV_Intel
Moderator
1,111 Views

Hi,


We have not heard back from you. Could you please give us an update regarding this issue?


Regards,

Alekhya


0 Kudos
He4Forum
Employee
1,009 Views

Hi Alekhya,

Sorry for replying late. I still cannot access the server after modification.

Regards,

He

 
 
0 Kudos
AlekhyaV_Intel
Moderator
992 Views

Hi,


Could you please try connecting to devcloud without proxy? Does it work? Could you please check and let us know?

If yes, you have to give the right proxy command in your config file to connect to devcloud behind proxy.


Regards,

Alekhya


0 Kudos
AlekhyaV_Intel
Moderator
875 Views

Hi,


Has the solution provided helped? Could you please give us an update regarding this issue?


Regards,

Alekhya


0 Kudos
AlekhyaV_Intel
Moderator
806 Views

Hi,


We assume that your issue is resolved. If you need any further assistance, please post a new question as this thread will no longer be monitored by Intel


Thanks,

Alekhya


0 Kudos
Reply