Intel® DevCloud
Help for those needing help starting or connecting to the Intel® DevCloud
Announcements
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!
679 Discussions

Unable to log back on after first logon

Jones__Brian
New Contributor I
676 Views

On Monday Dec 7, I signed up for DevCloud. My first logon, using Putty, was a success, and I got the full logon screen "Welcome to the Intel DevCloud for oneAPI Projects!"

Shortly after I got in, Putty terminated with "Server unexpectedly closed network connection." When I try to log on again with my credentials saved as a Saved Session in Putty, I get the same message "Server unexpectedly closed network connection."

My Putty setup was pre-saved with exactly the same credentials as the first logon. I use ssh keys to log on.  I use Putty for cloud access with other cloud providers, so I am an experienced Putty user.

I send an email to devcloud@intel.com, but I have not received any reply.

Thanks for any help on how to get back in.

 

0 Kudos
1 Solution
Jones__Brian
New Contributor I
582 Views

Hi,

Thanks for your help.  Yes, you did help me resolve the problem with Pageant. 

Regards,

Brian

 

View solution in original post

8 Replies
Gopika_Intel
Moderator
662 Views

Hi ,

Thankyou for posting in Intel DevCloud Forum .

Please check these pre requisites while you connect to DevCloud via PuTTY :


1)     Make sure that you have downloaded the correct the keys – SSH keys for windows and the .ppk file is loaded to pageant every time you try to connect.



2)     Check if you are behind a firewall or using a closed internet connection or proxy. If so, kindly try connecting once from an open internet connection to check if the issue has something to do with internet connection


For more details and suggestions regarding connectivity issues, refer

https://community.intel.com/t5/Intel-DevCloud/Getting-Starated-and-Frequently-asked-questions-on-Dev...

Please contact us if you still experience the same issue.


Regards

Gopika


Jones__Brian
New Contributor I
647 Views

Thank you for your reply. The .pdf file you linked to said I must re-load into Pageant before each logon, so I did that (right-click on the ppk key file and select "Load into Pageant"). But I still get the same error message each time I attempt to log on ("Server unexpectedly closed network connection").

My Putty configuration is:

Session:
Host Name or IP address: uXXXXX@c009 (where XXXXX represents my five-digit code provided at first logon).
Connection type: SSH

Connection - Proxy:
Radio button is set to "Local."
Proxy hostname = proxy, port=80.
Telnet command or local proxy command:
"C:\Program Files\PuTTY\plink.exe" guest@devcloud.intel.com -nc %host:%port

Connection - SSH - Auth:

The check boxes are set as the default, including "Attempt authentication using Pageant."

Private key file for authentication: <path>devcloud-access-key-XXXXX.ppk

I am not behind a proxy or filewall. As I said in my first post above, I was able to log on the first time, but I have not had success since then.

I hope that with the information above you can tell me what's wrong.

Thank you.

 

Gopika_Intel
Moderator
632 Views

Hi,

Thank you for the update. We’ve attached the screenshots of configuration settings of putty that have worked for us. Try removing the contents in the ‘private key file for authentication’ field(putty_3.PNG) in Connection->SSH->Auth(It is not a mandatory field..it should be working fine even when the field is populated). Rest of the configurations are same.

Session:

Host Name or IP address: uXXXXX@c009

Port :22

Connection type: SSH

<putty_1.PNG>

 

Connection - Proxy:

Radio button is set to "Local."

Proxy hostname = proxy, port=80.

Telnet command or local proxy command:"C:\Program Files\PuTTY\plink.exe" guest@devcloud.intel.com -nc %host:%port

<putty_2.PNG>

 

Ensure the session is saved and loaded. Try connecting after “load into pageant” step, let us know whether you still have the issue.

Regards

Gopika

 

Jones__Brian
New Contributor I
620 Views

Thank you for your reply and screenshots. I am configured in Putty exactly as shown in your screenshots. Today I found that if I open Pageant first and load the keys (which do not stay autoloaded after shutdown), then open Putty, I was able to log in to DevCloud again. However, less than 5 minutes later I got "Server unexpectedly closed the network connection." After that each new logon got the same message. I am unable to log on again.

In the "Connections" box in Putty the "seconds between keepalives" is set to 0 (turn off).

I use Putty for cloud access at AWS and Oracle and I never have any problems, except that they do not authenticate with Pageant.

Thanks very much for any other ideas. I would really like to use DevCloud.

 

Gopika_Intel
Moderator
607 Views

Hi,

Thank you for the update.

1.    As you are able to connect to devcloud via putty, it seems the error is showing because of screen timeout(We checked it in ours too).

2.    Loading into pageant is needed for connecting after a shutdown

3.    Yes, "Connections" box in Putty the "seconds between keepalives" is set to 0. Screenshot attached <putty_4.PNG>.

4.    Glad to know your interest in devcloud. We would like to suggest alternate methods to connect to intel devcloud like via jupyter notebook, Cygwin, Visual Studio Code or via an ssh client. Please refer https://devcloud.intel.com/oneapi/get_started/ for more information.

Hope this helps you.

Regards

Gopika

 

Gopika_Intel
Moderator
590 Views

Hi,

We haven’t heard from you in awhile. Is your query clarified. Shall we discontinue monitoring this thread. Let us know your updates.

Regards

Gopika


Jones__Brian
New Contributor I
583 Views

Hi,

Thanks for your help.  Yes, you did help me resolve the problem with Pageant. 

Regards,

Brian

 

View solution in original post

Gopika_Intel
Moderator
569 Views

Hi Brian,


Thank you for the confirmation. Glad to know your query has been resolved. We would no longer be monitoring this thread. For further queries and issues please raise a new thread.


Regards

Gopika


Reply