Intel® Distribution for Python*
Engage in discussions with community peers related to Python* applications and core computational packages.
424 Discussions

Can't install MKL as part of miniconda environment inside Docker image


Inside a Dockerfile based on an official miniconda image from I have a step: 

RUN conda env create -n my-env -f=environment.yml

This creates a conda environment based on dependencies listed in environment.yml. One of the dependencies, listed under the pip section of the yaml is mkl==2018.0.3. When creating the environment, conda attempts to do a pip install of mkl version 2018.0.3. Unfortunately, after downloading mkl, the environment creation invariably fails with the error 

CondaValueError: pip returned an error

When running the same command locally – outside the Docker image – the environment is created successfully. I have also tried basing my image off of an Ubuntu image, and manually installing miniconda on top of it. The same error still occurs when I try to create the environment after these steps.

Has anybody else experienced this problem?

0 Kudos
0 Replies