Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
460 Views

ImportError: DLL load failed

    from sklearn.svm import SVR
  File "d:\intelpython3\lib\site-packages\sklearn\__init__.py", line 82, in <module>
    from .daal4sklearn import dispatcher
  File "d:\intelpython3\lib\site-packages\sklearn\daal4sklearn\__init__.py", line 1, in <module>
    from .decision_forest import (DaalRandomForestClassifier, DaalRandomForestRegressor)
  File "d:\intelpython3\lib\site-packages\sklearn\daal4sklearn\decision_forest.py", line 6, in <module>
    import daal4py
  File "d:\intelpython3\lib\site-packages\daal4py\__init__.py", line 2, in <module>
    from _daal4py import *
ImportError: DLL load failed

I have LAtest python Intel distribution but I get this Error.

If I update the daal4py & scikit-learn (out from intel repository) I get warning of compatibility...

0 Kudos
13 Replies
Highlighted
Beginner
460 Views

Someone else ?

0 Kudos
Highlighted
Employee
460 Views

Hi Andre,

the dll load problem is most likely an issue with the MPI package. 

However, the latest version should have this fixed. What's the exact warning you get?

 

frank

0 Kudos
Highlighted
Beginner
460 Views

Frank Schlimbach (Intel) wrote:

Hi Andre,

the dll load problem is most likely an issue with the MPI package. 

However, the latest version should have this fixed. What's the exact warning you get?

 

frank

Thanks for answer me, Frank.

I forced the update of scikit-learn and seem that work Now (but before I got error and incompatibilities) :

conda update scikit-learn
Solving environment: done

## Package Plan ##

  environment location: d:\intelpython3

  added / updated specs:
    - scikit-learn


The following packages will be downloaded:

    package                    |            build
    ---------------------------|-----------------
    conda-4.6.9                |           py36_0         1.7 MB

The following packages will be UPDATED:

    conda:        4.5.13-py36_0            --> 4.6.9-py36_0
    llvmlite:     0.25.0-py36_2      intel --> 0.27.1-py36_0         intel
    menuinst:     1.4.1-py36_6       intel --> 1.4.14-py36hfa6e2cd_0
    numba:        0.40.0-np115py36_3 intel --> 0.42.1-np116py36_0    intel
    numpy:        1.15.4-py36_2      intel --> 1.16.1-py36h7b7c402_3 intel
    numpy-base:   1.15.4-py36_2      intel --> 1.16.1-py36_3         intel
    pytables:     3.4.3-np115py36_6  intel --> 3.4.4-py36he6f6034_0
    scikit-learn: 0.20.0-py36_17     intel --> 0.20.2-py36h7b7c402_2 intel
    scipy:        1.1.0-np115py36_7  intel --> 1.2.0-py36_3          intel

The following packages will be DOWNGRADED:

    hdf5:         1.10.3-vc14_0      intel [vc14] --> 1.10.2-vc14_2         intel [vc14]

 

0 Kudos
Highlighted
Beginner
460 Views

However , the Conda Update want DOWNGRADE !!! :

conda update --all
Collecting package metadata: done
Solving environment: done

## Package Plan ##

  environment location: d:\intelpython3


The following packages will be UPDATED:

  hdf5                                        1.10.2-vc14_2 --> 1.10.3-vc14_0

The following packages will be SUPERSEDED by a higher-priority channel:

  pytables           pkgs/main::pytables-3.4.4-py36he6f603~ --> intel::pytables-3.4.3-np115py36_6

The following packages will be DOWNGRADED:

  llvmlite                                    0.27.1-py36_0 --> 0.25.0-py36_2
  numba                                  0.42.1-np116py36_0 --> 0.40.0-np115py36_3
  numpy                               1.16.1-py36h7b7c402_3 --> 1.15.4-py36_2
  numpy-base                                  1.16.1-py36_3 --> 1.15.4-py36_2
  scikit-learn                        0.20.2-py36h7b7c402_2 --> 0.20.0-py36_17
  scipy                                        1.2.0-py36_3 --> 1.1.0-np115py36_7


Proceed (/n)? n


CondaSystemExit: Exiting.

 

0 Kudos
Highlighted
460 Views

Hi Andre, 

Could you please share the output of conda list --explicit for us to be able to replicate your environment and look into the problem.

I was able to successfully create an environment using 

conda create -n daal4py -c intel --override-channels python=3.6 scikit-learn ipython

This included MPI, and I could import sklearn just fine.

 

0 Kudos
Highlighted
Beginner
460 Views

Hi Oleksandr, my output :

conda list --explicit
# This file may be used to create an environment using:
# $ conda create --name <env> --file <this file>
# platform: win-64
@EXPLICIT
https://repo.continuum.io/pkgs/main/win-64/conda-env-2.6.0-1.tar.bz2
https://conda.anaconda.org/intel/win-64/icc_rt-2019.3-intel_203.tar.bz2
https://conda.anaconda.org/intel/win-64/impi_rt-2019.3-intel_203.tar.bz2
https://conda.anaconda.org/intel/win-64/intel-openmp-2019.3-intel_203.tar.bz2
https://conda.anaconda.org/intel/win-64/intelpython-2019.3-0.tar.bz2
https://conda.anaconda.org/intel/win-64/vs2015_runtime-14.0.25420-intel_2.tar.bz2
https://conda.anaconda.org/intel/win-64/vc-14.0-2.tar.bz2
https://conda.anaconda.org/intel/win-64/bzip2-1.0.6-vc14_17.tar.bz2
https://repo.anaconda.com/pkgs/main/win-64/lzo-2.10-h6df0209_2.tar.bz2
https://conda.anaconda.org/intel/win-64/openssl-1.0.2r-vc14_0.tar.bz2
https://repo.anaconda.com/pkgs/main/win-64/snappy-1.1.7-h777316e_3.tar.bz2
https://conda.anaconda.org/intel/win-64/sqlite-3.27.2-vc14_2.tar.bz2
https://conda.anaconda.org/intel/win-64/tbb-2019.4-vc14_intel_203.tar.bz2
https://conda.anaconda.org/intel/win-64/tcl-8.6.4-vc14_22.tar.bz2
https://conda.anaconda.org/intel/win-64/tk-8.6.4-vc14_28.tar.bz2
https://conda.anaconda.org/intel/win-64/xz-5.2.3-vc14_2.tar.bz2
https://repo.continuum.io/pkgs/main/win-64/yaml-0.1.7-hc54c509_2.tar.bz2
https://conda.anaconda.org/intel/win-64/zlib-1.2.11-vc14h21ff451_5.tar.bz2
https://repo.anaconda.com/pkgs/main/win-64/blosc-1.14.4-he51fdeb_0.tar.bz2
https://conda.anaconda.org/intel/win-64/daal-2019.3-intel_203.tar.bz2
https://conda.anaconda.org/intel/win-64/hdf5-1.10.2-vc14_2.tar.bz2
https://conda.anaconda.org/intel/win-64/libpng-1.6.36-vc14_2.tar.bz2
https://conda.anaconda.org/intel/win-64/mkl-2019.3-intel_203.tar.bz2
https://conda.anaconda.org/intel/win-64/python-3.6.8-6.tar.bz2
https://conda.anaconda.org/intel/win-64/freetype-2.9-vc14_3.tar.bz2
https://repo.continuum.io/pkgs/main/win-64/pywin32-223-py36hfa6e2cd_1.tar.bz2
https://repo.continuum.io/pkgs/main/win-64/menuinst-1.4.14-py36hfa6e2cd_0.tar.bz2
https://conda.anaconda.org/intel/win-64/asn1crypto-0.24.0-py36_3.tar.bz2
https://conda.anaconda.org/intel/win-64/backcall-0.1.0-py36_2.tar.bz2
https://conda.anaconda.org/intel/win-64/backports-1.0-py36_9.tar.bz2
https://conda.anaconda.org/intel/win-64/certifi-2018.1.18-py36_2.tar.bz2
https://conda.anaconda.org/intel/win-64/chardet-3.0.4-py36_3.tar.bz2
https://repo.anaconda.com/pkgs/main/win-64/click-7.0-py36_0.tar.bz2
https://repo.anaconda.com/pkgs/main/win-64/cloudpickle-0.8.0-py36_0.tar.bz2
https://conda.anaconda.org/intel/win-64/colorama-0.3.9-py36_2.tar.bz2
https://conda.anaconda.org/intel/win-64/cython-0.29.3-py36_1.tar.bz2
https://repo.anaconda.com/pkgs/main/win-64/dask-core-1.1.4-py36_1.tar.bz2
https://conda.anaconda.org/intel/win-64/decorator-4.3.0-py36_3.tar.bz2
https://conda.anaconda.org/intel/win-64/entrypoints-0.2.3-py36_2.tar.bz2
https://repo.anaconda.com/pkgs/main/win-64/heapdict-1.0.0-py36_2.tar.bz2
https://conda.anaconda.org/intel/win-64/idna-2.6-py36_3.tar.bz2
https://conda.anaconda.org/intel/win-64/ipython_genutils-0.2.0-py36_2.tar.bz2
https://conda.anaconda.org/intel/win-64/jsonschema-2.6.0-py36_2.tar.bz2
https://conda.anaconda.org/intel/win-64/kiwisolver-1.0.1-py36_2.tar.bz2
https://conda.anaconda.org/intel/win-64/llvmlite-0.27.1-py36_0.tar.bz2
https://repo.anaconda.com/pkgs/main/win-64/locket-0.2.0-py36hfed976d_1.tar.bz2
https://conda.anaconda.org/intel/win-64/markupsafe-1.0-py36_3.tar.bz2
https://conda.anaconda.org/intel/win-64/mistune-0.8.3-py36_2.tar.bz2
https://conda.anaconda.org/intel/win-64/mpi4py-3.0.0-py36_3.tar.bz2
https://conda.anaconda.org/intel/win-64/mpmath-1.0.0-py36_2.tar.bz2
https://repo.anaconda.com/pkgs/main/win-64/msgpack-python-0.5.6-py36he980bc4_1.tar.bz2
https://conda.anaconda.org/intel/win-64/nose-1.3.7-py36_18.tar.bz2
https://conda.anaconda.org/intel/win-64/pandocfilters-1.4.1-py36_2.tar.bz2
https://conda.anaconda.org/intel/win-64/parso-0.2.0-py36_2.tar.bz2
https://conda.anaconda.org/intel/win-64/path.py-11.0.1-py36_2.tar.bz2
https://repo.anaconda.com/pkgs/main/win-64/psutil-5.4.7-py36hfa6e2cd_0.tar.bz2
https://conda.anaconda.org/intel/win-64/pycosat-0.6.3-py36_3.tar.bz2
https://conda.anaconda.org/intel/win-64/pycparser-2.18-py36_2.tar.bz2
https://conda.anaconda.org/intel/win-64/pygments-2.2.0-py36_5.tar.bz2
https://conda.anaconda.org/intel/win-64/pyparsing-2.2.0-py36_2.tar.bz2
https://conda.anaconda.org/intel/win-64/pytz-2018.4-py36_3.tar.bz2
https://conda.anaconda.org/intel/win-64/pyyaml-4.1-py36_3.tar.bz2
https://conda.anaconda.org/intel/win-64/pyzmq-16.0.2-py36_6.tar.bz2
https://conda.anaconda.org/intel/win-64/ruamel_yaml-0.11.14-py36_4.tar.bz2
https://conda.anaconda.org/intel/win-64/simplegeneric-0.8.1-py36_7.tar.bz2
https://conda.anaconda.org/intel/win-64/six-1.11.0-py36_3.tar.bz2
https://repo.anaconda.com/pkgs/main/win-64/sortedcontainers-2.1.0-py36_0.tar.bz2
https://conda.anaconda.org/intel/win-64/tbb4py-2019.4-py36_intel_0.tar.bz2
https://repo.anaconda.com/pkgs/main/win-64/tblib-1.3.2-py36h30f5020_0.tar.bz2
https://conda.anaconda.org/intel/win-64/testpath-0.3.1-py36_2.tar.bz2
https://repo.anaconda.com/pkgs/main/win-64/toolz-0.9.0-py36_0.tar.bz2
https://conda.anaconda.org/intel/win-64/tornado-4.5.2-py36_5.tar.bz2
https://conda.anaconda.org/intel/win-64/wcwidth-0.1.7-py36_6.tar.bz2
https://conda.anaconda.org/intel/win-64/webencodings-0.5.1-py36_0.tar.bz2
https://conda.anaconda.org/intel/win-64/win_inet_pton-1.0.1-py36_4.tar.bz2
https://conda.anaconda.org/intel/win-64/win_unicode_console-0.5-py36_2.tar.bz2
https://conda.anaconda.org/intel/win-64/wincertstore-0.2-py36_3.tar.bz2
https://conda.anaconda.org/intel/win-64/cffi-1.11.5-py36_3.tar.bz2
https://conda.anaconda.org/intel/win-64/cycler-0.10.0-py36_7.tar.bz2
https://repo.anaconda.com/pkgs/main/win-64/cytoolz-0.9.0.1-py36hfa6e2cd_1.tar.bz2
https://conda.anaconda.org/intel/win-64/get_terminal_size-1.0.0-py36_7.tar.bz2
https://conda.anaconda.org/intel/win-64/html5lib-1.0.1-py36_4.tar.bz2
https://conda.anaconda.org/intel/win-64/jedi-0.12.0-py36_2.tar.bz2
https://conda.anaconda.org/intel/win-64/numpy-base-1.16.1-py36_3.tar.bz2
https://repo.anaconda.com/pkgs/main/win-64/packaging-19.0-py36_0.tar.bz2
https://repo.anaconda.com/pkgs/main/win-64/partd-0.3.10-py36_1.tar.bz2
https://conda.anaconda.org/intel/win-64/pickleshare-0.7.4-py36_3.tar.bz2
https://conda.anaconda.org/intel/win-64/prompt_toolkit-1.0.15-py36_2.tar.bz2
https://conda.anaconda.org/intel/win-64/pysocks-1.6.7-py36_1.tar.bz2
https://conda.anaconda.org/intel/win-64/python-dateutil-2.6.0-py36_12.tar.bz2
https://conda.anaconda.org/intel/win-64/setuptools-39.0.1-py36_0.tar.bz2
https://conda.anaconda.org/intel/win-64/sympy-1.3-py36_1.tar.bz2
https://conda.anaconda.org/intel/win-64/traitlets-4.3.2-py36_3.tar.bz2
https://repo.anaconda.com/pkgs/main/win-64/zict-0.1.4-py36_0.tar.bz2
https://conda.anaconda.org/intel/win-64/bleach-2.1.3-py36_2.tar.bz2
https://conda.anaconda.org/intel/win-64/cryptography-2.3-py36_1.tar.bz2
https://repo.anaconda.com/pkgs/main/win-64/distributed-1.26.0-py36_0.tar.bz2
https://conda.anaconda.org/intel/win-64/ipython-6.3.1-py36_3.tar.bz2
https://conda.anaconda.org/intel/win-64/jinja2-2.9.6-py36_2.tar.bz2
https://conda.anaconda.org/intel/win-64/jupyter_core-4.4.0-py36_6.tar.bz2
https://conda.anaconda.org/intel/win-64/wheel-0.31.0-py36_3.tar.bz2
https://conda.anaconda.org/intel/win-64/jupyter_client-5.1.0-py36_5.tar.bz2
https://conda.anaconda.org/intel/win-64/nbformat-4.4.0-py36_2.tar.bz2
https://conda.anaconda.org/intel/win-64/pip-10.0.1-py36_0.tar.bz2
https://conda.anaconda.org/intel/win-64/pyopenssl-17.5.0-py36_2.tar.bz2
https://conda.anaconda.org/intel/win-64/ipykernel-4.6.1-py36_2.tar.bz2
https://conda.anaconda.org/intel/win-64/nbconvert-5.2.1-py36_2.tar.bz2
https://conda.anaconda.org/intel/win-64/urllib3-1.24.1-py36_2.tar.bz2
https://conda.anaconda.org/intel/win-64/ipyparallel-6.0.2-py36_2.tar.bz2
https://conda.anaconda.org/intel/win-64/jupyter_console-5.1.0-py36_2.tar.bz2
https://conda.anaconda.org/intel/win-64/notebook-5.2.2-py36_1.tar.bz2
https://conda.anaconda.org/intel/win-64/requests-2.20.1-py36_1.tar.bz2
https://repo.anaconda.com/pkgs/main/win-64/conda-4.6.9-py36_0.tar.bz2
https://conda.anaconda.org/intel/win-64/widgetsnbextension-3.2.0-py36_1.tar.bz2
https://conda.anaconda.org/intel/win-64/ipywidgets-7.0.0-py36_2.tar.bz2
https://conda.anaconda.org/intel/win-64/jupyter-1.0.0-py36_7.tar.bz2
https://repo.anaconda.com/pkgs/main/win-64/bokeh-0.13.0-py36_0.tar.bz2
https://conda.anaconda.org/intel/win-64/daal4py-2019.3-py36h7b7c402_6.tar.bz2
https://conda.anaconda.org/intel/win-64/matplotlib-2.2.3-py36_0.tar.bz2
https://conda.anaconda.org/intel/win-64/mkl-service-1.0.0-py36_7.tar.bz2
https://conda.anaconda.org/intel/win-64/mkl_fft-1.0.6-py36_2.tar.bz2
https://conda.anaconda.org/intel/win-64/mkl_random-1.0.2-py36_0.tar.bz2
https://conda.anaconda.org/intel/win-64/numpy-1.16.1-py36h7b7c402_3.tar.bz2
https://conda.anaconda.org/intel/win-64/numba-0.42.1-np116py36_0.tar.bz2
https://conda.anaconda.org/intel/win-64/numexpr-2.6.8-py36_1.tar.bz2
https://conda.anaconda.org/intel/win-64/scipy-1.2.0-py36_3.tar.bz2
https://conda.anaconda.org/intel/win-64/pandas-0.23.4-py36_4.tar.bz2
https://repo.anaconda.com/pkgs/main/win-64/pytables-3.4.4-py36he6f6034_0.tar.bz2
https://conda.anaconda.org/intel/win-64/scikit-learn-0.20.2-py36h7b7c402_2.tar.bz2
https://repo.anaconda.com/pkgs/main/win-64/dask-1.1.4-py36_1.tar.bz2

 

0 Kudos
Highlighted
Beginner
460 Views

Oleksandr P. (Intel) wrote:

Hi Andre, 

Could you please share the output of conda list --explicit for us to be able to replicate your environment and look into the problem.

I was able to successfully create an environment using 

conda create -n daal4py -c intel --override-channels python=3.6 scikit-learn ipython

This included MPI, and I could import sklearn just fine.

 

with "conda update scikit-learn" I could import sklearn but Now conda want Update with DOWNGRADE :

conda update --all
Collecting package metadata: done
Solving environment: done

## Package Plan ##

  environment location: d:\intelpython3


The following packages will be UPDATED:

  hdf5                                        1.10.2-vc14_2 --> 1.10.3-vc14_0

The following packages will be SUPERSEDED by a higher-priority channel:

  pytables           pkgs/main::pytables-3.4.4-py36he6f603~ --> intel::pytables-3.4.3-np115py36_6

The following packages will be DOWNGRADED:

  llvmlite                                    0.27.1-py36_0 --> 0.25.0-py36_2
  numba                                  0.42.1-np116py36_0 --> 0.40.0-np115py36_3
  numpy                               1.16.1-py36h7b7c402_3 --> 1.15.4-py36_2
  numpy-base                                  1.16.1-py36_3 --> 1.15.4-py36_2
  scikit-learn                        0.20.2-py36h7b7c402_2 --> 0.20.0-py36_17
  scipy                                        1.2.0-py36_3 --> 1.1.0-np115py36_7


Proceed (/n)? n


CondaSystemExit: Exiting.

 

0 Kudos
Highlighted
Employee
460 Views

Andre,

Thank you. Please also include the output of "conda info" so we can see your channels configuration. That will help us troubleshoot the upgrade/downgrade problem.

Todd

0 Kudos
Highlighted
Beginner
460 Views

Todd T. (Intel) wrote:

Andre,

Thank you. Please also include the output of "conda info" so we can see your channels configuration. That will help us troubleshoot the upgrade/downgrade problem.

Todd

 

Hello Todd , Long time no talk, longing for our conversations.

conda info

     active environment : None
       user config file : C:\Users\andre\.condarc
 populated config files : C:\Users\andre\.condarc
          conda version : 4.6.9
    conda-build version : not installed
         python version : 3.6.8.final.0
       base environment : d:\intelpython3  (writable)
           channel URLs : https://conda.anaconda.org/intel/win-64
                          https://conda.anaconda.org/intel/noarch
                          https://repo.anaconda.com/pkgs/main/win-64
                          https://repo.anaconda.com/pkgs/main/noarch
                          https://repo.anaconda.com/pkgs/free/win-64
                          https://repo.anaconda.com/pkgs/free/noarch
                          https://repo.anaconda.com/pkgs/r/win-64
                          https://repo.anaconda.com/pkgs/r/noarch
                          https://repo.anaconda.com/pkgs/msys2/win-64
                          https://repo.anaconda.com/pkgs/msys2/noarch
          package cache : d:\intelpython3\pkgs
                          C:\Users\andre\.conda\pkgs
                          C:\Users\andre\AppData\Local\conda\conda\pkgs
       envs directories : d:\intelpython3\envs
                          C:\Users\andre\.conda\envs
                          C:\Users\andre\AppData\Local\conda\conda\envs
               platform : win-64
             user-agent : conda/4.6.9 requests/2.20.1 CPython/3.6.8 Windows/10 Windows/10.0.18865
          administrator : False
             netrc file : None
           offline mode : False

 

0 Kudos
Highlighted
Beginner
460 Views

@Todd , how are you ? I hope well... no more answer. I updated everything and now intel python worked. Perhaps the last conda notify show :

The following packages will be UPDATED:

  cloudpickle        pkgs/main/win-64::cloudpickle-0.8.0-p~ --> pkgs/main/noarch::cloudpickle-0.8.1-py_0


Proceed (/n)? n

yes or no ?! because one win64 --> noArch !!

0 Kudos
Highlighted
Employee
460 Views

Andre,

The reason for the downgrading of numpy, numba, and a few other packages is the downgrade of pytables from 3.4.4 to 3.4.3.  The pytables package on the Intel channel was built with older numpy (1.15.4), so when your channel priority settings prefer pytables from the Intel channel, it must use numpy 1.15.4.

From my experience with conda, using "update --all" can produce unexpected results, like the "downgrade" you saw. I almost never use it now, preferring to install the specific versions I want, or update specific packages. I always need to watch carefully the list of package changes before accepting what conda proposes. To prevent an initially proposed downgrade, you can specify the version you want on the "conda install" command line (you cannot specify versions with "conda update", so I prefer "conda install").

As for the change from "win-64" to "noarch", that should have no impact. They must have more correctly classified that package as pure python, and thus applicable to all architectures (noarch) rather than need a separate package for Windows, Linux, and Mac.

Todd

 

0 Kudos
Highlighted
Beginner
460 Views

Thanks for answer, Todd. I know that what I do always "conda update --all" is not good, but then what must I do to update the distribution after it is installed ? Have a good day.

 

Andre

0 Kudos
Highlighted
460 Views

Hello -

I am also getting a .dll error when loading:

import daal4py.sklearn
daal4py.sklearn.patch_sklearn()

conda list

# packages in environment at C:\Users\ShawnDMcDonald\.conda\envs\fdbk-conda:
#
# Name                    Version                   Build  Channel
absl-py                   0.9.0                    pypi_0    pypi
alembic                   1.4.2                    pypi_0    pypi
astor                     0.8.1                    pypi_0    pypi
astroid                   2.3.3                    py37_0
azure-core                1.4.0                    pypi_0    pypi
azure-storage-blob        12.3.1                   pypi_0    pypi
bzip2                     1.0.8                    vc14_1  [vc14]  intel
cachetools                4.1.0                    pypi_0    pypi
certifi                   2019.11.28               py37_0    intel
cffi                      1.14.0                   pypi_0    pypi
chardet                   3.0.4                    pypi_0    pypi
collections-extended      1.0.3                    pypi_0    pypi
colorama                  0.4.3                      py_0
cryptography              2.9.2                    pypi_0    pypi
cycler                    0.10.0                   pypi_0    pypi
daal                      2020.1                intel_216    intel
daal4py                   2020.1           py37ha68da19_0    intel
gast                      0.2.2                    pypi_0    pypi
geos                      3.6.2                h9ef7328_2
google-auth               1.14.1                   pypi_0    pypi
google-auth-oauthlib      0.4.1                    pypi_0    pypi
google-pasta              0.2.0                    pypi_0    pypi
graphviz                  2.38                 hfd603c8_2
grpcio                    1.28.1                   pypi_0    pypi
h5py                      2.10.0                   pypi_0    pypi
icc_rt                    2020.1                intel_216    intel
idna                      2.8                      pypi_0    pypi
imbalanced-learn          0.6.2                    pypi_0    pypi
imblearn                  0.0                      pypi_0    pypi
impi_rt                   2019.7                intel_216    intel
imutils                   0.5.3                    pypi_0    pypi
intel-openmp              2020.1                intel_216    intel
intelpython               2020.1                        0    intel
isodate                   0.6.0                    pypi_0    pypi
isort                     4.3.21                   py37_0
jinja2                    2.10.1                   pypi_0    pypi
joblib                    0.13.2                   py37_1    intel
keras                     2.3.1                    pypi_0    pypi
keras-applications        1.0.8                    pypi_0    pypi
keras-preprocessing       1.1.0                    pypi_0    pypi
keyboard                  0.13.5                   pypi_0    pypi
kiwisolver                1.2.0                    pypi_0    pypi
labelimg                  1.8.3                    pypi_0    pypi
lazy-object-proxy         1.3.1            py37hfa6e2cd_2
lxml                      4.5.0                    pypi_0    pypi
mako                      1.1.2                    pypi_0    pypi
markdown                  3.2.1                    pypi_0    pypi
markupsafe                1.1.1                    pypi_0    pypi
matplotlib                3.2.1                    pypi_0    pypi
mccabe                    0.6.1                    py37_1
mkl                       2020.1                intel_216    intel
mkl-service               2.3.0                    py37_0    intel
mkl_fft                   1.1.0            py37ha68da19_0    intel
mkl_random                1.1.0            py37ha68da19_0    intel
msrest                    0.6.13                   pypi_0    pypi
numpy                     1.17.5           py37ha68da19_1    intel
numpy-base                1.17.5                   py37_1    intel
oauthlib                  3.1.0                    pypi_0    pypi
opencv-python             4.2.0.34                 pypi_0    pypi
openssl                   1.1.1d                   vc14_1  [vc14]  intel
opt-einsum                3.2.1                    pypi_0    pypi
packaging                 20.3                     pypi_0    pypi
pandas                    1.0.3                    pypi_0    pypi
pillow                    7.1.1                    pypi_0    pypi
pip                       19.3.1                   py37_2    intel
protobuf                  3.11.3                   pypi_0    pypi
pyasn1                    0.4.8                    pypi_0    pypi
pyasn1-modules            0.2.8                    pypi_0    pypi
pycparser                 2.20                     pypi_0    pypi
pydot                     1.4.1                    pypi_0    pypi
pylint                    2.4.4                    py37_0
pyodbc                    4.0.30                   pypi_0    pypi
pyparsing                 2.4.7                    pypi_0    pypi
python                    3.7.7                h21ff451_0    intel
python-dateutil           2.8.1                    pypi_0    pypi
python-editor             1.0.4                    pypi_0    pypi
python-graphviz           0.14                     pypi_0    pypi
pytz                      2019.3                   pypi_0    pypi
pyyaml                    5.3.1                    pypi_0    pypi
requests                  2.22.0                   pypi_0    pypi
requests-oauthlib         1.3.0                    pypi_0    pypi
rsa                       4.0                      pypi_0    pypi
scikit-learn              0.22.1          py37ha68da19_10    intel
scipy                     1.4.1                    pypi_0    pypi
setuptools                45.2.0                   py37_0    intel
shapely                   1.6.4            py37hc90234e_0
six                       1.13.0                   py37_2    intel
sqlalchemy                1.3.16                   pypi_0    pypi
sqlite                    3.30.1                   vc14_6  [vc14]  intel
tbb                       2020.2           vc14_intel_216  [vc14]  intel
tbb4py                    2020.2             py37_intel_0  [vc14]  intel
tcl                       8.6.9                   vc14_24  [vc14]  intel
tensorboard               1.15.0                   pypi_0    pypi
tensorflow-estimator      1.15.1                   pypi_0    pypi
tensorflow-gpu            1.15.2                   pypi_0    pypi
termcolor                 1.1.0                    pypi_0    pypi
tk                        8.6.9                   vc14_29  [vc14]  intel
toml                      0.10.0                   pypi_0    pypi
tqdm                      4.45.0                   pypi_0    pypi
urllib3                   1.25.9                   pypi_0    pypi
vc                        14.0                          2    intel
vs2015_runtime            14.0.25420              intel_3    intel
werkzeug                  1.0.1                    pypi_0    pypi
wheel                     0.33.6                   py37_4    intel
wincertstore              0.2                      py37_3    intel
wrapt                     1.12.1                   pypi_0    pypi
xz                        5.2.4                    vc14_5  [vc14]  intel
zlib                      1.2.11.1         vc14hfa6e2cd_1  [vc14]  intel

 

 

conda info

active environment : fdbk-conda
    active env location : C:\Users\ShawnDMcDonald\.conda\envs\fdbk-conda
            shell level : 1
       user config file : C:\Users\ShawnDMcDonald\.condarc
 populated config files : C:\Users\ShawnDMcDonald\.condarc
          conda version : 4.8.2
    conda-build version : 3.18.11
         python version : 3.7.6.final.0
       virtual packages : __cuda=10.2
       base environment : D:\Anaconda  (writable)
           channel URLs : https://conda.anaconda.org/intel/win-64
                          https://conda.anaconda.org/intel/noarch
                          https://repo.anaconda.com/pkgs/main/win-64
                          https://repo.anaconda.com/pkgs/main/noarch
                          https://repo.anaconda.com/pkgs/r/win-64
                          https://repo.anaconda.com/pkgs/r/noarch
                          https://repo.anaconda.com/pkgs/msys2/win-64
                          https://repo.anaconda.com/pkgs/msys2/noarch
          package cache : D:\Anaconda\pkgs
                          C:\Users\ShawnDMcDonald\.conda\pkgs
                          C:\Users\ShawnDMcDonald\AppData\Local\conda\conda\pkgs
       envs directories : D:\Anaconda\envs
                          C:\Users\ShawnDMcDonald\.conda\envs
                          C:\Users\ShawnDMcDonald\AppData\Local\conda\conda\envs
               platform : win-64
             user-agent : conda/4.8.2 requests/2.22.0 CPython/3.7.6 Windows/10 Windows/10.0.18362
          administrator : True
             netrc file : None
           offline mode : False

0 Kudos