Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Maffei__Davide
Beginner
326 Views

Cannot load library 'myriadPlugin.dll' - Win10

Hi community,

I'm trying to USE MYRIAD X NCS2 on Win10. OpenVINO installed both in version R3 and R2.0.1-.

Using the demo file demo_squeezenet_download_convert_run.bat -d MYRIAD I get this error:on Inference task

An error popup comes out "The procedure GetThreadDescription entry point cannot be found in the dynamic link library C:\Program Files (x86)\IntelSWTools\openvino\deployment_tools\inference_engine\bin\intel64\Release\myriadPlugin.dll".

A snippet of the log of the demo program follows:

###############|| Run Inference Engine classification sample ||###############


In attesa da 0 secondi. Premere un tasto per continuare...
        1 file copiati.
classification_sample_async.exe -i "C:\Program Files (x86)\IntelSWTools\openvino\deployment_tools\demo\\car.png" -m "C:\Users\EPF\Documents\Intel\OpenVINO\openvino_models\ir\FP16\public\squeezenet1.1\squeezenet1.1.xml" -d MYRIAD
[ INFO ] InferenceEngine:
        API version ............ 2.1
        Build .................. 30677
        Description ....... API
[ INFO ] Parsing input parameters
[ INFO ] Parsing input parameters
[ INFO ] Files were added: 1
[ INFO ]     C:\Program Files (x86)\IntelSWTools\openvino\deployment_tools\demo\\car.png
[ INFO ] Creating Inference Engine
[ ERROR ] Failed to create plugin C:\Program Files (x86)\IntelSWTools\openvino\deployment_tools\inference_engine\bin\intel64\Release\myriadPlugin.dll for device MYRIAD
Please, check your environment
Cannot load library 'C:\Program Files (x86)\IntelSWTools\openvino\deployment_tools\inference_engine\bin\intel64\Release\myriadPlugin.dll': 127 from cwd: C:\Users\EPF\Documents\Intel\OpenVINO\inference_engine_samples_build\intel64\Release

Error

Attached the whole log file.

NCS2 is visible in Device Manager, OpenVino installation seems fine,.model optimizer seems to work.

Any Ideas what is going on?  Miss something from my system?

Thank you in advance

 

 

0 Kudos
4 Replies
Anthony_L_Intel1
Employee
326 Views

If I understood the issue you face, let me rephrase: You were using R2 and running the demo worked prior.  Now you have installed R3 and the same demo app is now broken.

Have you tried renaming to something else (or deleting) C:\Users\EPF\Documents\Intel\OpenVINO and trying the demo again?  As a rule I delete this folder when moving open vino versions.  Also, if you're keeping multiple openvino installations and switching back and forth, make sure C:\Program Files (x86)\IntelSWTools\openvino shortcut points to the one you think it should.  Usually I just uninstall the prior release before installing another.

Hope that helps,

Anthony

 

Maffei__Davide
Beginner
326 Views

Hello Anthony L.,

Sorry what I said is that I've tried two times the demo file with both versions.

Before I've tried R3 2019 but that gives me the error above.

I have uninstalled R3, cleaned all files and installed R2.0.1 but I get the same error you see above. 

I saw this post:

https://forums.intel.com/s/question/0D50P00004TJ45x/problems-with-2019r3?language=de 

And I was believing that the problem is regarding latest R3 version.

I followed the official guides for installing and configuring

https://docs.openvinotoolkit.org/latest/_docs_install_guides_installing_openvino_windows.html#hddl-m...

 

I'm getting crazy! I cannot use Linux for that Application (even if I jnow that it work for sure because usually I use that OS).

 

Anthony_L_Intel1
Employee
326 Views

Maffei, Davide wrote:

I followed the official guides for installing and configuring

https://docs.openvinotoolkit.org/latest/_docs_install_guides_installing_...

FYI, the link you provided is for a different kick off arg (-d HDDL vs -d MYRIAD) and none of that is needed to run the neural compute stick.  To verify the previous statement I tried from a fresh R3 install on win 10 using the ncs (not ncs2 as you used but expect same result) and it works via the windows usb driver - without additional steps you linked to.  It can be confusing with the number of myriad based devices to know which docs to follow.

 

Regards,

Anthony

 

 

Sahira_Intel
Moderator
326 Views

Hi Davide,

It looks like you did not install the Inference Engine Runtime for Intel Movidius VPU. When you're installing OpenVINO R3 via the GUI, be sure to check all the boxes under "Inference Engine" when choosing which components to install. 

Please let me know if you have any further questions!

Best Regards,
Sahira 

Reply