Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Soni__Neha
Beginner
149 Views

[ ERROR ] Following layers are not supported by the plugin for specified device MYRIAD: input_1, lstm1/while/LoopCond/TensorIte

HI I am trying to run deel learning model on MYRIAD device. There were 3 model whose output act as input to LSTM. LSTM output is final output. When I am trying to run inference on OpenVINO R2. It shows me error on console--- [ ERROR ] Following layers are not supported by the plugin for specified device MYRIAD: input_1, lstm1/while/LoopCond/TensorIteratorCondition_/TensorIterator And when I am run this on CPU ,it works perfectly. Please do needful.Looking forward.
0 Kudos
4 Replies
Shubha_R_Intel
Employee
149 Views

Dear Soni, Neha,

According to the Supported Devices Doc TensorIterator is definitely supported on VPU (MYRIAD).  LSTM is also supported by MYRIAD. I  have PM'd you so that you can send me your model privately as a *.zip file. This may be a bug.

Thanks,

Shubha

Soni__Neha
Beginner
149 Views

Hi @Shubha, I have received your mail but I can't share model and inferencing script as per organization policy. Please suggest another way how can I convey you about the issue?
Shubha_R_Intel
Employee
149 Views

Dear Soni, Neha,

As I answered on your github post, you can supply me with a small demo model and inference script which demonstrates the issue.

Happy to help !

Thanks,

Shubha

 

 

Sielski__Marcin
Beginner
149 Views

Hi,

I am experiencing similar issue on MYRIAD.

Unsupported layers found: ['input', 'h0', 'fc.bias/Output_0/Data_/copy_const', 'c0', '37/TensorIterator', '63/TensorIterator', '71'] Check whether extensions are available to add to IECore.

The model was converted from ONNX format.

Best Regards

Marcin Sielski

Reply