Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Kurniawan__Sonny
Beginner
70 Views

Error when running sample script

Hi, first of all, thanks for OpenVino.

I'm having trouble running the demo sample with the following error.

Model Optimizer version:        2019.3.0-375-g332562022
[ ERROR ]  -------------------------------------------------
[ ERROR ]  ----------------- INTERNAL ERROR ----------------
[ ERROR ]  Unexpected exception happened.
[ ERROR ]  Please contact Model Optimizer developers and forward the following information:
[ ERROR ]  'Graph' object has no attribute 'node'
[ ERROR ]  Traceback (most recent call last):
  File "D:\Libraries\openvino\openvino_2019.3.334\deployment_tools\model_optimizer\mo\main.py", line 302, in main
    return driver(argv)
  File "D:\Libraries\openvino\openvino_2019.3.334\deployment_tools\model_optimizer\mo\main.py", line 261, in driver
    custom_layers_mapping_path=custom_layers_mapping_path)
  File "D:\Libraries\openvino\openvino_2019.3.334\deployment_tools\model_optimizer\mo\pipeline\caffe.py", line 65, in driver
    graph, original_shapes = loader.caffe_pb_to_nx(proto, model)
  File "D:\Libraries\openvino\openvino_2019.3.334\deployment_tools\model_optimizer\mo\front\caffe\loader.py", line 294, in caffe_pb_to_nx
    graph.add_node(layer.name, pb=layer, model_pb=model_layer, kind='op', type='Parameter')
  File "D:\Libraries\openvino\openvino_2019.3.334\deployment_tools\model_optimizer\mo\graph\graph.py", line 505, in add_node
    node.update_node()
  File "D:\Libraries\openvino\openvino_2019.3.334\deployment_tools\model_optimizer\mo\graph\graph.py", line 470, in update_node
    in_ports_count = self.in_ports_count if self.has_valid('in_ports_count') else None
  File "D:\Libraries\openvino\openvino_2019.3.334\deployment_tools\model_optimizer\mo\graph\graph.py", line 161, in has_valid
    return self.has(k) and not self.graph.node[self.node] is None
  File "D:\Libraries\openvino\openvino_2019.3.334\deployment_tools\model_optimizer\mo\graph\graph.py", line 158, in has
    return k in self.graph.node[self.node]
AttributeError: 'Graph' object has no attribute 'node'

[ ERROR ]  ---------------- END OF BUG REPORT --------------
[ ERROR ]  -------------------------------------------------
Error

 

I'm using open vino 2019.3.334 on Windows 10

0 Kudos
2 Replies
Monique_J_Intel
Employee
70 Views

Hi Sonny,

Which demo sample are you running? What command are you using to execute it?

Kind Regards,

Monique Jones

JesusE_Intel
Moderator
70 Views

Hi Sonny,

This is a known issue with the OpenVINO toolkit 2019 R3 release. The latest release contains the fix, please download OpenVINO toolkit 2019 R3.1. Basically, there is a compatibility issue with the latest netoworkx python library.

You can also fix the issue by manually installing networkx version 2.3 with pip3 install networkx==2.3 but I recommend installing the latest OpenVINO version.

Regards,

Jesus

Reply