Community
cancel
Showing results for 
Search instead for 
Did you mean: 
idata
Community Manager
915 Views

FileNotFoundError: [Errno 2] No such file or directory: '../../caffe/SSD_MobileNet/graph'

Hello! ……. I'm not sure what is going on here, error below:

 

I tried making the graph with MVCNCCompile, but that failed due to 'list index out of range'.

 

Please help! …… Thanks.

 

` pi@raspberrypi:~ $ cd /home/pi/ncappzoo/apps/security-cam

 

pi@raspberrypi:~/ncappzoo/apps/security-cam $ make run

 

================================================================ Making MobileNet SSD... make[1]: Entering directory '/home/pi/ncappzoo/caffe/SSD_MobileNet' making caffemodel caffemodel already exists, skipping download. making prototxt Prototxt file already exists, skipping download. if [ -e merge_bn.py ] ; \ then \ echo "merge_bn.py already exists. skipping download."; \ else \ echo ""; \ echo "Attempting download of merge_bn.py from this url: "; \ echo "https://raw.githubusercontent.com/chuanqi305/MobileNet-SSD/master/merge_bn.py"; \ wget -P . https://raw.githubusercontent.com/chuanqi305/MobileNet-SSD/master/merge_bn.py; \ python3 merge_bn.py --model deploy.prototxt --weight mobilenet_iter_73000.caffemodel; \ fi; \ merge_bn.py already exists. skipping download. making compile mvNCCompile v02.00, Copyright @ Movidius Ltd 2016 /usr/lib/python3/dist-packages/scipy/_lib/_numpy_compat.py:10: DeprecationWarning: Importing from numpy.testing.nosetester is deprecated, import from numpy.testing instead. from numpy.testing.nosetester import import_nose /usr/lib/python3/dist-packages/scipy/stats/morestats.py:16: DeprecationWarning: Importing from numpy.testing.decorators is deprecated, import from numpy.testing instead. from numpy.testing.decorators import setastest [Error 9] Argument Error: Network weight cannot be found. make[1]: Leaving directory '/home/pi/ncappzoo/caffe/SSD_MobileNet' Done! See ../../caffe/SSD_MobileNet/graph. ================================================================ Running security-cam.py... python3 security-cam.py --video 0 Traceback (most recent call last): File "security-cam.py", line 219, in <module> main() File "security-cam.py", line 152, in main graph = load_graph( device ) File "security-cam.py", line 57, in load_graph with open( ARGS.graph, mode='rb' ) as f: FileNotFoundError: [Errno 2] No such file or directory: '../../caffe/SSD_MobileNet/graph' Makefile:18: recipe for target 'run' failed make: *** [run] Error 1 pi@raspberrypi:~/ncappzoo/apps/security-cam $ `
Tags (1)
0 Kudos
3 Replies
idata
Community Manager
510 Views

Hi @TegwynTwmffat

 

I believe you installed the NCSDK in API-only mode on your Raspberry PI. If that is the case, you will need to copy the graph from a development machine with the full SDK installed.

 

Take a look at section Bonus step: Deploying a pre-compiled graph file after step 3 in the following guide:

 

https://movidius.github.io/blog/ncs-apps-on-rpi/

 

Hope this helps!

 

Regards,

 

Jesus
idata
Community Manager
510 Views

I've got this installed: mvNCCompile v02.00, Copyright @ Movidius Ltd 2016

 

…. Is that not in the SDK rather than the API ???

 

I tried to use the mvNCCompile v02.00, Copyright @ Movidius Ltd 2016 to create a graph but it failed. I'd like to have it working if possible.

 

I posted another thread on that error.

 

I found a suitable graph file, thanks, please could you confirm I have SDK installed and maybe answer my other thread question?

 

Thanks !!!

PMark13
Beginner
510 Views

To get rid of this error you can try using Python file exists methods to check that at least python sees the file exists or not. In other words, you can make sure that the user has indeed typed a correct path for a real existing file. If the user does not pass the full path to the file, the path is interpreted relatively to the current working directory. The current working directory usually is the directory in which you started the program. 

 

 

Reply