Community
cancel
Showing results for 
Search instead for 
Did you mean: 
YUBIN__XIAO
Beginner
111 Views

I can't reproduce your CRNN steps, Can't Convert the model into IR

Follow yours guide:

https://docs.openvinotoolkit.org/latest/_docs_MO_DG_prepare_model_convert_model_tf_specific_Convert_...

Can't Convert the model into IR

[ ERROR ]  Cannot infer shapes or values for node "shadow/LSTMLayers/stack_bidirectional_rnn/cell_0/bidirectional_rnn/fw/fw/while/LoopCond".
[ ERROR ]  graph_def is invalid at node 'shadow/LSTMLayers/stack_bidirectional_rnn/cell_0/bidirectional_rnn/fw/fw/while/LoopCond': Input tensor 'shadow/LSTMLayers/stack_bidirectional_rnn/cell_0/bidirectional_rnn/fw/fw/while/Less_port_0_ie_placeholder:0' Cannot convert a tensor of type int32 to an input of type bool.
[ ERROR ]  
[ ERROR ]  It can happen due to bug in custom shape infer function <function tf_native_tf_node_infer at 0x7f7569b70bf8>.
[ ERROR ]  Or because the node inputs have incorrect values/shapes.
[ ERROR ]  Or because input shapes are incorrect (embedded to the model or passed via --input_shape).
[ ERROR ]  Run Model Optimizer with --log_level=DEBUG for more information.
[ ERROR ]  Exception occurred during running replacer "REPLACEMENT_ID" (<class 'extensions.middle.PartialInfer.PartialInfer'>): Stopped shape/value propagation at "shadow/LSTMLayers/stack_bidirectional_rnn/cell_0/bidirectional_rnn/fw/fw/while/LoopCond" node. 
 For more information please refer to Model Optimizer FAQ (<INSTALL_DIR>/deployment_tools/documentation/docs/MO_FAQ.html), question #38. 

the attachment is my debug information.

0 Kudos
3 Replies
YUBIN__XIAO
Beginner
111 Views

Waiting for your reply

Shubha_R_Intel
Employee
111 Views

Dear YUBIN, XIAO,

You are using the correct steps. If it doesn't work, then it may be a bug - and I'm assuming that you are using the latest OpenVino 2019R1.1. Let me try and reproduce it. Thanks for your patience,

Shubha

Shubha_R_Intel
Employee
111 Views

Dear YUBIN, XIAO,

I just now tried exactly the steps outlined in Convert CRNN Models Doc and I had no issues. The specified Model Optimizer command on OpenVino R2019R1.1 produced IR successfully.

My guess is that you didn't install OpenVino properly, perhaps you forgot to install the Model Optimizer pre-requisites ? I'm also on Tensorflow 1.12.0 if it helps.

Thanks,

Shubha

 

Reply