Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Community Manager
333 Views

Install SDK Error - Please help

Hi, I got installation failed error like below, anyone can help? Thanks!!! (my Environment, Ubuntu16.04, GCC - 4.8, Python 3.5, OpenCV 3.1) /usr/lib/x86_64-linux-gnu/libopencv_highgui.so.2.4.9:对‘TIFFWriteScanline@LIBTIFF_4.0’未定义的引用 //usr/lib/x86_64-linux-gnu/libsoxr.so.0:对‘GOMP_parallel@GOMP_4.0’未定义的引用 ../lib/libcaffe.so.1.0.0:对‘google::protobuf::internal::empty_string_’未定义的引用 ../lib/libcaffe.so.1.0.0:对‘google::protobuf::MessageLite::ParseFromString(std::string const&)’未定义的引用 /usr/lib/x86_64-linux-gnu/libopencv_highgui.so.2.4.9:对‘TIFFGetField@LIBTIFF_4.0’未定义的引用 /usr/lib/x86_64-linux-gnu/libopencv_highgui.so.2.4.9:对‘TIFFScanlineSize@LIBTIFF_4.0’未定义的引用 /usr/lib/gcc/x86_64-linux-gnu/4.8/../../../x86_64-linux-gnu/libboost_python.so:对‘PyString_AsString’未定义的引用 ../lib/libcaffe.so.1.0.0:对‘google::protobuf::internal::NameOfEnum(google::protobuf::EnumDescriptor const*, int)’未定义的引用 ../lib/libcaffe.so.1.0.0:对‘cv::imread(std::string const&, int)’未定义的引用 /usr/lib/x86_64-linux-gnu/libopencv_highgui.so.2.4.9:对‘TIFFReadEncodedTile@LIBTIFF_4.0’未定义的引用 /usr/lib/x86_64-linux-gnu/libopencv_highgui.so.2.4.9:对‘TIFFReadRGBATile@LIBTIFF_4.0’未定义的引用 /usr/lib/gcc/x86_64-linux-gnu/4.8/../../../x86_64-linux-gnu/libboost_python.so:对‘PyString_FromFormat’未定义的引用 /usr/lib/x86_64-linux-gnu/libopencv_highgui.so.2.4.9:对‘TIFFClose@LIBTIFF_4.0’未定义的引用 ../lib/libcaffe.so.1.0.0:对‘google::protobuf::internal::ArenaStringPtr::AssignWithDefault(std::string const*, google::protobuf::internal::ArenaStringPtr)’未定义的引用 ../lib/libcaffe.so.1.0.0:对‘google::protobuf::DescriptorPool::FindFileByName(std::string const&) const’未定义的引用 /usr/lib/x86_64-linux-gnu/libopencv_highgui.so.2.4.9:对‘TIFFRGBAImageOK@LIBTIFF_4.0’未定义的引用 ../lib/libcaffe.so.1.0.0:对‘google::protobuf::internal::WireFormatLite::ReadBytes(google::protobuf::io::CodedInputStream*, std::string*)’未定义的引用 /usr/lib/gcc/x86_64-linux-gnu/4.8/../../../x86_64-linux-gnu/libboost_python.so:对‘PyClass_Type’未定义的引用 /usr/lib/gcc/x86_64-linux-gnu/4.8/../../../x86_64-linux-gnu/libboost_python.so:对‘PyString_FromString’未定义的引用 /usr/lib/gcc/x86_64-linux-gnu/4.8/../../../x86_64-linux-gnu/libboost_python.so:对‘PyFile_AsFile’未定义的引用 /usr/lib/gcc/x86_64-linux-gnu/4.8/../../../x86_64-linux-gnu/libboost_python.so:对‘Py_InitModule4_64’未定义的引用 /usr/lib/x86_64-linux-gnu/libopencv_highgui.so.2.4.9:对‘TIFFOpen@LIBTIFF_4.0’未定义的引用 ../lib/libcaffe.so.1.0.0:对‘google::protobuf::MessageFactory::InternalRegisterGeneratedFile(char const*, void (*)(std::string const&))’未定义的引用 /usr/lib/gcc/x86_64-linux-gnu/4.8/../../../x86_64-linux-gnu/libboost_python.so:对‘PyInt_Type’未定义的引用 ../lib/libcaffe.so.1.0.0:对‘leveldb::DB::Open(leveldb::Options const&, std::string const&, leveldb::DB**)’未定义的引用 /usr/lib/gcc/x86_64-linux-gnu/4.8/../../../x86_64-linux-gnu/libboost_python.so:对‘PyInt_FromLong’未定义的引用 ../lib/libcaffe.so.1.0.0:对‘cv::imencode(std::string const&, cv::_InputArray const&, std::vector<unsigned char, std::allocator<unsigned char> >&, std::vector<int, std::allocator<int> > const&)’未定义的引用 /usr/lib/gcc/x86_64-linux-gnu/4.8/../../../x86_64-linux-gnu/libboost_python.so:对‘PyFile_FromString’未定义的引用 /usr/lib/x86_64-linux-gnu/libopencv_highgui.so.2.4.9:对‘TIFFReadEncodedStrip@LIBTIFF_4.0’未定义的引用 /usr/lib/x86_64-linux-gnu/libopencv_highgui.so.2.4.9:对‘TIFFSetField@LIBTIFF_4.0’未定义的引用 ../lib/libcaffe.so.1.0.0:对‘google::protobuf::internal::WireFormatLite::WriteBytesMaybeAliased(int, std::string const&, google::protobuf::io::CodedOutputStream*)’未定义的引用 /usr/lib/gcc/x86_64-linux-gnu/4.8/../../../x86_64-linux-gnu/libboost_python.so:对‘PyNumber_Divide’未定义的引用 /usr/lib/gcc/x86_64-linux-gnu/4.8/../../../x86_64-linux-gnu/libboost_python.so:对‘PyString_Type’未定义的引用 /usr/lib/x86_64-linux-gnu/libopencv_highgui.so.2.4.9:对‘TIFFSetWarningHandler@LIBTIFF_4.0’未定义的引用 /usr/lib/x86_64-linux-gnu/libopencv_highgui.so.2.4.9:对‘TIFFSetErrorHandler@LIBTIFF_4.0’未定义的引用 ../lib/libcaffe.so.1.0.0:对‘leveldb::Status::ToString() const’未定义的引用 ../lib/libcaffe.so.1.0.0:对‘google::protobuf::internal::WireFormatLite::WriteString(int, std::string const&, google::protobuf::io::CodedOutputStream*)’未定义的引用 collect2: error: ld returned 1 exit status tools/CMakeFiles/upgrade_solver_proto_text.dir/build.make:130: recipe for target 'tools/upgrade_solver_proto_text' failed make[2]: *** [tools/upgrade_solver_proto_text] Error 1 CMakeFiles/Makefile2:467: recipe for target 'tools/CMakeFiles/upgrade_solver_proto_text.dir/all' failed make[1]: *** [tools/CMakeFiles/upgrade_solver_proto_text.dir/all] Error 2 Makefile:127: recipe for target 'all' failed make: *** [all] Error 2 Installation failed. Error on line 129
0 Kudos
1 Reply
Highlighted
Community Manager
19 Views

@seaview28 Hi, may I have more information regarding your system and environment (OS? x86? 64 bit?)? Did you have OpenCV and Anaconda installed beforehand? Your situation may be related to https://ncsforum.movidius.com/discussion/247/caffe-build-error#latest.

0 Kudos