Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Community Manager
1,059 Views

Makefile:47: recipe for target 'install' failed

libprotobuf-dev : Depends: libprotobuf9 (= 2.6.1-1) but it is not going to be i nstalled

 

libsnappy-dev : Depends: libsnappy1 (= 1.1.2-3) but it is not going to be insta lled

 

libstdc++6 : Breaks: python3-scipy (<= 0.14.1-1) but 0.14.0-2 is to be installe d

 

libxml2-dev : Depends: libxml2 (= 2.9.1+dfsg1-5+deb8u6) but 2.9.4+dfsg1-2.2+deb 9u2 is to be installed

 

libxslt1-dev : Depends: libxslt1.1 (= 1.1.28-2+deb8u3) but it is not going to b e installed

 

protobuf-compiler : Depends: libprotobuf9 but it is not going to be installed

 

Depends: libprotoc9 (= 2.6.1-1) but it is not going to be i nstalled

 

python3-scipy : Depends: python3 (< 3.5) but 3.5.3-1 is to be installed

 

Recommends: g++ but it is not going to be installed or

 

c++-compiler

 

python3-yaml : Depends: python3 (< 3.5) but 3.5.3-1 is to be installed

 

E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

 

Installation failed: Command 'sudo apt-get install -y unzip coreutils curl git python3 libprotobuf-dev libleveldb-dev libsnappy-dev libopencv-dev libhdf5-seria l-dev protobuf-compiler libatlas-base-dev git python3-dev python3-numpy automake cmake make byacc lsb-release python3-scipy libgflags-dev libgoogle-glog-dev lib lmdb-dev swig3.0 graphviz libxslt-dev libxml2-dev gfortran python3-yaml python3- nose python-numpy python3-tk python3-pip python-pip tar wget libgraphviz-dev' re turn code=100. Error on line 308 in ./install-utilities.sh. Will exit

 

Makefile:47: recipe for target 'install' failed

 

make: *** [install] Error 131

 

pi@raspberrypi:~/workspace/ncsdk $
Tags (1)
0 Kudos
6 Replies
Highlighted
Community Manager
190 Views

@zd6963 Which version of the NCSDK are you trying to install? Additionally is this on a fresh Raspberry Pi? If possible, I recommend installing on a fresh Raspberry Pi.

0 Kudos
Highlighted
Community Manager
190 Views

Hi I wanna install movidius to Raspberry but ı can not install. beacuse NCSDK2 version give make file 47 error when start to make install . NCSDKv1 is completed on Raspberry but NCSDKv2 not completed. Please help to me how can install this version on Raspberry. I am using datas on this link https://github.com/movidius/ncsdk. There is a only one link about NCSDK. I am so sad due to not installing movidius on raspberry. I am waiting your answer.

0 Kudos
Highlighted
Community Manager
190 Views

Firstly, I installed ncsdk1 with using this link git clone

 

https://github.com/movidius/ncsdk.git.

 

Secondly, I used following command to clone the ncsdk2 branch

 

git clone -b ncsdk2 https://github.com/movidius/ncsdk.git

 

and then when ı branched ncsdk2 installer said to us: ncsdk folder already exists.

 

Thirdly, when ı clone in different folder name , the ncsdk2 installer say the opencv already installed and it try to uninstall opencv. when ı ask to this question of uninstalling ı pressed (y) can not uninstall. When ı

 

pressed (n) , installer did not install. At this point what can ı do ?

 

Best, ilgindogan

0 Kudos
Highlighted
Community Manager
190 Views

@ilgindogan94 When you press "y" to uninstall OpenCV, what is the error you are receiving? Maybe you don't have permission to uninstall? A possible solution is to edit the install-opencv.sh and uninstall-opencv.sh scripts and remove the contents to prevent the installation process from uninstalling your current opencv and installing a new opencv version. However there is no guarantee that your installed version of opencv will work with the samples in the ncsdk and ncappzoo.

0 Kudos
Highlighted
Community Manager
190 Views

@Tome_at_Intel you said that '' > However there is no guarantee that your installed version of opencv will work with the samples in the ncsdk and ncappzoo. '' we edited install-opencv.sh and compiled NCSDK 2X, but the Tensorflow and OpenCV not work properly, at this point what can I do?

 

Best, Vahid

0 Kudos
Highlighted
Community Manager
190 Views

@Vahid_Faryad If you are using Ubuntu 16, try running the following commands to install openCV: pip3 install opencv-python

 

and then pip3 install opencv-contrib-python
0 Kudos