Community
cancel
Showing results for 
Search instead for 
Did you mean: 
aag
Novice
254 Views

Model Optimizer: Problem with requirements_tf.txt

Model converter has developed an ailment, where using the requirements in requirements_tf.txt (as of 2020.1) results in the following error:

Collecting futures>=2.2.0; python_version < "3.2" (from grpcio>=1.8.6->tensorflow<2.0.0,>=1.2.0->-r /home/insectoidsombrero/.conan/data/openvinomo/2020.1.023.70+6813447a/sighthound/master/package/4db1be536558d833e52e862fd84d64d75c2b3656/bin/../requirements_tf.txt (line 1))
  Downloading https://files.pythonhosted.org/packages/47/04/5fc6c74ad114032cd2c544c575bffc17582295e9cd6a851d6026ab...
    Complete output from command python setup.py egg_info:
    This backport is meant only for Python 2.
    It does not work on Python 3, and Python 3 users do not need it as the concurrent.futures package is available in the standard library.
    For projects that work on both Python 2 and 3, the dependency needs to be conditional on the Python version, like so:
    extras_require={':python_version == "2.7"': ['futures']}

(full setup output attached). I've been able to lock down the requirements using previous successful conversion -- changing from:

tensorflow>=1.2.0,<2.0.0
networkx>=1.11
numpy>=1.12.0
defusedxml>=0.5.0

to:

grpcio==1.24.1
tensorflow==1.14.0
networkx==2.3
numpy==1.17.2
defusedxml==0.6.0

 

Seems to fix things. Not sure if 2020.2 fixes it.

 

 

 

 

0 Replies
Reply