Community
cancel
Showing results for 
Search instead for 
Did you mean: 
idata
Community Manager
309 Views

NCSDK2.08.01.02 ValueError compiling graph

i`m trying to compile graph from model built on Keras -> converted to TF using NCSDK2.08.01.02. The traceback is:

 

File "/usr/local/bin/ncsdk/Controllers/TensorFlowParser.py", line 1480, in parse_tensor

 

if axis != len(output_shape) - 1:

 

ValueError: The truth value of an array with more than one element is ambiguous. Use a.any() or a.all()

 

on older SDK 1.12 the ERROR is -> Toolkit Error: Stage Details Not Supported: Square

 

Please check my models:

 

Keras: https://drive.google.com/drive/folders/1I1fc4qfxCVRZg54cM1t2d8Ze0jAaWoLZ?usp=sharing

 

TF: https://drive.google.com/drive/folders/1s67N-FziFUHt-DCaXM68u9Esz_n09p6-?usp=sharing
Tags (1)
0 Kudos
1 Reply
idata
Community Manager
70 Views

Hi @civilism

 

We have seen issues when converting models from Keras to TensorFlow to NCS Graph file. It's possible the issue may be with the conversion or the Tensorflow layer not being supported on the NCSDK. I would like to try to turn your model into the NCS graph. Could you share the input and output node names?

 

Also, try to enable the debug option in the tenserflow parser, this could provide us additional information about the error. You will need to set the debug flag to True in the following file as sudo:

 

/usr/local/bin/ncsdk/Controllers/Parsers/TensorFlow.py

 

Regards,

 

Jesus