Intel® Distribution of OpenVINO™ Toolkit
Community support and discussions about the Intel® Distribution of OpenVINO™ toolkit, OpenCV, and all things computer vision-related on Intel® platforms.
5771 Discussions

Read only status for MYRIAD configuration on workbench

Benguigui__Michael
1,268 Views

(first post  https://community.intel.com/t5/Intel-Distribution-of-OpenVINO/Read-only-status-for-MYRIAD-configurat... )

 

Hi, I am trying to optimize an imported model for my MYRIAD via OpenVINO workbench.. But I get a the following message:

"Optimize button is not available because the selected project has the Read-Only status."

 

I am using this command to start OpenVINO workbench

 

./start_workbench.sh -IMAGE_NAME openvino/workbench -TAG latest -ENABLE_MYRIAD -DETACHED -ASSETS_DIR /hdd-raid0/openvino_workbench

 

with the following file hierarchy

 

➜ openvino_workbench ls -al /hdd-raid0/openvino_workbench
total 1984
drwxrwxrwx 1 root root 126 mai 19 10:50 .
drwxr-xr-x 1 root root 444 mai 19 01:06 ..
drwxr-xr-x 1 5665 workbench 20 avril 26 14:10 datasets
drwxr-xr-x 1 5665 workbench 164 avril 26 13:43 models
drwx------ 1 5665 workbench 512 mai 19 10:53 postgresql_data_directory
-rw-r--r-- 1 5665 workbench 2009444 mai 19 11:18 server.log
-rw-rw-r-- 1 5665 workbench 64 févr. 16 14:42 token.txt
drwxr-xr-x 1 5665 workbench 0 févr. 16 14:42 users

 

Unplugging/plugging the NCS2 and restarting the workbench docker container does not fix it. I TEMPORARELY solved it by removing all my data (datasets, models, postgresql_data_directory) from my assets dir, and restarting the workbench docker container. But since today, I get the "read only" status in my MYRIAD based configurations again. The 2 steps procedure of "Share Profiling Data on Linux and macOS" is not clear since it recommends to move the asset dir to another machine (without the datasets and models folders). What am I supposed to do with my full local installation?

Labels (2)
0 Kudos
11 Replies
artyom_tugaryov
Employee
1,233 Views

Hello Michale,

 

Can you describe how you get the Read-Only project? As I understand, you switch off DL Workbench (stop the container) but don't plug off the MYRIAD device, and when you start the DL Workbench again the project is Read-Only. Please correct me if I wrong.

Do you restart DL Workbench with your data on the same machine? Or on another machine with copied data?

 

Benguigui__Michael
1,225 Views

All actions were performed on the same machine... and I can only work on the same machine ("full local installation" as I said). But I already exposed you everything I ve done (understand "Unplugging/plugging" like "pug off then pug on").

Alexander_D_Intel1
1,207 Views

Dear @Benguigui__Michael ,

 

Thank you for your question. Am I right that your workflow is the following:

  1. You start Workbench from scratch (new container) with VPU plugged-in
  2. You create the project, make experiments
  3. You stop the Workbench
  4. You start the Workbench again
  5. You open the project you created before
  6. You see it Read-Only
Benguigui__Michael
1,197 Views

5. -> Not necessarely .. creating a new configuration can lead to this issue.

(thxx)

Alexander_D_Intel1
1,195 Views

Does that mean that once you made 4., the old project (from 2.) is still marked as active, but once you make a new project or 5., your get Read-Only?

 

For the DL Workbench, the usual thing is to have all projects with NCS2 marked as Read-only after 4. If you face another behavior, this might be the problem.

 

Please let us know what you see.

 

Alexander

Benguigui__Michael
1,192 Views

(thx for our discussion).. you mean every time I stop/start the workbench (many situations lead to this: docker daemon crash, server restart,..),  all my existing Myriad based projects will be marked as Read-only (-> with no way to infer) ? Is there a simple solution to tackle this by keeping my imported models/dataset ? Can I only remove the postgresql_data_directory directory before restarting the workbench ?

Alexander_D_Intel1
1,189 Views

@Benguigui__Michael I am saying that it is possible to have such projects become in Read-Only as it depends on such factors as UUID that is assigned to the device or the way DL Workbench recognizes it as a separate, or new, stick. That's why it is quite natural for the DL Workbench then to mark the project where the device is not available as Read-only, right? Unfortunately, there is no way to override this behavior, and forcibly tell DL Workbench to bind old projects with the existing NCS2 device.

 

At the same time, I think that your workaround (removing all the projects and the data) is too radical. You do not need to remove anything imported to the DL Workbench. You just need to create the new project using the existing model (imported before), dataset (imported before) and choose your NCS2 as a device. Then you create the new project and continue your work. The only drawback of this solution is that your historical data (previous performance experiments, accuracy measurements etc.) are not available on the new project, but you can always open it and inspect in the old project. Also, you can always compare the performance of the model by using the corresponding "Compare" button on the projects page. Finally, this way of working is not so radical as your workaround with resetting all the data. Can you confirm that this way is acceptable for your future work?

 

If you want a live chat, let me know.

 

Alexander

Benguigui__Michael
1,155 Views

Sorry but your solution does not work at all. I created a new myriad based configuration, after having  imported a new onnx model and a new dataset, and I still get the same read only warning.

Benguigui__Michael_0-1623073983642.png

 

Syamimi_Intel
Moderator
1,096 Views

Hi Benguigui__Michael,

I am running on the latest OpenVINO which is version 2021.3. unfortunately, I cannot replicate the issue and observe the read-only project error.

Here my suggestion which based on Alexander comment;

 

1.      Install the latest OpenVINO 2021.3

2.      Go to $ /<path_to_installed_package>/deployment_tools/tools/workbench/

3.      Make sure your /hdd-raid0/openvino_workbench have the read-write access

sudo chmod 777 /hdd-raid0/openvino_workbench

4.      $ sudo ./start_workbench.sh -IMAGE_NAME openvino/workbench -TAG latest -ENABLE_MYRIAD -DETACHED -ASSETS_DIR /hdd-raid0/openvino_workbench

5.      Try to upload your Model and Dataset

6.      Select your local workstation as your Target

7.      And change the device to Myriad

 

Once all set, you should be able to click the button “CREATE

 

If this method does not work, perhaps you can try if CPU options work and update us on your results so that we can further access you.

 

 

Regards,

Syamimi

 

Syamimi_Intel
Moderator
1,062 Views

Hi Benguigui__Michael,

This thread will no longer be monitored since we have provided a solution. If you need any additional information from Intel, please submit a new question.



Regards,

Syamimi


Benguigui__Michael
966 Views

With the new 1.0.3537.a422215b dockerized workbench version, and by deleting all the content of my assets dir, it works. Hoping by simply creating a new configuration if the workbench restart will avoid a MYRIAD error. Thanks a lot for the Intel support.

Reply