Community
cancel
Showing results for 
Search instead for 
Did you mean: 
ke__xu
Novice
599 Views

Run OpenVINO demo with GPU failed (ubuntu 16.04 with NVIDIA display card)

Jump to solution

Hello,

I try the demo in ubuntu 16.04, when I run it with CPU, it is OK, with GPU, it failed. 

run : /opt/intel/computer_vision_sdk/deployment_tools/demo$ ./demo_security_barrier_camera.sh -d GPU

OpenCL is installed, when OpenCL is not installed, the log do not show " Intel(R) Core(TM) i7-7700 CPU @ 3.60GHz: invalid device type"

[ INFO ] Loading Vehicle Detection model to the GPU plugin
[ ERROR ] failed to create engine: No OpenCL device found which would match provided configuration:
    Intel(R) Core(TM) i7-7700 CPU @ 3.60GHz: invalid device type
    TITAN Xp: invalid vendor type
    TITAN Xp: invalid vendor type
    Intel(R) Core(TM) i7-7700 CP
Error on or near line 142; exiting with status 1

Log when not install OpenCL:

[ ERROR ] failed to create engine: No OpenCL device found which would match provided configuration:
    TITAN Xp: invalid vendor type
    TITAN Xp: invalid vendor type
Error on or near line 142; exiting with status 1

 

0 Kudos
1 Solution
ke__xu
Novice
599 Views

Hello,

I am afraid that the Intel HD graph is not work, for I use a Nvidia display card as primary device.  

When I use "lspci |grep VGA" to show, but not found any word about "Intel HD" at all.

View solution in original post

5 Replies
ke__xu
Novice
600 Views

Hello,

I am afraid that the Intel HD graph is not work, for I use a Nvidia display card as primary device.  

When I use "lspci |grep VGA" to show, but not found any word about "Intel HD" at all.

View solution in original post

nikos1
Valued Contributor I
599 Views

You should be able to see the Intel HD Graphics 630 GPU too. Sometimes it can be tricky with dual GPU systems like yours. You may have to enable Intel GPU from BIOS and you may also have to connect a monitor to the system DVI/HDMI port (not on the discrete graphics ports).

FWIW I had a similar system and GPU configuration and my Intel HD worked fine when using the same sample with -d GPU.

nikos1
Valued Contributor I
599 Views

BTW there was a similar issue on Windows https://software.intel.com/en-us/forums/computer-vision/topic/785425

ke__xu
Novice
599 Views

Hi Nikos,

  Thanks you very much!

  For current development env is co-used with workmates, he is trying a CUDA program, so I will not do more trying to config this env.

Best Regards,

Ke

 

nikos1
Valued Contributor I
599 Views

Hi Ka,

You are welcome.

BTW I am also doing a lot of CUDA work and OpenCL development and AI work and I have both GPUs happily co-existing in my system. It is possible. You may have to connect one monitor to the discrete GPU and a second monitor to your motherboard. Your HD Graphics 630 GPU is a nice AI accelerator and will run at high framerates with very low CPU load.

Cheers,

Nikos

Reply