Intel® Distribution of OpenVINO™ Toolkit
Community support and discussions about the Intel® Distribution of OpenVINO™ toolkit, OpenCV, and all things computer vision-related on Intel® platforms.
5864 Discussions

Running gstreamer app in OpenVino using Windows subsystem in Linux (WSL2)

nnain1
New Contributor I
541 Views

My system main's OS is  Windows-10 OS and installed WSL2 in subsystem.

Openvino is installed in Linux under WSL2. The reason is dlstreamer-gst is supported only in linux.

When I test the following test app, it works only for fps and display is not working.

If I run app as 

 ./vehicle_pedestrian_tracking.sh person-bicycle-car-detection.mp4 10 CPU fps

I can see the output as
FpsCounter(1sec): total=346.54 fps, number-streams=1, per-stream=346.54 fps
FPSCounter(average): total=340.06 fps, number-streams=1, per-stream=340.06 fps
Got EOS from element "pipeline0".
Execution ended after 0:00:02.456260800
Setting pipeline to NULL ...
Freeing pipeline ...

 

When I run for display, 

./vehicle_pedestrian_tracking.sh person-bicycle-car-detection.mp4 10 CPU dispaly

 

I have error as

ERROR: from element /GstPipeline:pipeline0/GstFPSDisplaySink:fpsdisplaysink0/GstXvImageSink:xvimagesink0: Could not initialise Xv output
Additional debug info:
../sys/xvimage/xvimagesink.c(1778): gst_xv_image_sink_open (): /GstPipeline:pipeline0/GstFPSDisplaySink:fpsdisplaysink0/GstXvImageSink:xvimagesink0:
Could not open display (null)
ERROR: pipeline doesn't want to preroll.
Failed to set pipeline to PAUSED.
Setting pipeline to NULL ...
Freeing pipeline ...

 

Is it display is not available in WSL subsystem?

0 Kudos
5 Replies
nnain1
New Contributor I
511 Views
nnain1
New Contributor I
506 Views

My solution is I can't display but I can save to file as

gst-launch-1.0 filesrc location=video1.avi ! decodebin ! video/x-raw ! queue ! gvadetect model=/home/nyan/intel/dl_streamer/models/intel/vehicle-detection/FP16/model_fp16.xml model-proc=./model_proc/vehicle-detection.json inference-interval=10 threshold=0.6 device=CPU ! queue ! gvafpscounter ! filesink location=output.avi
Wan_Intel
Moderator
497 Views

Hi Nnain1,

Thank you for reaching out to us.


We are investigating this issue and will update you at the earliest.


Regards,

Wan


Wan_Intel
Moderator
478 Views

Hi Nnain1,

Thank you for reaching out to us.

 

I encountered the same error as you did when I tried to generate DISPLAY when executing vehicle_pedestrian_tracking.sh.

 

However, I can generate the DISPLAY when I use MobaXTerm with WSL2 and change the command of xvimagesink to ximagesink in vehicle_pedestrian_tracking.sh.

 

MobaXTerm is available for download on the following page:

https://mobaxterm.mobatek.net/download.html

 

 

Regards,

Wan


Wan_Intel
Moderator
432 Views

Hi Nnain,

 

Based on the development team's response, the error you faced might be due to the x-server issue.

Hence, you can also change the command of xvimagesink to autovideosink in vehicle_pedestrian_tracking.sh

 

On another note, this thread will no longer be monitored since we have provided a solution. 

If you need any additional information from Intel, please submit a new question.

 

 

Regards,

Wan

 

Reply