Intel® Distribution of OpenVINO™ Toolkit
Community support and discussions about the Intel® Distribution of OpenVINO™ toolkit, OpenCV, and all things computer vision-related on Intel® platforms.
5532 Discussions

Specify CPU extension in version 2021.1.110 ?

jobdulo
New Contributor I
279 Views

I am following the instructions at https://github.com/intel-iot-devkit/smart-retail-analytics on how to run the smart retail analytics app. Everything is okay until running Grafana on the browser. On the terminal I am getting the following output and error;

[ ERROR ] Please try to specify cpu extensions library path in command line parameters using -l or --cpu_extension command line argument

I assumed that the CPU extension did not need specification on OpenVINO versions > 2019.

I am using the 2021.1.110 version on WSL Ubuntu Ubuntu 20.04.1 LTS.

What I have tried

I have tried looking for any cpu extension in /opt/intel/openvino_2021.1.110/deployment_tools/inference_engine/lib/intel64 but there is none.

Any help?

0 Kudos
1 Solution
jobdulo
New Contributor I
229 Views

so finally, I decided to change my system and retried the whole set up. I used the following specifications (different from the initial ones);

WSL Ubuntu 18.04

Intel(R) OpenVINO Toolkit version 2020.3.341

Python 3.6.9

And now everything works perfectly.

View solution in original post

5 Replies
Adli
Moderator
261 Views

Hi jobdulo,


Thank you for reaching out to us. Did you get any errors besides the 'specify CPU extensions' error? If possible, could you share the full log error here?


Please share the additional information regarding:

• CPU processor

• Python version


Regards,

Adli


jobdulo
New Contributor I
246 Views

This is the complete log:

[ INFO ] Initializing plugin for CPU device...
[ INFO ] Reading IR...
[ INFO ] Loading IR to the plugin...
/home/cv_admin/smart-retail-analytics/application/inference.py:85: DeprecationWarning: 'layers' property of IENetwork class is deprecated. For iteration over network please use get_ops()/get_ordered_ops() methods from nGraph Python API
[l for l in self.net.layers.keys() if l not in supported_layers]
/home/cv_admin/smart-retail-analytics/application/inference.py:102: DeprecationWarning: 'inputs' property of IENetwork class is deprecated. To access DataPtrs user need to use 'input_data' property of InputInfoPtr objects which can be accessed by 'input_info' property.
self.input_blob = next(iter(self.net.inputs))
[ INFO ] Initializing plugin for CPU device...
[ INFO ] Reading IR...
[ INFO ] Loading IR to the plugin...
[ INFO ] Initializing plugin for CPU device...
[ INFO ] Reading IR...
[ INFO ] Loading IR to the plugin...
[ INFO ] Initializing plugin for CPU device...
[ INFO ] Reading IR...
[ INFO ] Loading IR to the plugin...
[ ERROR ] Following layers are not supported by the plugin for specified device CPU:
Constant_14990, Constant_14988
[ ERROR ] Please try to specify cpu extensions library path in command line parameters using -l or --cpu_extension command line argument

 

Here are the system details;

Python version 3.8.5

Intel(R) Core i7-1065G7 CPU

 

jobdulo
New Contributor I
230 Views

so finally, I decided to change my system and retried the whole set up. I used the following specifications (different from the initial ones);

WSL Ubuntu 18.04

Intel(R) OpenVINO Toolkit version 2020.3.341

Python 3.6.9

And now everything works perfectly.

View solution in original post

Adli
Moderator
220 Views

Hi jobdulo,


This thread will no longer be monitored since this issue has been resolved. If you need any additional information from Intel, please submit a new question.


Regards,

Adli


jobdulo
New Contributor I
217 Views

Thank you for the help!

Reply