Community
cancel
Showing results for 
Search instead for 
Did you mean: 
170 Views

Ubuntu and Debian installations failing

Hi community.

I tried to install this tool on my own but after trying many times with tens of different options, after ready many posts on this forum and other places on the web, I tend to think that I might be doing something wrong, or this doesn't really work :(

 

I first tried on Debian. Not supported. So I found that by placing the /etc/lsb-release file you can trick the installer and make it think that it's Ubuntu. Installation went well, I can get the GUI for the different modules, not a single package seems to be missing and all the commands are working fine.

Except the demo :-/ After trying to install into my home folder, or as root, I keep getting this error:

[ INFO ] Loading model to the device
E: [ncAPI] [    621525] [classification_] ncDeviceOpen:1012	Failed to find booted device after boot
[ ERROR ] Can not init Myriad device: NC_ERROR
Error on or near line 217; exiting with status 1

So I gave up. I removed everything and installed Ubuntu in VirtualBox an retried. Again, installed first as my user, failed to run the demo. Installed as root, failed again. And guess what is the error?

[ INFO ] Loading model to the device
E: [ncAPI] [    153059] [classification_] ncDeviceOpen:1012	Failed to find booted device after boot
[ ERROR ] Can not init Myriad device: NC_ERROR

Interesting. Exact same error.

What am I doing wrong? It seems that, both on Debian and on Ubuntu, when the demo restarts the stick (or reload? Or I don't know what), it doesn't reconnect. Before starting the demo I can see the device connected as a USB device, When the demo removes it, I have to unplug and replug, and it comes back.

 

I followed the steps listed there: https://software.intel.com/en-us/articles/get-started-with-neural-compute-stick and there: https://docs.openvinotoolkit.org/2020.1/_docs_install_guides_installing_openvino_linux.html#install-external-dependencies

Any idea what I am missing? 

Thanks.

0 Kudos
8 Replies
170 Views

I also tried on a VirtualBox Ubuntu VM running on Mac OS and got the exact same error :(

170 Views

Hi Jean-Marc,

Did you configure the USB driver for the NCS?  Run the following commands and try again:

source ~/intel/openvino/bin/setupvars.sh
cd ~/intel/openvino/install_dependencies
./install_NCS_udev_rules.sh

Additionally for Virtualbox, you can check the USB configuration. You must enable a USB 3.0 controller and create USB whitelist filters for the virtual machine. The USB 3.0 feature requires the VirtualBox Extension Pack.

  • Shut down the virtual machine
  • With the virtual machine selected on the VirtualBox Manager:
    • Open Settings -> USB
      • Check “Enable USB Controller”
      • Check “USB 3.0 (xHCI) Controller”
      • Add a new USB filter with Vendor ID: 03e7
        • The other filter fields can be blank.
      • Add a new USB filter with Vendor ID: 040e
        • The other filter fields can be blank.

Please let me know if you have any further questions.

Best regards,

Randall B.

170 Views

Hi Randall,

Thanks for helping here. I already have the VirtualBox Extension Pack and USB 3 installed and activated. I already had the stick filter (03e7). I didn't have 040e and I don't have any USB peripheral reporting under than vendor ID (still, adding it to the configuration just in case).

Here is the output of the commands you proposed. Please not that my installation is in /opt/intel so I adjusted the commands a bit.

jmspaggi@openvino:~$ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 03e7:2485  
Bus 001 Device 002: ID 80ee:0021 VirtualBox USB Tablet
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
jmspaggi@openvino:~$ source ~/intel/openvino/bin/setupvars.sh
bash: /home/jmspaggi/intel/openvino/bin/setupvars.sh: Aucun fichier ou dossier de ce type
jmspaggi@openvino:~$ source /opt/intel/openvino/bin/setupvars.sh
[setupvars.sh] OpenVINO environment initialized
jmspaggi@openvino:~$ cd /opt/intel/openvino/install_dependencies
jmspaggi@openvino:/opt/intel/openvino/install_dependencies$ ./install_NCS_udev_rules.sh 
Updating udev rules...
[sudo] Mot de passe de jmspaggi : 
Udev rules have been successfully installed.

 

And here is the output of the run:

jmspaggi@openvino:/opt/intel/openvino/install_dependencies$ cd /opt/intel/openvino/deployment_tools/model_optimizer/install_prerequisites/
jmspaggi@openvino:/opt/intel/openvino/deployment_tools/model_optimizer/install_prerequisites$ ./install_prerequisites.sh
Atteint :1 http://security.ubuntu.com/ubuntu bionic-security InRelease
Atteint :2 http://ca.archive.ubuntu.com/ubuntu bionic InRelease                  
Atteint :3 http://ca.archive.ubuntu.com/ubuntu bionic-updates InRelease          
Atteint :4 http://ca.archive.ubuntu.com/ubuntu bionic-backports InRelease
Lecture des listes de paquets... Fait                         
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
3 paquets peuvent être mis à jour. Exécutez « apt list --upgradable » pour les voir.
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
libgfortran3 est déjà la version la plus récente (6.5.0-2ubuntu1~18.04).
python3-pip est déjà la version la plus récente (9.0.1-2.3~ubuntu1.18.04.1).
python3-venv est déjà la version la plus récente (3.6.7-1~18.04).
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  efibootmgr fonts-liberation2 fonts-opensymbol gir1.2-gst-plugins-base-1.0 gir1.2-gstreamer-1.0 gir1.2-gudev-1.0 gir1.2-udisks-2.0 grilo-plugins-0.3-base gstreamer1.0-gtk3 libboost-date-time1.65.1
  libboost-filesystem1.65.1 libboost-iostreams1.65.1 libboost-locale1.65.1 libcdr-0.1-1 libclucene-contribs1v5 libclucene-core1v5 libcmis-0.5-5v5 libcolamd2 libdazzle-1.0-0 libe-book-0.1-1
  libedataserverui-1.2-2 libeot0 libepubgen-0.1-1 libetonyek-0.1-1 libevent-2.1-6 libexiv2-14 libfreerdp-client2-2 libfreerdp2-2 libfwup1 libgc1c2 libgee-0.8-2 libgexiv2-2 libgom-1.0-0 libgpgmepp6
  libgpod-common libgpod4 liblangtag-common liblangtag1 liblirc-client0 liblua5.3-0 libmediaart-2.0-0 libmspub-0.1-1 libodfgen-0.1-1 libqqwing2v5 libraw16 librevenge-0.0-0 libsgutils2-2 libssh-4
  libsuitesparseconfig5 libvncclient1 libwinpr2-2 libxapian30 libxmlsec1 libxmlsec1-nss lp-solve media-player-info python3-mako python3-markupsafe syslinux syslinux-common syslinux-legacy
  usb-creator-common
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 3 non mis à jour.
The directory '/home/jmspaggi/.cache/pip/http' or its parent directory is not owned by the current user and the cache has been disabled. Please check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.
The directory '/home/jmspaggi/.cache/pip' or its parent directory is not owned by the current user and caching wheels has been disabled. check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.
Requirement already satisfied: tensorflow<2.0.0,>=1.2.0 in /usr/local/lib/python3.6/dist-packages (from -r /opt/intel/openvino/deployment_tools/model_optimizer/install_prerequisites/../requirements.txt (line 1))
Requirement already satisfied: mxnet<=1.5.1,>=1.0.0 in /usr/local/lib/python3.6/dist-packages (from -r /opt/intel/openvino/deployment_tools/model_optimizer/install_prerequisites/../requirements.txt (line 2))
Requirement already satisfied: networkx>=1.11 in /usr/local/lib/python3.6/dist-packages (from -r /opt/intel/openvino/deployment_tools/model_optimizer/install_prerequisites/../requirements.txt (line 3))
Requirement already satisfied: numpy>=1.12.0 in /usr/local/lib/python3.6/dist-packages (from -r /opt/intel/openvino/deployment_tools/model_optimizer/install_prerequisites/../requirements.txt (line 4))
Requirement already satisfied: protobuf==3.6.1 in /usr/local/lib/python3.6/dist-packages (from -r /opt/intel/openvino/deployment_tools/model_optimizer/install_prerequisites/../requirements.txt (line 5))
Requirement already satisfied: onnx>=1.1.2 in /usr/local/lib/python3.6/dist-packages (from -r /opt/intel/openvino/deployment_tools/model_optimizer/install_prerequisites/../requirements.txt (line 6))
Requirement already satisfied: defusedxml>=0.5.0 in /usr/local/lib/python3.6/dist-packages (from -r /opt/intel/openvino/deployment_tools/model_optimizer/install_prerequisites/../requirements.txt (line 7))
Requirement already satisfied: wrapt>=1.11.1 in /usr/local/lib/python3.6/dist-packages (from tensorflow<2.0.0,>=1.2.0->-r /opt/intel/openvino/deployment_tools/model_optimizer/install_prerequisites/../requirements.txt (line 1))
Requirement already satisfied: astor>=0.6.0 in /usr/local/lib/python3.6/dist-packages (from tensorflow<2.0.0,>=1.2.0->-r /opt/intel/openvino/deployment_tools/model_optimizer/install_prerequisites/../requirements.txt (line 1))
Requirement already satisfied: grpcio>=1.8.6 in /usr/local/lib/python3.6/dist-packages (from tensorflow<2.0.0,>=1.2.0->-r /opt/intel/openvino/deployment_tools/model_optimizer/install_prerequisites/../requirements.txt (line 1))
Requirement already satisfied: keras-preprocessing>=1.0.5 in /usr/local/lib/python3.6/dist-packages (from tensorflow<2.0.0,>=1.2.0->-r /opt/intel/openvino/deployment_tools/model_optimizer/install_prerequisites/../requirements.txt (line 1))
Requirement already satisfied: wheel>=0.26 in /usr/lib/python3/dist-packages (from tensorflow<2.0.0,>=1.2.0->-r /opt/intel/openvino/deployment_tools/model_optimizer/install_prerequisites/../requirements.txt (line 1))
Requirement already satisfied: gast>=0.2.0 in /usr/local/lib/python3.6/dist-packages (from tensorflow<2.0.0,>=1.2.0->-r /opt/intel/openvino/deployment_tools/model_optimizer/install_prerequisites/../requirements.txt (line 1))
Requirement already satisfied: keras-applications>=1.0.6 in /usr/local/lib/python3.6/dist-packages (from tensorflow<2.0.0,>=1.2.0->-r /opt/intel/openvino/deployment_tools/model_optimizer/install_prerequisites/../requirements.txt (line 1))
Requirement already satisfied: absl-py>=0.7.0 in /usr/local/lib/python3.6/dist-packages (from tensorflow<2.0.0,>=1.2.0->-r /opt/intel/openvino/deployment_tools/model_optimizer/install_prerequisites/../requirements.txt (line 1))
Requirement already satisfied: tensorflow-estimator<1.15.0rc0,>=1.14.0rc0 in /usr/local/lib/python3.6/dist-packages (from tensorflow<2.0.0,>=1.2.0->-r /opt/intel/openvino/deployment_tools/model_optimizer/install_prerequisites/../requirements.txt (line 1))
Requirement already satisfied: six>=1.10.0 in /usr/lib/python3/dist-packages (from tensorflow<2.0.0,>=1.2.0->-r /opt/intel/openvino/deployment_tools/model_optimizer/install_prerequisites/../requirements.txt (line 1))
Requirement already satisfied: termcolor>=1.1.0 in /usr/local/lib/python3.6/dist-packages (from tensorflow<2.0.0,>=1.2.0->-r /opt/intel/openvino/deployment_tools/model_optimizer/install_prerequisites/../requirements.txt (line 1))
Requirement already satisfied: tensorboard<1.15.0,>=1.14.0 in /usr/local/lib/python3.6/dist-packages (from tensorflow<2.0.0,>=1.2.0->-r /opt/intel/openvino/deployment_tools/model_optimizer/install_prerequisites/../requirements.txt (line 1))
Requirement already satisfied: google-pasta>=0.1.6 in /usr/local/lib/python3.6/dist-packages (from tensorflow<2.0.0,>=1.2.0->-r /opt/intel/openvino/deployment_tools/model_optimizer/install_prerequisites/../requirements.txt (line 1))
Requirement already satisfied: graphviz<0.9.0,>=0.8.1 in /usr/local/lib/python3.6/dist-packages (from mxnet<=1.5.1,>=1.0.0->-r /opt/intel/openvino/deployment_tools/model_optimizer/install_prerequisites/../requirements.txt (line 2))
Requirement already satisfied: requests<3,>=2.20.0 in /usr/local/lib/python3.6/dist-packages (from mxnet<=1.5.1,>=1.0.0->-r /opt/intel/openvino/deployment_tools/model_optimizer/install_prerequisites/../requirements.txt (line 2))
Requirement already satisfied: decorator>=4.3.0 in /usr/local/lib/python3.6/dist-packages (from networkx>=1.11->-r /opt/intel/openvino/deployment_tools/model_optimizer/install_prerequisites/../requirements.txt (line 3))
Requirement already satisfied: setuptools in /usr/lib/python3/dist-packages (from protobuf==3.6.1->-r /opt/intel/openvino/deployment_tools/model_optimizer/install_prerequisites/../requirements.txt (line 5))
Requirement already satisfied: typing-extensions>=3.6.2.1 in /usr/local/lib/python3.6/dist-packages (from onnx>=1.1.2->-r /opt/intel/openvino/deployment_tools/model_optimizer/install_prerequisites/../requirements.txt (line 6))
Requirement already satisfied: h5py in /usr/local/lib/python3.6/dist-packages (from keras-applications>=1.0.6->tensorflow<2.0.0,>=1.2.0->-r /opt/intel/openvino/deployment_tools/model_optimizer/install_prerequisites/../requirements.txt (line 1))
Requirement already satisfied: markdown>=2.6.8 in /usr/local/lib/python3.6/dist-packages (from tensorboard<1.15.0,>=1.14.0->tensorflow<2.0.0,>=1.2.0->-r /opt/intel/openvino/deployment_tools/model_optimizer/install_prerequisites/../requirements.txt (line 1))
Requirement already satisfied: werkzeug>=0.11.15 in /usr/local/lib/python3.6/dist-packages (from tensorboard<1.15.0,>=1.14.0->tensorflow<2.0.0,>=1.2.0->-r /opt/intel/openvino/deployment_tools/model_optimizer/install_prerequisites/../requirements.txt (line 1))
Requirement already satisfied: urllib3!=1.25.0,!=1.25.1,<1.26,>=1.21.1 in /usr/lib/python3/dist-packages (from requests<3,>=2.20.0->mxnet<=1.5.1,>=1.0.0->-r /opt/intel/openvino/deployment_tools/model_optimizer/install_prerequisites/../requirements.txt (line 2))
Requirement already satisfied: idna<3,>=2.5 in /usr/lib/python3/dist-packages (from requests<3,>=2.20.0->mxnet<=1.5.1,>=1.0.0->-r /opt/intel/openvino/deployment_tools/model_optimizer/install_prerequisites/../requirements.txt (line 2))
Requirement already satisfied: certifi>=2017.4.17 in /usr/lib/python3/dist-packages (from requests<3,>=2.20.0->mxnet<=1.5.1,>=1.0.0->-r /opt/intel/openvino/deployment_tools/model_optimizer/install_prerequisites/../requirements.txt (line 2))
Requirement already satisfied: chardet<4,>=3.0.2 in /usr/lib/python3/dist-packages (from requests<3,>=2.20.0->mxnet<=1.5.1,>=1.0.0->-r /opt/intel/openvino/deployment_tools/model_optimizer/install_prerequisites/../requirements.txt (line 2))
[WARNING] All Model Optimizer dependencies are installed globally.
[WARNING] If you want to keep Model Optimizer in separate sandbox
[WARNING] run install_prerequisites.sh venv {caffe|tf|mxnet|kaldi|onnx}
jmspaggi@openvino:/opt/intel/openvino/deployment_tools/model_optimizer/install_prerequisites$ cd /opt/intel/openvino/deployment_tools/demo
jmspaggi@openvino:/opt/intel/openvino/deployment_tools/demo$ ./demo_squeezenet_download_convert_run.sh -d MYRIAD
target = MYRIAD
target_precision = FP16
[setupvars.sh] OpenVINO environment initialized


###################################################



Downloading the Caffe model and the prototxt
Installing dependencies
Atteint :1 http://ca.archive.ubuntu.com/ubuntu bionic InRelease
Atteint :2 http://security.ubuntu.com/ubuntu bionic-security InRelease                          
Atteint :3 http://ca.archive.ubuntu.com/ubuntu bionic-updates InRelease                         
Atteint :4 http://ca.archive.ubuntu.com/ubuntu bionic-backports InRelease
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
3 paquets peuvent être mis à jour. Exécutez « apt list --upgradable » pour les voir.
Run sudo -E apt -y install build-essential python3-pip virtualenv cmake libcairo2-dev libpango1.0-dev libglib2.0-dev libgtk2.0-dev libswscale-dev libavcodec-dev libavformat-dev libgstreamer1.0-0 gstreamer1.0-plugins-base

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
build-essential est déjà la version la plus récente (12.4ubuntu1).
libgtk2.0-dev est déjà la version la plus récente (2.24.32-1ubuntu1).
virtualenv est déjà la version la plus récente (15.1.0+ds-1.1).
cmake est déjà la version la plus récente (3.10.2-1ubuntu2.18.04.1).
gstreamer1.0-plugins-base est déjà la version la plus récente (1.14.5-0ubuntu1~18.04.1).
libcairo2-dev est déjà la version la plus récente (1.15.10-2ubuntu0.1).
libglib2.0-dev est déjà la version la plus récente (2.56.4-0ubuntu0.18.04.6).
libgstreamer1.0-0 est déjà la version la plus récente (1.14.5-0ubuntu1~18.04.1).
libpango1.0-dev est déjà la version la plus récente (1.40.14-1ubuntu0.1).
libavcodec-dev est déjà la version la plus récente (7:3.4.6-0ubuntu0.18.04.1).
libavformat-dev est déjà la version la plus récente (7:3.4.6-0ubuntu0.18.04.1).
libswscale-dev est déjà la version la plus récente (7:3.4.6-0ubuntu0.18.04.1).
python3-pip est déjà la version la plus récente (9.0.1-2.3~ubuntu1.18.04.1).
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  efibootmgr fonts-liberation2 fonts-opensymbol gir1.2-gst-plugins-base-1.0 gir1.2-gstreamer-1.0 gir1.2-gudev-1.0 gir1.2-udisks-2.0 grilo-plugins-0.3-base gstreamer1.0-gtk3 libboost-date-time1.65.1
  libboost-filesystem1.65.1 libboost-iostreams1.65.1 libboost-locale1.65.1 libcdr-0.1-1 libclucene-contribs1v5 libclucene-core1v5 libcmis-0.5-5v5 libcolamd2 libdazzle-1.0-0 libe-book-0.1-1
  libedataserverui-1.2-2 libeot0 libepubgen-0.1-1 libetonyek-0.1-1 libevent-2.1-6 libexiv2-14 libfreerdp-client2-2 libfreerdp2-2 libfwup1 libgc1c2 libgee-0.8-2 libgexiv2-2 libgom-1.0-0 libgpgmepp6
  libgpod-common libgpod4 liblangtag-common liblangtag1 liblirc-client0 liblua5.3-0 libmediaart-2.0-0 libmspub-0.1-1 libodfgen-0.1-1 libqqwing2v5 libraw16 librevenge-0.0-0 libsgutils2-2 libssh-4
  libsuitesparseconfig5 libvncclient1 libwinpr2-2 libxapian30 libxmlsec1 libxmlsec1-nss lp-solve media-player-info python3-mako python3-markupsafe syslinux syslinux-common syslinux-legacy
  usb-creator-common
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 3 non mis à jour.
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
libpng-dev est déjà la version la plus récente (1.6.34-1ubuntu0.18.04.2).
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  efibootmgr fonts-liberation2 fonts-opensymbol gir1.2-gst-plugins-base-1.0 gir1.2-gstreamer-1.0 gir1.2-gudev-1.0 gir1.2-udisks-2.0 grilo-plugins-0.3-base gstreamer1.0-gtk3 libboost-date-time1.65.1
  libboost-filesystem1.65.1 libboost-iostreams1.65.1 libboost-locale1.65.1 libcdr-0.1-1 libclucene-contribs1v5 libclucene-core1v5 libcmis-0.5-5v5 libcolamd2 libdazzle-1.0-0 libe-book-0.1-1
  libedataserverui-1.2-2 libeot0 libepubgen-0.1-1 libetonyek-0.1-1 libevent-2.1-6 libexiv2-14 libfreerdp-client2-2 libfreerdp2-2 libfwup1 libgc1c2 libgee-0.8-2 libgexiv2-2 libgom-1.0-0 libgpgmepp6
  libgpod-common libgpod4 liblangtag-common liblangtag1 liblirc-client0 liblua5.3-0 libmediaart-2.0-0 libmspub-0.1-1 libodfgen-0.1-1 libqqwing2v5 libraw16 librevenge-0.0-0 libsgutils2-2 libssh-4
  libsuitesparseconfig5 libvncclient1 libwinpr2-2 libxapian30 libxmlsec1 libxmlsec1-nss lp-solve media-player-info python3-mako python3-markupsafe syslinux syslinux-common syslinux-legacy
  usb-creator-common
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 3 non mis à jour.
The directory '/home/jmspaggi/.cache/pip/http' or its parent directory is not owned by the current user and the cache has been disabled. Please check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.
The directory '/home/jmspaggi/.cache/pip' or its parent directory is not owned by the current user and caching wheels has been disabled. check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.
Requirement already satisfied: pyyaml in /usr/lib/python3/dist-packages (from -r /opt/intel/openvino/deployment_tools/demo/../open_model_zoo/tools/downloader/requirements.in (line 1))
Requirement already satisfied: requests in /usr/local/lib/python3.6/dist-packages (from -r /opt/intel/openvino/deployment_tools/demo/../open_model_zoo/tools/downloader/requirements.in (line 2))
Requirement already satisfied: urllib3!=1.25.0,!=1.25.1,<1.26,>=1.21.1 in /usr/lib/python3/dist-packages (from requests->-r /opt/intel/openvino/deployment_tools/demo/../open_model_zoo/tools/downloader/requirements.in (line 2))
Requirement already satisfied: certifi>=2017.4.17 in /usr/lib/python3/dist-packages (from requests->-r /opt/intel/openvino/deployment_tools/demo/../open_model_zoo/tools/downloader/requirements.in (line 2))
Requirement already satisfied: idna<3,>=2.5 in /usr/lib/python3/dist-packages (from requests->-r /opt/intel/openvino/deployment_tools/demo/../open_model_zoo/tools/downloader/requirements.in (line 2))
Requirement already satisfied: chardet<4,>=3.0.2 in /usr/lib/python3/dist-packages (from requests->-r /opt/intel/openvino/deployment_tools/demo/../open_model_zoo/tools/downloader/requirements.in (line 2))
Run python3 /opt/intel/openvino_2020.1.023/deployment_tools/open_model_zoo/tools/downloader/downloader.py --name squeezenet1.1 --output_dir /home/jmspaggi/openvino_models/models --cache_dir /home/jmspaggi/openvino_models/cache

################|| Downloading models ||################

========== Downloading /home/jmspaggi/openvino_models/models/public/squeezenet1.1/squeezenet1.1.prototxt
... 100%, 9 KB, 16863 KB/s, 0 seconds passed

========== Downloading /home/jmspaggi/openvino_models/models/public/squeezenet1.1/squeezenet1.1.caffemodel
... 100%, 4834 KB, 8608 KB/s, 0 seconds passed

################|| Post-processing ||################

========== Replacing text in /home/jmspaggi/openvino_models/models/public/squeezenet1.1/squeezenet1.1.prototxt


###################################################

Install Model Optimizer dependencies

Atteint :1 http://ca.archive.ubuntu.com/ubuntu bionic InRelease
Atteint :2 http://ca.archive.ubuntu.com/ubuntu bionic-updates InRelease                         
Atteint :3 http://ca.archive.ubuntu.com/ubuntu bionic-backports InRelease                       
Atteint :4 http://security.ubuntu.com/ubuntu bionic-security InRelease
Lecture des listes de paquets... Fait                         
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
3 paquets peuvent être mis à jour. Exécutez « apt list --upgradable » pour les voir.
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
libgfortran3 est déjà la version la plus récente (6.5.0-2ubuntu1~18.04).
python3-pip est déjà la version la plus récente (9.0.1-2.3~ubuntu1.18.04.1).
python3-venv est déjà la version la plus récente (3.6.7-1~18.04).
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  efibootmgr fonts-liberation2 fonts-opensymbol gir1.2-gst-plugins-base-1.0 gir1.2-gstreamer-1.0 gir1.2-gudev-1.0 gir1.2-udisks-2.0 grilo-plugins-0.3-base gstreamer1.0-gtk3 libboost-date-time1.65.1
  libboost-filesystem1.65.1 libboost-iostreams1.65.1 libboost-locale1.65.1 libcdr-0.1-1 libclucene-contribs1v5 libclucene-core1v5 libcmis-0.5-5v5 libcolamd2 libdazzle-1.0-0 libe-book-0.1-1
  libedataserverui-1.2-2 libeot0 libepubgen-0.1-1 libetonyek-0.1-1 libevent-2.1-6 libexiv2-14 libfreerdp-client2-2 libfreerdp2-2 libfwup1 libgc1c2 libgee-0.8-2 libgexiv2-2 libgom-1.0-0 libgpgmepp6
  libgpod-common libgpod4 liblangtag-common liblangtag1 liblirc-client0 liblua5.3-0 libmediaart-2.0-0 libmspub-0.1-1 libodfgen-0.1-1 libqqwing2v5 libraw16 librevenge-0.0-0 libsgutils2-2 libssh-4
  libsuitesparseconfig5 libvncclient1 libwinpr2-2 libxapian30 libxmlsec1 libxmlsec1-nss lp-solve media-player-info python3-mako python3-markupsafe syslinux syslinux-common syslinux-legacy
  usb-creator-common
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 3 non mis à jour.
The directory '/home/jmspaggi/.cache/pip/http' or its parent directory is not owned by the current user and the cache has been disabled. Please check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.
The directory '/home/jmspaggi/.cache/pip' or its parent directory is not owned by the current user and caching wheels has been disabled. check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.
Requirement already satisfied: networkx>=1.11 in /usr/local/lib/python3.6/dist-packages (from -r /opt/intel/openvino_2020.1.023/deployment_tools/model_optimizer/install_prerequisites/../requirements_caffe.txt (line 1))
Requirement already satisfied: numpy>=1.12.0 in /usr/local/lib/python3.6/dist-packages (from -r /opt/intel/openvino_2020.1.023/deployment_tools/model_optimizer/install_prerequisites/../requirements_caffe.txt (line 2))
Requirement already satisfied: protobuf==3.6.1 in /usr/local/lib/python3.6/dist-packages (from -r /opt/intel/openvino_2020.1.023/deployment_tools/model_optimizer/install_prerequisites/../requirements_caffe.txt (line 3))
Requirement already satisfied: defusedxml>=0.5.0 in /usr/local/lib/python3.6/dist-packages (from -r /opt/intel/openvino_2020.1.023/deployment_tools/model_optimizer/install_prerequisites/../requirements_caffe.txt (line 4))
Requirement already satisfied: decorator>=4.3.0 in /usr/local/lib/python3.6/dist-packages (from networkx>=1.11->-r /opt/intel/openvino_2020.1.023/deployment_tools/model_optimizer/install_prerequisites/../requirements_caffe.txt (line 1))
Requirement already satisfied: setuptools in /usr/lib/python3/dist-packages (from protobuf==3.6.1->-r /opt/intel/openvino_2020.1.023/deployment_tools/model_optimizer/install_prerequisites/../requirements_caffe.txt (line 3))
Requirement already satisfied: six>=1.9 in /usr/lib/python3/dist-packages (from protobuf==3.6.1->-r /opt/intel/openvino_2020.1.023/deployment_tools/model_optimizer/install_prerequisites/../requirements_caffe.txt (line 3))
[WARNING] All Model Optimizer dependencies are installed globally.
[WARNING] If you want to keep Model Optimizer in separate sandbox
[WARNING] run install_prerequisites.sh venv {caffe|tf|mxnet|kaldi|onnx}


###################################################

Convert a model with Model Optimizer

Run python3 /opt/intel/openvino_2020.1.023/deployment_tools/open_model_zoo/tools/downloader/converter.py --mo /opt/intel/openvino_2020.1.023/deployment_tools/model_optimizer/mo.py --name squeezenet1.1 -d /home/jmspaggi/openvino_models/models -o /home/jmspaggi/openvino_models/ir --precisions FP16

========= Converting squeezenet1.1 to IR (FP16)
Conversion command: /usr/bin/python3 -- /opt/intel/openvino_2020.1.023/deployment_tools/model_optimizer/mo.py --framework=caffe --data_type=FP16 --output_dir=/home/jmspaggi/openvino_models/ir/public/squeezenet1.1/FP16 --model_name=squeezenet1.1 '--input_shape=[1,3,227,227]' --input=data '--mean_values=data[104.0,117.0,123.0]' --output=prob --input_model=/home/jmspaggi/openvino_models/models/public/squeezenet1.1/squeezenet1.1.caffemodel --input_proto=/home/jmspaggi/openvino_models/models/public/squeezenet1.1/squeezenet1.1.prototxt

Model Optimizer arguments:
Common parameters:
	- Path to the Input Model: 	/home/jmspaggi/openvino_models/models/public/squeezenet1.1/squeezenet1.1.caffemodel
	- Path for generated IR: 	/home/jmspaggi/openvino_models/ir/public/squeezenet1.1/FP16
	- IR output name: 	squeezenet1.1
	- Log level: 	ERROR
	- Batch: 	Not specified, inherited from the model
	- Input layers: 	data
	- Output layers: 	prob
	- Input shapes: 	[1,3,227,227]
	- Mean values: 	data[104.0,117.0,123.0]
	- Scale values: 	Not specified
	- Scale factor: 	Not specified
	- Precision of IR: 	FP16
	- Enable fusing: 	True
	- Enable grouped convolutions fusing: 	True
	- Move mean values to preprocess section: 	False
	- Reverse input channels: 	False
Caffe specific parameters:
	- Path to Python Caffe* parser generated from caffe.proto: 	/opt/intel/openvino_2020.1.023/deployment_tools/model_optimizer/mo/front/caffe/proto
	- Enable resnet optimization: 	True
	- Path to the Input prototxt: 	/home/jmspaggi/openvino_models/models/public/squeezenet1.1/squeezenet1.1.prototxt
	- Path to CustomLayersMapping.xml: 	Default
	- Path to a mean file: 	Not specified
	- Offsets for a mean file: 	Not specified
Model Optimizer version: 	2020.1.0-61-gd349c3ba4a
[ WARNING ]  
Detected not satisfied dependencies:
	protobuf: installed: 3.0.0, required: == 3.6.1

Please install required versions of components or use install_prerequisites script
/opt/intel/openvino_2020.1.023/deployment_tools/model_optimizer/install_prerequisites/install_prerequisites_caffe.sh
Note that install_prerequisites scripts may install additional components.

[ SUCCESS ] Generated IR version 10 model.
[ SUCCESS ] XML file: /home/jmspaggi/openvino_models/ir/public/squeezenet1.1/FP16/squeezenet1.1.xml
[ SUCCESS ] BIN file: /home/jmspaggi/openvino_models/ir/public/squeezenet1.1/FP16/squeezenet1.1.bin
[ SUCCESS ] Total execution time: 4.35 seconds. 
[ SUCCESS ] Memory consumed: 83 MB. 



###################################################

Build Inference Engine samples

-- The C compiler identification is GNU 7.5.0
-- The CXX compiler identification is GNU 7.5.0
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Looking for C++ include unistd.h
-- Looking for C++ include unistd.h - found
-- Looking for C++ include stdint.h
-- Looking for C++ include stdint.h - found
-- Looking for C++ include sys/types.h
-- Looking for C++ include sys/types.h - found
-- Looking for C++ include fnmatch.h
-- Looking for C++ include fnmatch.h - found
-- Looking for strtoll
-- Looking for strtoll - found
-- Found InferenceEngine: /opt/intel/openvino_2020.1.023/deployment_tools/inference_engine/lib/intel64/libinference_engine.so (Required is at least version "2.1") 
-- Configuring done
-- Generating done
-- Build files have been written to: /home/jmspaggi/inference_engine_samples_build
Scanning dependencies of target format_reader
Scanning dependencies of target gflags_nothreads_static
[  9%] Building CXX object thirdparty/gflags/CMakeFiles/gflags_nothreads_static.dir/src/gflags_completions.cc.o
[ 18%] Building CXX object thirdparty/gflags/CMakeFiles/gflags_nothreads_static.dir/src/gflags.cc.o
[ 27%] Building CXX object thirdparty/gflags/CMakeFiles/gflags_nothreads_static.dir/src/gflags_reporting.cc.o
[ 36%] Building CXX object common/format_reader/CMakeFiles/format_reader.dir/opencv_wraper.cpp.o
[ 45%] Building CXX object common/format_reader/CMakeFiles/format_reader.dir/MnistUbyte.cpp.o
[ 54%] Building CXX object common/format_reader/CMakeFiles/format_reader.dir/format_reader.cpp.o
[ 63%] Building CXX object common/format_reader/CMakeFiles/format_reader.dir/bmp.cpp.o
[ 72%] Linking CXX shared library ../../intel64/Release/lib/libformat_reader.so
[ 72%] Built target format_reader
[ 81%] Linking CXX static library ../../intel64/Release/lib/libgflags_nothreads.a
[ 81%] Built target gflags_nothreads_static
Scanning dependencies of target classification_sample_async
[ 90%] Building CXX object classification_sample_async/CMakeFiles/classification_sample_async.dir/main.cpp.o
[100%] Linking CXX executable ../intel64/Release/classification_sample_async
[100%] Built target classification_sample_async


###################################################

Run Inference Engine classification sample

Run ./classification_sample_async -d MYRIAD -i /opt/intel/openvino/deployment_tools/demo/car.png -m /home/jmspaggi/openvino_models/ir/public/squeezenet1.1/FP16/squeezenet1.1.xml

[ INFO ] InferenceEngine: 
	API version ............ 2.1
	Build .................. 37988
	Description ....... API
[ INFO ] Parsing input parameters
[ INFO ] Parsing input parameters
[ INFO ] Files were added: 1
[ INFO ]     /opt/intel/openvino/deployment_tools/demo/car.png
[ INFO ] Creating Inference Engine
	MYRIAD
	myriadPlugin version ......... 2.1
	Build ........... 37988

[ INFO ] Loading network files
[ INFO ] Preparing input blobs
[ WARNING ] Image is resized from (787, 259) to (227, 227)
[ INFO ] Batch size is 1
[ INFO ] Loading model to the device
E: [ncAPI] [    520121] [classification_] ncDeviceOpen:1012	Failed to find booted device after boot
[ ERROR ] Can not init Myriad device: NC_ERROR
Error on or near line 217; exiting with status 1

 

I'm still getting this same error what ever I do. On Debian, Ubuntu (Debian VirtualBox), Ubuntu (MacOS VirtualBox). 

Any idea what I can try next?

Thanks,

JMS

Carrere__Maxime
Beginner
170 Views

Hi,

I have the same error (NC_ERROR with ncDeviceOpen:1012) on an ubuntu 16.04 running in a docker container.

The same code works fine directly on the machine (raspberry 4, raspbian) hosting the container, so it may be a problem linked to the usb with containerisation/virtualisation ?

I tried some solutions found in others posts (verifying usb rules, with or without docker privileged and mounting /dev) without success.

Thanks,

Maxime

170 Views

At least on my side it's consistent ;) I get the exact same issue on the host machine (Debian) 

 

I might have access to another laptop this week-end. I will install Ubuntu 18 on it and try again, but it will be far from practical :-/

Sahira_Intel
Moderator
170 Views

Hi JMS,

Just a clarification - are you getting the same errors on your host machine running a supported OS? Or are you only getting the errors when you run a virtual machine. 

Can you please provide system specifications for your host machine so I can try to reproduce? Also, are you using a powered USB hub or plugging directly into your system?

Best Regards,

Sahira 

170 Views

Hi Sahira,

Here are the details of my tries:

Ubuntu 18.04.4 LTS on Lenovo T430s direct USB plug (Supported) => Works well (So I know issue is not the stick), but not on all the USB ports.

Debian 10.3 on Lenovo T460s direct USB plug (Not supported) => Installation went well, NC_ERROR error.

Ubuntu 18.04.4 LTS on VirtualBox on Debian 10.3 on Lenovo T460s direct USB plug (Supported) => Installation went well, NC_ERROR error.

Ubuntu 18.04.4 LTS on VirtualBox on Mac OS 10.15.1 plugged on powered USB (Cause only have USB C) (Supported?) => Installation went well, NC_ERROR error.

What I would really love to see working is anything on the T460s which is my prime workstation. Any way I can troubleshoot a bit more to figure what is causing the issue?

Thanks.

 

170 Views

Just to be sure, I tried on the Mac with a USB adaptor (Not through the powered hub) and I get the exact same error. :(