Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Novice
1,768 Views

Visual Studio 15 2017 could not find any instance of Visual Studio (demo_squeezenet_download_convert_run.bat

Jump to solution

I'm using Windows 10  and OpenVINO 2019 R3.1 with Processor Intel Core i7-6500U CPU 64-bit Operating System.   When I ran "demo_squeezenet_download_convert_run.bat"  and got the error message

"CMake Error at CMakeLists.txt:7 (project):

 Generator

    Visual Studio 15 2017

  could not find any instance of Visual Studio.

-- Configuring incomplete, errors occurred!"

I also attached demo_squeezenet_download_convert_run status file, CMakeOutput.log, About Visual Studio 15 2017 screenshot and the set path file.

Please advise.  Thanks.

0 Kudos

Accepted Solutions
Highlighted
Moderator
1,768 Views

Hi Law, Alice,

Thanks for reaching out. Make sure you have ran the setupvars.bat under "C:\Program Files (x86)\IntelSWTools\openvino\bin" prior to running the demo script.

If the problem persists, based on About VisualStudio.JPG looks like your Visual Studio* may be missing some install components. Make sure you have the Desktop development with C++ and MS Build (as seen in my screenshot) installed. You can do this by running the Visual Studio Installer app, although I did this with MVS 2019 it should be something similar in v2017. Once that has been done, re-run the setupvars.bat and proceed to run the demo.

Let me know if the issue persists, I am hoping this resolves your issue.

Regards,

Luis

View solution in original post

0 Kudos
2 Replies
Highlighted
Moderator
1,769 Views

Hi Law, Alice,

Thanks for reaching out. Make sure you have ran the setupvars.bat under "C:\Program Files (x86)\IntelSWTools\openvino\bin" prior to running the demo script.

If the problem persists, based on About VisualStudio.JPG looks like your Visual Studio* may be missing some install components. Make sure you have the Desktop development with C++ and MS Build (as seen in my screenshot) installed. You can do this by running the Visual Studio Installer app, although I did this with MVS 2019 it should be something similar in v2017. Once that has been done, re-run the setupvars.bat and proceed to run the demo.

Let me know if the issue persists, I am hoping this resolves your issue.

Regards,

Luis

View solution in original post

0 Kudos
Highlighted
Novice
1,768 Views

Thanks Luis.

After installed the Desktop development with C++ and MS Build, both demos are working.

0 Kudos