Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
165 Views

Windows10 [ERROR] Can not init Myriad device: NC_ERROR

I have seen several posts here with similar problem but none of them describes exactly my situation.

Environment:

  • Windows 10
  • OpenVINO toolkit 2020.1 (the same is for 2019.3)
  • INCS2

So, I am using INCS 2 on pure Windows 10 without any virtualization. I am testing my models using provided sample object_detection_demo_ssd_async.exe. Usually it works as expected, but sometimes device falls into condition when Windows stops to recognize it. If I reconnect device to the system it is shown in Device Manager as Movidius MyriadX. Output of demo app is as follows:

InferenceEngine: 00007FF8D48CB740                                                                                                                                                         
[ INFO ] Parsing input parameters                                                                                                                                                         
[ INFO ] Reading input                                                                                                                                                                    
MFX: Can't initialize session
[ INFO ] Loading Inference Engine
[ INFO ] Device info: 
    MYRIAD
    myriadPlugin version ......... 2.1
    Build ........... 37988
[ INFO ] Loading network files
[ INFO ] Batch size is forced to  1.
[ INFO ] Checking that the inputs are as the demo expects
[ INFO ] Checking that the outputs are as the demo expects
[ INFO ] Loading model to the device
<[35mE: [ncAPI] [         0] [] ncDeviceOpen:1012       Failed to find booted device after boot<[0m                                                                                       
[ ERROR ] Can not init Myriad device: NC_ERROR

 

When program starts loading model to teh device this Windows notification appears: The last USB device you connected to the computer malfunctioned and Windows does not recognize it. Recommedation: Try reconnecting the device. If Windows still does not recognize it, your device may not be working properly.

Reconnection of device does not help. I do not know what need to be done to make it wokr properly again. but after some time it works again. Can you please recommend something?

 

0 Kudos
1 Reply
Highlighted
Employee
165 Views

Hi Tkachov,

Thanks for reaching out.

  1. Could you please try testing it on another system with the same OS or with another OS (Ubuntu, MacOS) and see if the issue persists?
  2. While working, how much time do you wait for the error to show up?
  3. You are saying it stops working and after some time it works again, how long do you wait for it to work again? 
  4. Does the error occur while testing one of our models or just with your models?

Regards,

David C.

0 Kudos