Community
cancel
Showing results for 
Search instead for 
Did you mean: 
115 Views

action recognition python sample on Raspberry Pi

Hello.
I am trying to run following demo on Raspberry Pi, using NCS2 stick.

>https://github.com/opencv/open_model_zoo/tree/master/demos/python_demos/action_recognition

On  Raspberry Pi I do not have CPU plugin, so I modified demo.py a bit and invoked it specifying NYRIAD as device.

python3 demo.py \
 --device MYRIAD \
 ...

Then I get the following error.

>Initializing plugin for MYRIAD device...
>Reading IR...
>Loading IR to the plugin...
>Traceback (most recent call last):
>  File "/home/pi/open_model_zoo/demos/python_demos/action_recognition/demo.py", line 105, in <module>
>    sys.exit(main() or 0)
>  File "/home/pi/open_model_zoo/demos/python_demos/action_recognition/demo.py", line 99, in main
>    encoder = IEModel(encoder_xml, encoder_bin, encoder_plugin, num_requests=(3 if args.device == 'MYRIAD' else 1))
>  File "/home/pi/open_model_zoo/demos/python_demos/action_recognition/action_recognition_demo/models.py", line 82, in __init__
>    self.exec_net = self.plugin.load(self.net, num_requests=num_requests)
>  File "ie_api.pyx", line 395, in openvino.inference_engine.ie_api.IEPlugin.load
>  File "ie_api.pyx", line 406, in openvino.inference_engine.ie_api.IEPlugin.load
>RuntimeError: [VPU] Cannot convert layer "420" due to unsupported layer type "GEMM"

I can see plugins have different level of supports for the frameworks and this is the result that MYRIAD plugin is not ready for it?

I can see how to customize plugin node in oPenVIno document, but I am not sure if the above fis the case or how hard it would be make it run on Raspberry Pi.

Any suggestion on my step to be taken next?
 

0 Kudos
5 Replies
Shubha_R_Intel
Employee
115 Views

Dearest Matsuzawa, Takashi,

You should not have to modify the demo.py code. The bug you're experiencing has been fixed in 2019R1.1. Please download the latest OpenVino release and give it another try.

Thanks !

Shubha

115 Views

Hello.
Thank you very much for that info.

>Please download the latest OpenVino release and give it another try.

Unfortunately I am currently trying raspberry pi version of the toolkit.
Which is from below, and I cannot find updated package there.

>https://docs.openvinotoolkit.org/latest/_docs_install_guides_installing_openvino_raspbian.html
>https://download.01.org/opencv/2019/openvinotoolkit/
>l_openvino_toolkit_raspbi_p_2019.1.094.tgz 

Probably no R_1.01 or R_1.1 releases are available to RPi version?

In case it is just copying some updated  files from R1.1 release package of the other targets, I would like to try it.
 

BTW, Looking into following link:

>https://software.intel.com/en-us/openvino-toolkit/choose-download

I only see following target options (no Raspberry pi)

- Windows 
- Linux
- Linux for FPGA
- macOS
 

Shubha_R_Intel
Employee
115 Views

Dear Matsuzawa, Takashi,

I see the latest version of raspberry pi here:

https://download.01.org/opencv/2019/openvinotoolkit/

Which I got from rpi install doc

Are you using that one ?

if you are using the latest and getting this error:

>RuntimeError: [VPU] Cannot convert layer "420" due to unsupported layer type "GEMM"

Then that is a bug.

Let me know,

Thanks,

Shubha

 

115 Views

Hello.
Yes, I think I am using this.

l_openvno_toolkit_raspbi_p_2019.1.094.tgz is the one I have downloaded on 4/12 from there, and the file there today is same file name and  same checksum.

For to be sure, I did run model_downloader/downloader.py so that I should be getting the latest model data.
But the result is the same.

As noted above, I tweaked demo.py so that it only use MYRIAD plugin (no CPU plugin) since it is the only plugin available on RPi.
It might be that some of the layers? supported by CPU plugin not (yet?) supported by MYRIAD plugin..?

Then I am not sure how it hard to for me to further tweak it to run on RPi.
 

Shubha_R_Intel
Employee
115 Views

Dear Matsuzawa, Takashi,

I believe this is a bug. I will file it on your behalf.

Sorry for all the trouble ! Thanks for using OpenVino,

Shubha