Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
56 Views

executing mask_rcnn_inception_v2_coco on Atom x7-E3950 CPU The result is wrong.

OpenVINO2020 (OS: Ubuntu)
When executing mask_rcnn_inception_v2_coco on Atom x7-E3950 CPU
The result is wrong.
You can get the correct result when running on GPU.
In addition, correct results can be obtained by executing the CPU with OpenVINO2019R3.1.

The model before conversion is obtained from the following and IR converted.
https://github.com/tensorflow/models/blob/master/research/object_detection/g3doc/detection_model_zoo...

Is there a bug in the execution of SSE4.2?

Best Regards,

0 Kudos
9 Replies
Highlighted
56 Views

Hi taka,

Can you send the result of lscpu command?

 

 

0 Kudos
Highlighted
Beginner
56 Views

------------------------------------------------------

root@9a8f10b19908:~/omz_demos_build/intel64/Release# ./mask_rcnn_demo -i airliner.jpg -m mask_rcnn_inception_v2_coco.xml -d CPU
InferenceEngine: 0x7fc9d73b2040
[ INFO ] Parsing input parameters
[ INFO ] Files were added: 1
[ INFO ]     airliner.jpg
[ INFO ] Loading Inference Engine
[ INFO ] Device info:
        CPU
        MKLDNNPlugin version ......... 2.1
        Build ........... 37988
[ INFO ] Loading network files
[ INFO ] Preparing input blobs
[ INFO ] Network batch size is 1
[ INFO ] Prepare image airliner.jpg
[ INFO ] Preparing output blobs
[ INFO ] Loading model to the device
[ INFO ] Create infer request
[ INFO ] Setting input data to the blobs
[ INFO ] Start inference
[ INFO ] Processing output blobs
[ INFO ] Detected class 5 with probability 0.998982 from batch 0: [6.77591, 169.218], [425.919, 385.444]
[ INFO ] Image out0.png created!
[ INFO ] Execution successful

-----------------------------------------------------

Attach the execution results of OpenVINO2020 and OpenVINO2019R3.1

I guess the following changes made a bug

---------------2020Release note------------------------------
Backward incompatible changes compared with v.2019 R3.1

CPU extensions library was removed. Extensions were moved into the plugin.
------------------------------------------------------------------

Best Regards,

0 Kudos
Highlighted
56 Views

Hi Taka,

Can you run and provide the output of the below command:

lscpu

 

Regards,

Ram prasad

0 Kudos
Highlighted
Beginner
56 Views

 

This is the result of the lscpu command.

--------------------------------------------------------------

rchitecture:        x86_64
CPU op-mode(s):      32-bit, 64-bit
Byte Order:          Little Endian
CPU(s):              4
On-line CPU(s) list: 0-3
Thread(s) per core:  1
Core(s) per socket:  4
Socket(s):           1
Vendor ID:           GenuineIntel
CPU family:          6
Model:               92
Model name:          Intel(R) Atom(TM) Processor E3950 @ 1.60GHz
Stepping:            10
CPU MHz:             1446.587
CPU max MHz:         1600.0000
CPU min MHz:         800.0000
BogoMIPS:            3187.20
Virtualization:      VT-x
L1d cache:           24K
L1i cache:           32K
L2 cache:            1024K
Flags:               fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx pdpe1gb rdtscp lm constant_tsc art arch_perfmon pebs bts rep_good nopl xtopology tsc_reliable nonstop_tsc cpuid aperfmperf tsc_known_freq pni pclmulqdq dtes64 ds_cpl vmx est tm2 ssse3 sdbg cx16 xtpr pdcm sse4_1 sse4_2 x2apic movbe popcnt tsc_deadline_timer aes xsave rdrand lahf_lm 3dnowprefetch cpuid_fault cat_l2 ssbd ibrs ibpb stibp tpr_shadow vnmi flexpriority ept vpid fsgsbase tsc_adjust smep erms mpx rdt_a rdseed smap clflushopt intel_pt sha_ni xsaveopt xsavec xgetbv1 xsaves dtherm arat pln pts arch_capabilities

--------------------------------------------------------------

Best Regards,

0 Kudos
Highlighted
Beginner
56 Views

hi,  Hemanth

hi, Ram

 

Please tell us the result of this case.

Will it be fixed in the next version?

Best Regards,

0 Kudos
Highlighted
56 Views

Hi Taka,

We are debugging the issue from our end. 

We will update you as soon as possible.

Thanks,

Ram prasad

0 Kudos
Highlighted
56 Views

Hi taka,

Could you please clarify whether IRs which you used for inference in 2020.1 were generated using 2019.3 (IRv6)?

If this is the case, could you please also check whether the fault is visible when you regenerate IRs from original models using 2020.1 release?

0 Kudos
Highlighted
Beginner
56 Views

Hi Hemanth

 

>Could you please clarify whether IRs which you used for inference in 2020.1 were generated using 2019.3 (IRv6)?

>If this is the case, could you please also check whether the fault is visible when you regenerate IRs from original models using 2020.1 release?

Running inference on OpenVINO2020.1

The problem occurs in both "2019.3 (IRv6)" and "2020.1(IRv10)"

 

Best Regards,

 

 

 

0 Kudos
Highlighted
56 Views

Hi taka,

We are working on this issue and will take more time. 

0 Kudos