Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
New Contributor I
229 Views

model optimizer error

Jump to solution

hello,

i trained model in keras,
model has one input and two output
model summary is shown as belowScreenshot from 2020-06-17 20-23-28.png

I have converted h5 to pb by using script available https://software.intel.com/en-us/forums/intel-distribution-of-openvino-toolkit/topic/820599

 

I use following command to convert model 

python mo.py -m /media/prateek/shared_space/Notebooks/abg/helmet_n_vest/person_only_training/model_zero7.58-0.237301.hdf5.pb -o ~/prateek_space/model_files/helmet_n_vest/helmet_classification/2020_06_17/ --input_shape [1,3,224,224] --mean_values "data[85.26366915, 85.26366915, 85.26366915]" --scale_values "data[54.50988375, 55.22559735, 56.1583185]" --reverse_input_channels --output 'helmet/Softmax','vest/Softmax' 
 

Screenshot from 2020-06-17 20-23-46.png

0 Kudos

Accepted Solutions
Highlighted
Moderator
133 Views

Hi Prateek,

First, thank you for your patience while we resolved this.

It looks like the input size should be --input_size[1,224224,3]. You can also specify the batch size by using the parameter "-b" instead of specifying the full input shape.

Also, the name of the input node in the attached model is not "data" but "main_input". 

I hope this is helpful.

Best Regards,

Sahira 

View solution in original post

Tags (1)
0 Kudos
5 Replies
Highlighted
Moderator
229 Views

Hi Prateek,

Can you please share your model (the .pb file)? I'd like to take a look at your model to see if this is a bug. It could also be due to incorrect input sizes. 

If you prefer to privately share your model, please let me know and I will send you a PM.

Sincerely,
Sahira 

0 Kudos
Highlighted
New Contributor I
229 Views

hello sahira,
I would like to share model privately 
please PM me directly

0 Kudos
Highlighted
New Contributor I
178 Views

hello @Sahira_Intel 
any update toward model conversion?

0 Kudos
Highlighted
Moderator
161 Views

Hi Prateek,

This was escalated to Engineering and I have not heard anything yet. 

I will keep you updated, thank you for your patience.

Sincerely,

Sahira 

0 Kudos
Highlighted
Moderator
134 Views

Hi Prateek,

First, thank you for your patience while we resolved this.

It looks like the input size should be --input_size[1,224224,3]. You can also specify the batch size by using the parameter "-b" instead of specifying the full input shape.

Also, the name of the input node in the attached model is not "data" but "main_input". 

I hope this is helpful.

Best Regards,

Sahira 

View solution in original post

Tags (1)
0 Kudos