Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Community Manager
415 Views

mvNCCompile taking too much time to compile a SSD mobilenet pb file using tf-ssd-config file

It always keeps getting stuck after this,

 

 

mvNCCompile v02.00, Copyright @ Intel Corporation 2017

 

final_output_graph.pb

 

2019-03-12 09:04:43.544935: W tensorflow/core/framework/allocator.cc:113] Allocation of 8640000 exceeds 10% of system memory.

 

2019-03-12 09:04:45.343218: W tensorflow/core/framework/allocator.cc:113] Allocation of 8640000 exceeds 10% of system memory.

 

2019-03-12 09:04:47.008148: W tensorflow/core/framework/allocator.cc:113] Allocation of 8640000 exceeds 10% of system memory.

 

2019-03-12 09:04:49.956965: W tensorflow/core/framework/allocator.cc:113] Allocation of 8640000 exceeds 10% of system memory.

 

2019-03-12 09:04:51.681470: W tensorflow/core/framework/allocator.cc:113] Allocation of 8640000 exceeds 10% of system memory.

 

terminate called after throwing an instance of 'std::bad_alloc'

 

what(): std::bad_alloc

 

Aborted

 

 

Download link for the model,

 

drive.google.com/file/d/17HdXplYI6OYINULMBuaYf_aH-ewt9B0c/view?usp=sharing

 

Its config file,

 

drive.google.com/open?id=1w0BEfq0hohJ5I3wxfqYJe9CPyng5cAZI

 

The command I'm using,

 

mvNCCompile -s 12 final_output_graph.pb --tf-ssd-config mymodel.config -o myoutput.graph

 

I've also tried with this,

 

mvNCCompile -s 6 final_output_graph.pb --tf-ssd-config mymodel.config -o myoutput.graph

 

@Tome_at_Intel @Sahira_at_Intel @tf_movidius

 

It would be great if you could help me out with this.
Tags (1)
0 Kudos
7 Replies
Highlighted
Community Manager
17 Views

Hi @shujath

 

Thank you for reaching out! I was able to compile the model you link with the configuration file you provided. I have seen a similar issue when the system does not have enough memory. How much memory does your system have? I am running a virtual machine with 8 GB of memory allocated.

 

The following command took about 1 minute to generate the graph.

 

mvNCCompile -s12 final_output_graph.pb --tf-ssd-config mymodel.config

 

Regards,

 

Jesus
0 Kudos
Highlighted
Community Manager
17 Views

Hi @Jesus_at_Intel ,

 

Thank you for replying, I am using it on Raspberry pi3, with an 8GB SD Card, and Raspbian Stretch and ncsdk2.

 

It is always giving me a bad alloc error, now its giving me a OOM Resource exhausted error.
0 Kudos
Highlighted
Community Manager
17 Views

Hi @shujath

 

The Neural Compute SDK is can be installed in two modes, Full SDK mode and API-only mode. We recomend installing the Full SDK mode on a laptop/desktop to compile the networks and API-only on the Raspberry Pi. However, API-only mode will not allow you to profile, check or compile neural networks. Could you try to install the NCSDK on a laptop/desktop and compile the neural network into a graph and then run the application on the Raspberry Pi?

 

You can find additional information about NCS applications on the Raspberry Pi at the following link:

 

https://movidius.github.io/blog/ncs-apps-on-rpi/

 

Regards,

 

Jesus
0 Kudos
Highlighted
Community Manager
17 Views

HI @Jesus_at_Intel

 

Thank you, I'll look into it. Is there any way to setup NCSDK on Windows 10 without using VirtualBox but by using Hyper-V or setting it up on Windows itself as the host platform?
0 Kudos
Highlighted
Community Manager
17 Views

Hi @shujath

 

The Neural Compute SDK is not supported on Windows. However, there has been discussions by others that have the NCSDK working on windows. Take a look at the following thread:

 

https://ncsforum.movidius.com/discussion/comment/1548/#Comment_1548

 

The other option would be running a VM but that may require Hyper-V as you mentioned.

 

Regards,

 

Jesus
0 Kudos
Highlighted
Community Manager
17 Views

Hi @Jesus_at_Intel

 

Okay, I've got the graph compiled on ubuntu, now I'm facing an issue with returned output result from the graph.

 

I'm getting an array of values, How do I determine the num_detections, detection_scores, detection_boxes from the array?

 

I've tried using this utility wrapper for my ssd mobilenet graph,

 

It keeps giving me 1.0 for its first index and the rest of the values are negative, exponential and float values.

 

It would be great if you could help me out with this.

 

Thank you.

 

Regards,

 

Shujath
0 Kudos
Highlighted
Community Manager
17 Views

Also, @Jesus_at_Intel ,

 

I am getting the exact same plots when i'm plotting the array values for when there is object and when there is none.

 

This is basically a graph of victordibia's handtracking model.
0 Kudos