Community
cancel
Showing results for 
Search instead for 
Did you mean: 
idata
Community Manager
392 Views

ncappzoo: can't compile on a Docker instance of ncsdk

I am running ncsdk in a docker container on a Ubuntu 16.04 based system. After testing that the ncsdk works over the USB connection, I am trying to install and work on an image classifier example as described in: https://movidius.github.io/blog/ncs-image-classifier/

 

After I git cloned the ncappzoo archive into /ncsdk/workspace/, I tied to do a

 

make compile

 

from the /ncsdk/workspace/ncappzoo directory. This fails with the following error message:

 

/usr/local/bin/ncsdk/Controllers/FileIO.py:65: UserWarning: You are using a large type. Consider reducing your data sizes for best performance

 

Blob generated

 

make[2]: Leaving directory '/ncsdk/workspace/ncappzoo/tensorflow/inception_v3'

 

make -C tf_models/. compile

 

make[2]: Entering directory '/ncsdk/workspace/ncappzoo/tensorflow/tf_models'

 

make[2]: *** No rule to make target 'compile'. Stop.

 

make[2]: Leaving directory '/ncsdk/workspace/ncappzoo/tensorflow/tf_models'

 

Makefile:12: recipe for target 'tf_models/.' failed

 

make[1]: *** [tf_models/.] Error 2

 

make[1]: Leaving directory '/ncsdk/workspace/ncappzoo/tensorflow'

 

Makefile:12: recipe for target 'tensorflow/.' failed

 

make: *** [tensorflow/.] Error 2

 

=================================

 

What can I do to make this work? I have tried deleting the entire workspace directory and cloning again from github, but no luck: see the same error again. Have any one of you tried to build ncappzoo on a docker container instance of ncsdk? Is this a supported flow?

0 Kudos
1 Reply
idata
Community Manager
55 Views

@kalyan_s Have you taken a look at https://movidius.github.io/ncsdk/docker.html? Please let me know if this works for you.

Reply