Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Hu__Shuping
Beginner
327 Views

onnx model to IR model successfully, but print error " Layer 149 input port 1 is not connected to any data" when loadNetwork

"model.onnx" can be normally used in onnxruntime, then I use "mo_onnx.py" to transfer onnx model to IR model, and get "model.xml" / "model.bin" / "model.mapping" successfully. 

The error occurs when I'm trying to infer the network in openvino framework, the inputs info and the outputs info can be read successfully, but in "auto executable_network = core.LoadNetwork(network_reader, "CPU");" error " Layer 149 input port 1 is not connected to any data" occurs.

This model is a siamese network wich has 2 inputs and 2 outputs, when we looked into the "model.xml" file,  Layer 149 (id: 68)input port 1 is already connected to Layer 4970(id: 67) ouput port 2, how can I deal with it?

onnx version: 1.6.0

onnxruntime version: 1.1.2

openvino version: 2020.1.023

0 Kudos
10 Replies
feng__shi
Beginner
327 Views

hi.when you convert ONNX model to IR,have you get such problem like this:

Cannot infer shapes or values for node "im_info"

and how to solve it ?

SuryaPSC_Intel
Employee
327 Views

Hi Shuping,

The error might be due to the layer input port being connected to multiple locations. Make sure all the nodes are connected properly. You may use netron to visualize your model.

Best Regards,

Surya

Hu__Shuping
Beginner
327 Views

Hi Surya,

Thansks for your reply

it seems that there has no such probelms.

This network has 2 inputs (denote as z and x). The only special issue in layer n is that the kernel weights in this layer is not allocated in the bin file but allocated dynamically (get the output feature map in layer n-1 of input z as the kernel weights of layer n, get the output feature map in layer n-1 of input x is the input of layer n). Does openvino support this kind of operation? 

Chauhan, Surya Pratap Singh (Intel) wrote:

Hi Shuping,

The error might be due to the layer input port being connected to multiple locations. Make sure all the nodes are connected properly. You may use netron to visualize your model.

Best Regards,

Surya

327 Views

Hi Shuping,

We require more information to analyze the model. The first step is to share your model either here or in a private message. 

Hu__Shuping
Beginner
327 Views

Hi Hemanth,

Thanks for your reply. The attached file includes the onnx model that I need to transfer, and the .xml/.bin file that I transfered using openvino 2020.1.

Hemanth Kumar G. (Intel) wrote:

Hi Shuping,

We require more information to analyze the model. The first step is to share your model either here or in a private message. 

Hu__Shuping
Beginner
327 Views

here is another model(without group conv layer and strange reshape layer) that has a similar problem(in layer name "102"), the.onnx file and .bin file are too large to upload here.

Hemanth Kumar G. (Intel) wrote:

Hi Shuping,

We require more information to analyze the model. The first step is to share your model either here or in a private message. 

Hu__Shuping
Beginner
327 Views

Hi Hemanth,

 

Is there any recent progress on this issue? Looking forward to your reply.

Best regards.

Hemanth Kumar G. (Intel) wrote:

Hi Shuping,

We require more information to analyze the model. The first step is to share your model either here or in a private message. 

yu__jin
Beginner
327 Views

Hi~

I'm trying to infer siamfc as a test of Openvino 2019R3.  I have got the .xml and .bin.

And an error "RuntimeError: Incorrect number of input edges for layer 85".

So it was two inputs that caused this problem?

        <layer id="26" name="85" precision="FP32" type="Convolution">
            <data dilations="1,1" group="1" kernel="6,6" output="1" pads_begin="0,0" pads_end="0,0" strides="1,1"/>
            <input>
                <port id="0">
                    <dim>1</dim>
                    <dim>256</dim>
                    <dim>20</dim>
                    <dim>20</dim>
                </port>
                <port id="1">
                    <dim>1</dim>
                    <dim>256</dim>
                    <dim>6</dim>
                    <dim>6</dim>
                </port>
            </input>
            <output>
                <port id="2">
                    <dim>1</dim>
                    <dim>1</dim>
                    <dim>15</dim>
                    <dim>15</dim>
                </port>
            </output>

Hu__Shuping
Beginner
327 Views

I'm not sure...... I have met the same problem as yours when I used openvino 2019R3 to infer siamfc. When openvino 2020 was used, the error changes to "Layer ** input port 1 is not connected to any data". In my point of view, maybe dynamic kernel weight in this convolution layer caused this problem.

yu, jin wrote:

Hi~

I'm trying to infer siamfc as a test of Openvino 2019R3.  I have got the .xml and .bin.

And an error "RuntimeError: Incorrect number of input edges for layer 85".

So it was two inputs that caused this problem?

        <layer id="26" name="85" precision="FP32" type="Convolution">
            <data dilations="1,1" group="1" kernel="6,6" output="1" pads_begin="0,0" pads_end="0,0" strides="1,1"/>
            <input>
                <port id="0">
                    <dim>1</dim>
                    <dim>256</dim>
                    <dim>20</dim>
                    <dim>20</dim>
                </port>
                <port id="1">
                    <dim>1</dim>
                    <dim>256</dim>
                    <dim>6</dim>
                    <dim>6</dim>
                </port>
            </input>
            <output>
                <port id="2">
                    <dim>1</dim>
                    <dim>1</dim>
                    <dim>15</dim>
                    <dim>15</dim>
                </port>
            </output>

SuryaPSC_Intel
Employee
327 Views

Hi Shuping,

Siamese network is not supported as per onnx supported topologies.

We will inform you in case of any update.

Best Regards,

Surya

Reply