Community
cancel
Showing results for 
Search instead for 
Did you mean: 
ashna_12
Novice
439 Views

/opencv/modules/videoio/src/cap.cpp (563) open VIDEOIO(CV_MJPEG): raised OpenCV exception

Hi,

I'm getting the following error while trying to read a video and pass it to a face detection algorithm. The video is read using cv2.VideoCapture.

 

[ WARN:0] global ../opencv/modules/videoio/src/cap_gstreamer.cpp (480) isPipelinePlaying OpenCV | GStreamer warning: GStreamer: pipeline have not been created
libva info: VA-API version 1.6.0
libva info: va_getDriverName() returns 0
libva info: User requested driver 'iHD'
libva info: Trying to open /opt/intel/mediasdk/lib64/iHD_drv_video.so
libva info: Found init function __vaDriverInit_1_6
libva error: /opt/intel/mediasdk/lib64/iHD_drv_video.so init failed
libva info: va_openDriver() returns 1
MFX: Can't initialize session
Unable to read camera feed
FPS info:
0
2020-08-03 16:18:27.039942: I tensorflow/stream_executor/platform/default/dso_loader.cc:44] Successfully opened dynamic library libcuda.so.1
2020-08-03 16:18:27.041139: E tensorflow/stream_executor/cuda/cuda_driver.cc:318] failed call to cuInit: CUDA_ERROR_UNKNOWN: unknown error
2020-08-03 16:18:27.041168: I tensorflow/stream_executor/cuda/cuda_diagnostics.cc:169] retrieving CUDA diagnostic information for host: g2test-HP-ZBook-15-G2
2020-08-03 16:18:27.041177: I tensorflow/stream_executor/cuda/cuda_diagnostics.cc:176] hostname: g2test-HP-ZBook-15-G2
2020-08-03 16:18:27.041291: I tensorflow/stream_executor/cuda/cuda_diagnostics.cc:200] libcuda reported version is: 440.100.0
2020-08-03 16:18:27.041315: I tensorflow/stream_executor/cuda/cuda_diagnostics.cc:204] kernel reported version is: 440.100.0
2020-08-03 16:18:27.041323: I tensorflow/stream_executor/cuda/cuda_diagnostics.cc:310] kernel version seems to match DSO: 440.100.0
2020-08-03 16:18:27.041511: I tensorflow/core/platform/cpu_feature_guard.cc:142] Your CPU supports instructions that this TensorFlow binary was not compiled to use: SSE4.1 SSE4.2 AVX AVX2 FMA
2020-08-03 16:18:27.064366: I tensorflow/core/platform/profile_utils/cpu_utils.cc:94] CPU Frequency: 2793545000 Hz
2020-08-03 16:18:27.064896: I tensorflow/compiler/xla/service/service.cc:168] XLA service 0x55c33acd9a50 executing computations on platform Host. Devices:
2020-08-03 16:18:27.064923: I tensorflow/compiler/xla/service/service.cc:175] StreamExecutor device (0): Host, Default Version
MFX: Invalid FPS passed to encoder
[ERROR:0] global ../opencv/modules/videoio/src/cap.cpp (563) open VIDEOIO(CV_MJPEG): raised OpenCV exception:

OpenCV(4.4.0-openvino) ../opencv/modules/videoio/src/cap_mjpeg_encoder.cpp:436: error: (-215:Assertion failed) fps >= 1 in function 'open'


[INFO] elapsed time: 7.84
[INFO] approx. FPS: 0.00

 

I'm using openvino 2020.4.

Can someone help me out in solving this.

0 Kudos
2 Replies
Munesh_Intel
Moderator
423 Views

Hi Ashna,


This seems to be an issue with your camera feed. 

I suggest you try changing the webcam index.

Please also test if you can open your camera with other applications.


Regards,

Munesh


Munesh_Intel
Moderator
400 Views

Hi Ashna,


This thread will no longer be monitored since we have provided recommendations. If you need any additional information from Intel, please submit a new question.


Regards,

Munesh


Reply