Community
cancel
Showing results for 
Search instead for 
Did you mean: 
nmam
Novice
404 Views

unable to play video file with openvino_2020.4.287

  • openvino version 2020.4.287
  • Downloaded opencv_videoio_ffmpeg440_64.dll (fciv of 3a46d6356220796e044817ae3a21cc31) using the ffmpeg-download.ps1 script present under the \IntelSWTools\openvino\opencv folder
  • compiled peopledetect.cpp sample. On running a video file I get this:

 

[ERROR:0] global C:\jenkins\workspace\OpenCV\OpenVINO\2020.4\build\windows\opencv\modules\videoio\src\cap.cpp (142) cv::
VideoCapture::open VIDEOIO(CV_IMAGES): raised OpenCV exception:

OpenCV(4.4.0-openvino) C:\jenkins\workspace\OpenCV\OpenVINO\2020.4\build\windows\opencv\modules\videoio\src\cap_images.c
pp:253: error: (-5:Bad argument) CAP_IMAGES: can't find starting number (in the name of file): true in function 'cv::icv
ExtractPattern'

 

  •  changed peopledetect.cpp line 77 to 

 

cap.open(file, cv::CAP_FFMPEG);

 

  •  with the above change I an getting this error:

 

C:\Program Files (x86)\IntelSWTools\openvino\opencv\samples\build>Release\openvino_sample_peopledetect.exe -v f:\tv2.mp4

[ WARN:0] global C:\jenkins\workspace\OpenCV\OpenVINO\2020.4\build\windows\opencv\modules\core\src\utils\samples.cpp (59
) cv::samples::findFile cv::samples::findFile('true') => ''
Can not open video stream: 'true'

 

could you please advise on how to get past this issue ?  This is how I invoke the sample

 

openvino_sample_peopledetect.exe -v f:\tv2.mp4

 

Please do let me know in case you'd want more info form my env.

0 Kudos
4 Replies
IntelSupport
Community Manager
377 Views

Hi Neelabh Mam,


Thanks for reaching out.

We are able to replicate this issue and currently investigating it.


Regards,

Aznie



IntelSupport
Community Manager
362 Views

Hi Neelabh Mam,

 

Since this is OpenCV's sample, it should be invoked differently: openvino_sample_peopledetect.exe -v=f:\tv2.mp4

 

Besides, this is OpenCV's argument parser specific -all parameter should be separated by "=". The README file also suggests a long-form --video=<filename> which should work as well.

I have tested this and it works.

 

Regards,

Aznie

 

nmam
Novice
348 Views

sure, thank you.

IntelSupport
Community Manager
325 Views

Hi Neelabh Mam,


This thread will no longer be monitored since we have provided a solution. If you need any additional information from Intel, please submit a new question.


Regards,

Aznie


Reply