Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
5 Views

Cannot Find libmpifort.a

I have a program that I'm trying to compile which requires a statically linked libmpi (typically libmpi.a).  With the 2019 update 4 version of intel fortran, I cannot find a statically linked libmpi.  The statically linked copy is listed on this page (https://software.intel.com/en-us/mpi-developer-guide-linux-compilers-support) as existing, but it doesn't appear to be installed.

I installed Intel Composer Edition Fortran from http://registrationcenter-download.intel.com/akdlm/irc_nas/tec/15483/parallel_studio_xe_2019_update4_composer_edition_for_fortran.tgz

With a silent.cfg that looks like:

ACCEPT_EULA=accept
CONTINUE_WITH_OPTIONAL_ERROR=yes
PSET_INSTALL_DIR=/opt/intel
CONTINUE_WITH_INSTALLDIR_OVERWRITE=yes
PSET_MODE=install
ACTIVATION_LICENSE_FILE=/tmp/ifort.lic
ACTIVATION_TYPE=license_file
INTEL_SW_IMPROVEMENT_PROGRAM_CONSENT=no
ARCH_SELECTED=ALL
COMPONENTS=;intel-conda-index-tool__x86_64;intel-comp__x86_64;intel-comp-32bit__x86_64;intel-comp-doc__noarch;intel-comp-l-all-common__noarch;intel-comp-l-all-vars__noarch;intel-comp-nomcu-vars__noarch;intel-comp-ps-32bit__x86_64;intel-comp-ps__x86_64;intel-comp-ps-ss__x86_64;intel-comp-ps-ss-bec__x86_64;intel-comp-ps-ss-bec-32bit__x86_64;intel-openmp__x86_64;intel-openmp-32bit__x86_64;intel-openmp-common__noarch;intel-openmp-common-ifort__noarch;intel-openmp-ifort__x86_64;intel-openmp-ifort-32bit__x86_64;intel-tbb-libs-32bit__x86_64;intel-tbb-libs__x86_64;intel-conda-intel-openmp-linux-64-shadow-package__x86_64;intel-conda-intel-openmp-linux-32-shadow-package__x86_64;intel-ifort__x86_64;intel-ifort-32bit__x86_64;intel-ifort-common__noarch;intel-ifort-doc__noarch;intel-mkl-common__noarch;intel-mkl-core-32bit__x86_64;intel-mkl-core__x86_64;intel-mkl-core-rt-32bit__x86_64;intel-mkl-core-rt__x86_64;intel-mkl-doc__noarch;intel-mkl-doc-ps__noarch;intel-mkl-gnu-32bit__x86_64;intel-mkl-gnu__x86_64;intel-mkl-gnu-rt-32bit__x86_64;intel-mkl-gnu-rt__x86_64;intel-mkl-common-ps__noarch;intel-mkl-core-ps-32bit__x86_64;intel-mkl-core-ps__x86_64;intel-conda-mkl-linux-64-shadow-package__x86_64;intel-conda-mkl-linux-32-shadow-package__x86_64;intel-conda-mkl-static-linux-64-shadow-package__x86_64;intel-conda-mkl-static-linux-32-shadow-package__x86_64;intel-conda-mkl-devel-linux-64-shadow-package__x86_64;intel-conda-mkl-devel-linux-32-shadow-package__x86_64;intel-conda-mkl-include-linux-64-shadow-package__x86_64;intel-conda-mkl-include-linux-32-shadow-package__x86_64;intel-mkl-common-f__noarch;intel-mkl-core-f-32bit__x86_64;intel-mkl-core-f__x86_64;intel-mkl-gnu-f-rt-32bit__x86_64;intel-mkl-gnu-f-rt__x86_64;intel-mkl-gnu-f__x86_64;intel-mkl-gnu-f-32bit__x86_64;intel-mkl-f95-common__noarch;intel-mkl-f95-32bit__x86_64;intel-mkl-f__x86_64;intel-conda-tbb-linux-64-shadow-package__x86_64;intel-conda-tbb-linux-32-shadow-package__x86_64;intel-mpi-rt__x86_64;intel-mpi-doc__x86_64;intel-conda-impi_rt-linux-64-shadow-package__x86_64;intel-gdb__x86_64;intel-gdb-common__noarch;intel-gdb-common-ps__noarch;intel-fcompxe__noarch;intel-psxe-common__noarch;intel-psxe-doc__noarch;intel-psxe-common-doc__noarch;intel-compxe-doc__noarch;intel-psxe-licensing__noarch;intel-psxe-licensing-doc__noarch;intel-icsxe-pset
 

0 Kudos
4 Replies
Highlighted
5 Views

Related to this problem, I

Related to this problem, I just tried to download the MPI library directly, and I get HTTP 404 errors for the MPI library at this link: http://registrationcenter-download.intel.com/akdlm/irc_nas/tec/15553/l_mpi_2019.4.243.tgz

Has anyone else had success with the MPI libraries for the 2019.4 version of Intel Composer Edition Fortran?

0 Kudos
Highlighted
Moderator
5 Views

Quote:Denney, William wrote:

Denney, William wrote:

Related to this problem, I just tried to download the MPI library directly, and I get HTTP 404 errors for the MPI library at this link: http://registrationcenter-download.intel.com/akdlm/irc_nas/tec/15553/l_m...

Has anyone else had success with the MPI libraries for the 2019.4 version of Intel Composer Edition Fortran?

The link is working. Could you please try again? 

Devorah - Intel® Developer Support
0 Kudos
Highlighted
5 Views

The link wasn't working

The link wasn't working yesterday, but it is working today.

Also, the issue with missing libmpifort.a appears to have been in version 2019.4.227 of the MPI installation that occurred with my Fortran compiler installation, but with version 2019.4.243 (i.e. when the MPI library downloaded separately), it appears to be back in the installation.

0 Kudos
Highlighted
5 Views

As I kept working on this,

As I kept working on this, while installing the Fortran compiler then MPI works to get libmpi.a, when I do them in sequence, the installation of MPI breaks the Fortran installation (ifort is no longer in /opt/intel/bin).

0 Kudos