Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Beginner
70 Views

Compiler for 'x64' not installed

I recently installed the version 9.1.029 standard compiler on my Xeon computer with Windows XP x64 and Visual Studio 2005 Standard. When attempting tobuild with an x64 platform selected in the configuration manager, I get the message "Intel Fortran compiler for 'x64' not installed". I am working in the Visual Studio IDE. Visual Basic programs for x64 build fine. On the Options page in VS2005 under Intel Fortran, General, Compiler Selection, there is only a Win32 Target Platform option and Intel Fortran 9.1 [IA32] Selected Compiler option. Under Libraries at the same location, %IFORT_COMPILER91%EM64TLib is included, and under Includes IFORT_COMPILER91%EM64TInclude is present.

Uninstalling and reinstallingIVF twice had no change. This is a reformat and reinstall of Windows XP x64. When I had it all installed the first time I believe I tried this and it worked fine. I might have missed it, but I didn't figure it out from the forum or release notes. Thanks for any help you can offer.

David

0 Kudos
7 Replies
Black Belt
70 Views

You have available a sizeable menu of installation options, if you downloaded the full ifort installer. There is available an installer which contains only the 32-bit compiler. If you want both ifort 32-bit and ifort x64, you must install the Microsoft AMD64 C++ SDK, and install both compilers separately.
0 Kudos
70 Views

A correction to Tim's reply - if you are using VS2005, you do not need the Platform SDK.

You do need to ensure that the compiler for Intel EM64T is installed. An easy way to tell is Start>Programs>Intel Software Development Tools>Intel Fortran Compiler 9.1 and see if a "Build Environment for Fortran EM64T-based Applications" entry appears. If you select that, then you should get a command prompt window with the compiler set up.
0 Kudos
70 Views

Also, try uninstalling and reinstalling the Intel Fortran Integration in Visual Studio component after the compiler is installed.
0 Kudos
Beginner
70 Views

Hello,
I am having an identical problem, except that I have Vista (business edition) 64-bit rather than XP x64. I created a new "x64" platform in the Configuration Manager. But when I try to compile the exe, I get an error dialog saying "Intel Fortran compiler for 'x64' not installed." In the Options dialog in VS2005 under Intel Fortran, General, Compiler Selection, there is only a Win32 target platform available.

I am using version 9.1.037 of the compiler. I uninstalled and then re-installed the complete installation (including the Itanium and EM64T compilers), in order (VS integrations last), with default options. Are their any known issues (and workarounds) for installing on 64-bit Windows? Could the problem have something to do with the fact that the compilers are being installed in the directory structure "Program Files (x86)" rather than just "Program Files"? How do the VS Integrations "know" whether an x64 compiler has been installed or not -- by the environment variables?
Thanks in advance.
0 Kudos
70 Views

The VS integrations know because environment variables have been set appropriately. First, are you running VS2005 using the "Start as administrator" option? What edition of VS2005 do you have? If anything other than Standard Edition, did you do a Custom Install and add the "X64 Compiler and Tools" component? Go to Add/Remove Programs, do a "Change" on VS2005 and make sure that component is selected.

The installation directory you show is correct.
0 Kudos
Beginner
70 Views

Got it. Thanks! Very helpful response. I needed to install the VS2005 X64 Compiler & Tools component.

0 Kudos
Beginner
70 Views

Installing the x64 compiler tools fixed it for me as well .... Chris
0 Kudos