Intel® Fortran Compiler
Build applications that can scale for the future with optimized code designed for Intel® Xeon® and compatible processors.
Announcements
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!
26734 Discussions

Create link in linux (red hat) for abaqus 2018 to run UMAT subroutines

Murillo__Claudia
Beginner
500 Views

Hi, I am on abaqus 2018 in linux red hat and I am trying to create the link with ifort version 16.0.2. I have run the verification, and shows:

Begin Compiling Abaqus/Standard User Subroutines
Wed 12 Dec 2018 12:04:38 PM EST
End Compiling Abaqus/Standard User Subroutines
Begin Linking Abaqus/Standard User Subroutines
gfortran: unrecognized option '-soname,libstandardU.so'
/usr/bin/ld: : No such file: No such file or directory
collect2: ld returned 1 exit status
Abaqus Error: Problem during linking - Abaqus/Standard User Subroutines
Begin MFS->SFS and SIM cleanup
Wed 12 Dec 2018 12:04:38 PM EST
Run SMASimUtility
Wed 12 Dec 2018 12:04:39 PM EST
End MFS->SFS and SIM cleanup
Abaqus/Analysis exited with errors

 I have to make the changes in the .env file in my home directory since this is a university owned computer. Do you have any recommendation on how to do it? Thanks in advance.

0 Kudos
8 Replies
Steve_Lionel
Black Belt Retired Employee
500 Views

Looks to me as if you're using gfortran, not ifort.

Murillo__Claudia
Beginner
500 Views

in the lnx86_64.env in my home directory is defined:

import os, re, glob, driverUtils

# fortCmd = "ifort"   # <-- Fortran compiler
fortCmd = "/usr/local/intel/bin/ifort" # Fortran compiler on blackelk
cppCmd  = "g++"     # <-- C++ compiler
abaHomeInc = os.path.abspath(os.path.join(os.environ.get('ABA_HOME', ''), os.pardir)) # <-- Install include dir

# Avoid signal trapping by the Fortran RTE
os.environ["FOR_IGNORE_EXCEPTIONS"] = "1"
# Disable messages from the Fotran RTE
os.environ["FOR_DISABLE_STACK_TRACE"] = "1"

# Do not let QLogic InfiniPath driver set processor affinity.
os.environ["IPATH_NO_CPUAFFINITY"] = "1"

# Add the flag "-free" to the compile_fortran command below to use free-format FORTRAN 90 syntax.

compile_fortran = [fortCmd,
                   '-V',
                   '-c', '-fPIC', '-auto', '-mP2OPT_hpo_vec_divbyzero=F', '-extend_source',
                   '-fpp', '-WB', '-I%I', '-I'+abaHomeInc, '%P']

 

so I don't know how to fix this...

Juergen_R_R
Valued Contributor I
500 Views

Claudia, the following part that you posted

End Compiling Abaqus/Standard User Subroutines
Begin Linking Abaqus/Standard User Subroutines
gfortran: unrecognized option '-soname,libstandardU.so'

shows that compilation is donw, and the error message happens for the linking. So I would guess compilation is done with ifort, and then gfortran is invoked for linking.

Murillo__Claudia
Beginner
500 Views

the linking part of the lnx86_64.env file is defined as:


link_fmu = [cppCmd,
            '-fPIC', '-shared', '-o', '%J', '%M']

link_sl = [fortCmd,
           '-V',           
           '-cxxlib', '-fPIC', '-threads', '-shared','-Wl,--add-needed',
           '%E', '-Wl,-soname,%U', '-o', '%U', '%F', '%A', '%L', '%B', '-parallel',           
           '-Wl,-Bdynamic', '-shared-intel']

link_exe = [cppCmd,
            '-fPIC',
            '-Wl,-Bdynamic', '-Wl,--add-needed', '-o', '%J', '%F', '%M', '%L', '%B', '%O']

is there something to adjust? I appreciate your help.

Juergen_R_R
Valued Contributor I
500 Views

No way to tell from these excerpts. I don't know this software, I am not even sure what these files are that you posted. Looks like python. There is something screwed up with your environment variables, this

/usr/bin/ld: : No such file: No such file or directory

very fishy. But this all has to do with the setup of your software. Guess you have to ask in their support forum.

Murillo__Claudia
Beginner
500 Views

It is solved! i followed the step 4 of this page and it worked!

http://imechanica.org/node/13804

Thank you so much for the help! :)

Juergen_R_R
Valued Contributor I
500 Views

So what exactly was wrong? What did you change in order to get it run?

Murillo__Claudia
Beginner
500 Views

I am not sure what was wrong... but I wrote in the terminal: export PATH=/path to ifort.var/:$PATH. Then, I ran the verification again and it worked. I guess that command shows the program the right path. But I am just learning this topic, so I can't tell. 

Reply