Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
318 Views

Environmet set up

i want to know the the commands to set up environment in ubuntu 16.04 and 14.04 using intel ifort in bash file.

i am using Intel® Parallel Studio XE Cluster Edition for Linux* 2018 update 2.

with little knowledge and information that i could install it but getting export command nor found. its probably due to environment issues.

the documentation didnt help me

ab
 

0 Kudos
8 Replies
Highlighted
Employee
318 Views

Hello,

Could you please post exact commands you run and exact messages produced?

Thank you,

Eugene

 

0 Kudos
Highlighted
Beginner
318 Views

details of installation......

when installation is successful (as i get message on screen) i type

$ export LD_LIBRARY_PATH=”/opt/intel/2018/lib” 

it says export command not found

in bashfile, (my installation directory is opt/intel/2018) i am giving

source /opt/intel/2018/bin/ifortvars.sh intel64

if there is any other way, pl let me know

earlier while installing ifort for version 16 and 17 cluster version, i followed export LD_LIBRARY_PATH=”/opt/intel/lib” export DYLD_LIBRARY_PATH=”/opt/intel/lib” cd /opt/inte/ export MANPATH=”/opt/intel/man” export PATH=/opt/intel/versao/bin:$PATH then at terminal source .bashrc ifort -v now this approach is not working

ab

0 Kudos
Highlighted
Black Belt Retired Employee
318 Views

You should not be using export. Instead, as the documentation says:

source /opt/intel/bin/ifortvars.sh (or .csh if you are using the C shell.)

0 Kudos
Highlighted
Beginner
318 Views

so u mean

1  i should only write

source /opt/intel/2018/bin/ifortvars.sh intel64

2   type source .bashrc

in terminal of ifort installed

ifort -v    gives me version

3 once this is done should i reboot the system ?

4 i need to use linked static and dynamic libraries. what should i do

5 how do i ensure environment is correctly set up and and static and dynamic files are linked correctly 

in bash file...

0 Kudos
Highlighted
Beginner
318 Views

going further into details ... i have a source code. i could compile it using parallel suite 16/ 17 using ifort. when executed, i could run input file.

but my serial number expired in jan 18 and i downloaded a 2018 parallel suite, update 1. i could compile my codes again but while running the input file i get segmentation fault.

libpthread-2.19.s  00007FEADAA07330  Unknown               Unknown  Unknown

libc-2.19.so       00007FEADA64FF45  __libc_start_main     Unknown  Unknown

i could not understand the issue. I then downloaded version 17, update 1 of intel fortran parallel suite. i could compile the codes but to my surprise i could run the input file. i didnt make any change. i only played with environment commands. now i dont remember what did i do.

then i used 2018 parallel suite version of ifort, version 18.0.1. my input files ran and i got correct answer.

i could only conclude it was due to environment issues/ shared libraries were not linking.

i am now testing on different system but i am getting the same old problem.

i want to undertstand the issue and how to resolve it. for convenience , i have uploaded the make file. it works on it

thanks

ab

 

0 Kudos
Highlighted
Black Belt Retired Employee
318 Views

Rebooting is not necessary. You need to "source" ifortvars in a command session to make ifort available. You might want to put this in a .login script or something similar. I am not a Linux expert, and am not sure what "type source .bashrc" is supposed to do.

The compiler license covers the compiler only, not your executable. No license is required to run the executable.

The choice of static or dynamic libraries is selected with ifort command options. The default is dynamic linking; use -static-intel to link against static libraries.

I can't help regarding the segfault. If you add -traceback to the ifort commands, the traceback may be more informative.

0 Kudos
Highlighted
Beginner
318 Views

I have a bit similar problem in MacOS Catalina (Version 10.15.4). I have installed Xcode (Version 11.4) and Intel® Parallel Studio XE Composer Edition for Fortran macOS* 2020. It was successfully installed. The get started instruction shows 

----------------------------

From a terminal session, run:

source <install_dir>/bin/compilervars.sh intel64
where <install_dir> is the directory structure containing the compiler /bin directory
The default path for <install_dir> is /opt/intel/

----------------------------

I open terminal session, and run 

/bin/compilervars.sh

and it shows "No such file or directory"

What can I do? I never used FORTRAN in Mac. If you can let me know how to install FORTRAN in Mac, I would be really grateful to you.

Thanks a lot.

0 Kudos
Highlighted
Black Belt Retired Employee
318 Views

What can you do? You can do what the document told you to do, which is very different from what you told us you did.

What you want to type is:

source /opt/intel/bin/compilervars.sh intel64

 

0 Kudos