Intel® Fortran Compiler
Build applications that can scale for the future with optimized code designed for Intel® Xeon® and compatible processors.
Announcements
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!
26754 Discussions

Forward-Backward slash mismatch for source path in compiler output.

Andriy_R_
Beginner
127 Views

Hi,

I am using VS2013 update 4.

I noticed this problem as I installed Parallel Studio 2017 update 2 and it persist for update 4.

Compiler output in VS output window prints warnings and errors in source files as usual. But the file paths it provides are messed up with forward slash before the file names.

For example:

My file is located at

d:\tmp\a.f

If there is an error or a warning in the file, VS prints:

D:\tmp/a.f(1850): warning #6717: This name has not been given an explicit type.   [IERR]

When I double click on the message to correct the issue, VS opens another tab for the file even though the file has already been opened in VS with d:\tmp\a.f path. Then, VS complains that the file has been edited outside of the source editor. This is SO frustrating...

0 Kudos
2 Replies
Lorri_M_Intel
Employee
127 Views

Yes, this is a known problem, and has been fixed for Update 5.  It is related to the fpp (Fortran Pre-Processor).  If you do not need preprocessing for that file you can disable it.  

I'm sorry for the inconvenience --

                            --Lorri

Andriy_R_
Beginner
127 Views

Lorri,

Thank you for your reply.

There are too many files in the project and most of them are preprocessed. Will be looking forward for Update 5 for the fix.

Reply