Intel® Fortran Compiler
Build applications that can scale for the future with optimized code designed for Intel® Xeon® and compatible processors.
Announcements
The Intel sign-in experience is changing in February to support enhanced security controls. If you sign in, click here for more information.
27554 Discussions

Ifort error 10417 Problem setting up the Intel(R) Compiler compilation environment

jelopezaguilar
Beginner
596 Views

Hi everyone,

I'm new round here and on the programming world.

Just downloaded and installed the oneAPI package to get ifort compiler.
Have succesfully installed everything and ifort is invoked properly.
Nevertheless, when trying to compile, the following message is displayed:

ifort: error #10417: Problem setting up the Intel(R) Compiler compilation environment. Requires 'install path' setting gathered from 'gcc'

I can not seem to fix the problem on what I find in forums.

Hope you can help me out to sort this out.

I'm using the latest version of Red Hat distribution.

0 Kudos
5 Replies
Ron_Green
Moderator
567 Views

That's odd.  What version of gcc do you have installed, and on what version of RHEL? 

 

Before you run the compiler, you are using bash, correct, and you do this before compiling:

source /opt/intel/oneapi/setvars.sh

 

If you are not using bash as your shell let me know what shell you are using and I'll show you a hack to invoke setvars script from another shell.

 

ron

jelopezaguilar
Beginner
544 Views

Hi Ron,

Thanks very much for your answer.

 

I had already run setvars.sh as you suggested. Tried to force re-execution and got the following message:

 

:: WARNING: setvars.sh has already been run. Skipping re-execution.
To force a re-execution of setvars.sh, use the '--force' option.
Using '--force' can result in excessive use of your environment variables.

usage: source setvars.sh [--force] [--config=file] [--help] [...]
--force Force setvars.sh to re-run, doing so may overload environment.
--config=file Customize env vars using a setvars.sh configuration file.
--help Display this help message and exit.
... Additional args are passed to individual env/vars.sh scripts
and should follow this script's arguments.

Some POSIX shells do not accept command-line options. In that case, you can pass
command-line options via the SETVARS_ARGS environment variable. For example:

$ SETVARS_ARGS="ia32 --config=config.txt" ; export SETVARS_ARGS
$ . path/to/setvars.sh

The SETVARS_ARGS environment variable is cleared on exiting setvars.sh.

 

It seems that although I had already run setvars.sh the compiler wouldn`t recognize its execution.

 

Tried already to reinstall oneapi with the latest version (issued Jan 2022) and the problem persists.

The RHEL I'm using is 8.3 and I'm doing a recommended installation of oneapi taking the compilers it installs automatically, but it seems gcc is not installed in my machine. Is it possible to install gcc independently, without having to get a suscription from Red Hat?

 

This may be only my lack of expertise on this. Thanks in advance for your help.

jelopezaguilar
Beginner
528 Views

Hi Ron,

 

Found out what is the problem: gcc was not installed in my machine. Needed to get a no-cost developer subscription from Red Hat, link my machine to that subscription and install the developer toolset.

 

That solved the problem!

Thanks very much for your help and time!

VBR

 

Esteban

Ron_Green
Moderator
527 Views

too funny, I was JUST posting to get a developer image and you beat me to the solution!

Glad it's working now!

 

ron

Ron_Green
Moderator
528 Views

You do need gcc and bintutils to run Intel Fortran. 

Typically linux distros have "Developer" images.  Server images may not have all the developer tools needed.  "Developer" versions of distros will have gcc, binutils, cmake, python, and other tools typically needed by code developers.

 

RHEL does typically require a subscription to use their package manager repos for DNF/Yum.  There may be ways to use other repos but I don't know how to do this.  

If you are flexible on reinstalling a full Linux OS you could consider installing CentOS, Rocky Linux, or Fedora.  Or of course Ubuntu.   You will want to install gcc, binutils packages OR just install a "Developer" version of the OS. 

 

 

Reply